Closed Bug 1425261 Opened 2 years ago Closed 2 years ago

On cdw.com the autofill doesn't fill in the displayed fields

Categories

(Toolkit :: Form Autofill, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Ovidiu, Assigned: selee)

References

(Blocks 1 open bug)

Details

(Whiteboard: [form autofill:V2][Misc.])

Attachments

(1 obsolete file)

[Affected versions]:

Tested on Nightly 59.0a1(2017-12-14)

[Affected platforms]:

Tested on Mac 10.12

[Steps to reproduce]:

Prerequisites:
 1. Make sure you have at least two saved profiles.

 
1. Go to www.cdw.com
2. Log in to your account -> Profile and Preferences -> Billing - Address, SAved Payment Methods and Restrictions 
3. Click on the fields and from the suggestions that are displayed pick one.


[Expected result]:

All the fields are filled in with your profile suggestions.  

[Actual result]:

Only one field is auto-filled with your suggestions. 

Note: Please see the video for a better understanding.https://streamable.com/g870y
Whiteboard: [form autofill: V2]
This issue is caused by the incorrect detection of `address-line2`. The regexp of address-line* should be able to recognize the correct address lines.
See Also: → 1423204
Whiteboard: [form autofill: V2] → [form autofill:V2][Misc.]
Assignee: nobody → selee
Status: NEW → ASSIGNED
Attachment #8940497 - Attachment is obsolete: true
Attachment #8940497 - Flags: review?(lchang)
The patch attachment 8940498 [details] in bug 1423204 can fix the heuristics issue in this bug, but another issue is about previewing and filling. I have to look why not all fields can be previewed or filled.
The preview and filling issue in Profile and Preferences are caused by the inputs with the value as its placeholder, and previewing or filling feature will skip the inputs with `element.value`.

BTW, Chrome gets worse experience since the placeholder won't be clear when I click on an input.
Per comment 4, this bug is caused because the website falsely uses `element.value` as placeholders. Since Form Autofill by design won't fill any input containing a value already, this bug can't be fixed eventually. Therefore, close this bug as WONTFIX.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.