Update Fluent in Gecko to 0.6

RESOLVED FIXED in Firefox 59

Status

()

defect
P3
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: zbraniecki, Assigned: zbraniecki)

Tracking

unspecified
mozilla60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 wontfix, firefox59+ fixed, firefox60+ fixed)

Details

Attachments

(2 attachments)

This bug is about updating Fluent in Gecko to 0.5.
Blocks: 1426053
Priority: -- → P3
No longer blocks: 1415730
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
This is a patch against fluent.js rev 5e12a17. It Fluent 0.5 syntax into Gecko. Seems to work quite well :)
Attachment #8945911 - Flags: review?(stas)
Comment on attachment 8945911 [details]
Bug 1426054 - Update Fluent in Gecko to 0.6.

r? -> Pike because :stas' laptop doesn't like stas.
Attachment #8945911 - Flags: review?(stas) → review?(l10n)

Comment 4

Last year
mozreview-review
Comment on attachment 8945911 [details]
Bug 1426054 - Update Fluent in Gecko to 0.6.

https://reviewboard.mozilla.org/r/215990/#review222544

This sounds sane, but I'd like to see a couple of updates before we actually land this.

For one, we'll actually need 0.5 or 0.6 in fluent.js.

I'd also like an explicit revision in the commit message that corresponds to the version we're integrating. Even if the version's tagged, I'd still appreciate to see a hash in the commit message.

Also, would it make sense to have a README in intl/l10n on the process to update the code from fluent.js? The base make stuff, but maybe also a comment on what changed compared to fluent-gecko/dist. We could even add a patch for reference, like we do for things like icu?
Attachment #8945911 - Flags: review?(l10n)
Attachment #8945911 - Flags: feedback+
Comment hidden (mozreview-request)
This is a diff between what fluent-gecko produces in revision 24585e6 and what this patch lands in mozilla-central.

I filed bug 1434434 to deal with the artifacts of rollup shortcomings, align linting and add README on how to build Fluent for Gecko.
Attachment #8945911 - Flags: review?(l10n)
Comment hidden (mozreview-request)

Comment 8

Last year
mozreview-review
Comment on attachment 8945911 [details]
Bug 1426054 - Update Fluent in Gecko to 0.6.

https://reviewboard.mozilla.org/r/215990/#review222810
Attachment #8945911 - Flags: review+
Comment hidden (mozreview-request)
Summary: Update Fluent in Gecko to 0.5 → Update Fluent in Gecko to 0.6
Comment hidden (mozreview-request)

Comment 12

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/e7d8e40e140b
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
We'll want to request beta uplift for the following three bugs: bug 1426054, bug 1432229 and bug 1436790.

Reason: all three bugs are required to bring the updated version of new localization API (Fluent) to 0.6. Since we're using cross-channel for localization we'd like to start serializing our l10n to use 0.6 syntax in the localization tool (Pontoon).
Once we do, we'll need the updated parser in 59 to be able to read the output.

I'll request uplift for each patch separately, but placing them on the release mgmt radar together.
Comment on attachment 8945911 [details]
Bug 1426054 - Update Fluent in Gecko to 0.6.

Approval Request Comment
[Feature/Bug causing the regression]: none
[User impact if declined]: none, but complications in our build system which may indirectly lead to us not having a good way to uplift strings to 59.
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: bug 1436790 and bug 1432229
[Is the change risky?]: no
[Why is the change risky/not risky?]: this is at most affecting 5 strings in preferences and they all work in Nightly for a while now.
[String changes made/needed]: none
Attachment #8945911 - Flags: approval-mozilla-beta?
Comment on attachment 8945911 [details]
Bug 1426054 - Update Fluent in Gecko to 0.6.

Should help with l10n/string uplifts to beta. Let's land this for beta 10.
Attachment #8945911 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.