Land compare-locales 2.7 in mozilla-central

RESOLVED FIXED in Firefox 59

Status

()

P3
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Pike, Assigned: Pike)

Tracking

unspecified
mozilla60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59+ fixed, firefox60 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
Once we have the new version of compare-locales, we'll need to land that and python-fluent 0.6 in-tree to be used by bug 1424682.

Heads up, we'd like to uplift this to 59 for cross-channel support.
Priority: -- → P3
(Assignee)

Comment 1

a year ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7689b34d68c2f4188fd3dbf9f63ecbd4c35ba621&selectedJob=160912351 is on its way through try.

It'd be nice to get some feedback on how that tree's doing with migrations etc.
> Tt'd be nice to get some feedback on how that tree's doing with migrations etc.

Tested the patch against migrations from bug 1424682 and it all works flawlessly.
Comment hidden (mozreview-request)

Comment 4

a year ago
mozreview-review
Comment on attachment 8949229 [details]
bug 1432229, land compare-locales 2.7 and python-fluent 0.6.2,

https://reviewboard.mozilla.org/r/218602/#review224410

lgtm!
Attachment #8949229 - Flags: review?(gandalf) → review+
Assignee: nobody → l10n
Comment hidden (mozreview-request)
(Assignee)

Comment 6

a year ago
In the testing of python-fluent on our existing fluent projects, we discovered a bug that's fixed in fluent 0.6.2.

This passed on try in https://treeherder.mozilla.org/#/jobs?repo=try&revision=ec03ed3651e261e62a75cbf904a8ff293c8c8cd3.

Comment 7

a year ago
Pushed by axel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b6604798c16d
land compare-locales 2.7 and python-fluent 0.6.2, r=gandalf
We'll want to request beta uplift for the following three bugs: bug 1426054, bug 1432229 and bug 1436790.

Reason: all three bugs are required to bring the updated version of new localization API (Fluent) to 0.6. Since we're using cross-channel for localization we'd like to start serializing our l10n to use 0.6 syntax in the localization tool (Pontoon).
Once we do, we'll need the updated parser in 59 to be able to read the output.

I'll request uplift for each patch separately, but placing them on the release mgmt radar together.
tracking-firefox59: --- → ?
Sure, I'll track these for now, and please ask for beta uplift when you are ready.
status-firefox59: --- → affected
status-firefox60: --- → affected
tracking-firefox59: ? → +

Comment 10

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b6604798c16d
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox60: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
(Assignee)

Comment 11

a year ago
Comment on attachment 8949229 [details]
bug 1432229, land compare-locales 2.7 and python-fluent 0.6.2,

Approval Request Comment
[Feature/Bug causing the regression]: none
[User impact if declined]: we won't be able to take string updates for l10n
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: no dependencies, but this blocks uplifts in bugs 1426054, 1436790
[Is the change risky?]: no
[Why is the change risky/not risky?]: Build-time only, and the code has already been tested to successfully read all our strings as part of a test install of transvision
[String changes made/needed]:
Attachment #8949229 - Flags: approval-mozilla-beta?
Comment on attachment 8949229 [details]
bug 1432229, land compare-locales 2.7 and python-fluent 0.6.2,

Should land for the 59 beta 10 build. 
This looks like fun.
Attachment #8949229 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 13

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/c891235f733c
status-firefox59: affected → fixed
You need to log in before you can comment on or make changes to this bug.