Closed Bug 1426791 Opened 3 years ago Closed 3 years ago

All OSX tests are going to permacrash when Gecko 59 merges to Beta on 2018-01-11

Categories

(Core :: Audio/Video: cubeb, defect)

All
macOS
defect
Not set
blocker

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 - verified

People

(Reporter: RyanVM, Assigned: kinetik)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Should be reproducible with the patch below:
https://hg.mozilla.org/try/rev/0154852baa88e427a1957e67ec1fd9d3e0acd80b

https://treeherder.mozilla.org/logviewer.html#?job_id=153049656&repo=try

PROCESS-CRASH | automation.py | application crashed [@ audioipc_server::channel::{{impl}}::send<audioipc_server::Command>]

Does the newly-enabled OSX AudioIPC code have dependencies on NIGHTLY_BUILD being set?
Flags: needinfo?(kinetik)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #0)
> Should be reproducible with the patch below:
> https://hg.mozilla.org/try/rev/0154852baa88e427a1957e67ec1fd9d3e0acd80b
> 
> https://treeherder.mozilla.org/logviewer.html#?job_id=153049656&repo=try
> 
> PROCESS-CRASH | automation.py | application crashed [@
> audioipc_server::channel::{{impl}}::send<audioipc_server::Command>]
> 
> Does the newly-enabled OSX AudioIPC code have dependencies on NIGHTLY_BUILD
> being set?

The pref to enable it is nightly-only.  Looks like we're missing a simple pref test in the bits I added recently, should be a simple fix.
This fixes local macOS testing with remoting prefed off.

Ryan, if you get a chance to push this with the rest of the beta staging changes, that'd be great.  I expect this to address bug 1426791 too.
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
Flags: needinfo?(kinetik)
Attachment #8938627 - Flags: review?(dglastonbury)
Comment on attachment 8938627 [details] [diff] [review]
audioipc_pref.patch

This works great :)
Attachment #8938627 - Flags: feedback+
Duplicate of this bug: 1426798
Attachment #8938627 - Flags: review?(dglastonbury) → review+
Pushed by mgregan@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c4b8ab2281bd
Don't try to activate cubeb remoting without checking pref.  r=kamidphish a=covered-by-inbound
https://hg.mozilla.org/mozilla-central/rev/c4b8ab2281bd
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.