Closed Bug 1427224 Opened 6 years ago Closed 6 years ago

Services.search.originalDefaultEngine is null on Linux Mint (breaking some non default engines since FF 57)

Categories

(Firefox :: Search, defect, P5)

57 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: gnu4ever, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171130143349

Steps to reproduce:

Since FF 57, I noticed that the search field turned to be unusable with my default search engine (qwant.com). While non-default search engines are still usable.

Note: I don't have any Search engine ADD-ON installed. Only search engines added over the time via the search field.


Actual results:

Since FF 57, when typing keywords in the search field, then pressing Enter (or clicking on the default engine just below) doesn't do anything (the search is not triggered).
While clicking on any non-default s.e. works as expected.


Expected results:

Pressing Enter or clicking on the default s.e. just below should trigger the search.

Additional information:
1/ This issue was only detected with Linux Mint 18 (I didn't test with my other GNU/Linux distros), it's not present on Win7 for instance.
2/ Changing my default s.e. to startpage.com produces the same issue. Qwant.com - having turned into a non-default s.e. - works correctly again.
3/ Changing my default s.e. to duckduckgo.com solves the issue! (but DDG is not my preferred s.e.) Meaning the issue occurs with SOME s.e. not with all of them.
Please check if you can reproduce the problem in a brand new profile.
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Component: Untriaged → Search
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Thanks for the test case.
Actually not, I can't reproduce this issue with a brand new profile.
See Also: → 1426616
In your profile with the problem, could you please open the browser console (Tools > Web Developer > Browser Console), reproduce the problem, and then see if any errors show up in the console?
Flags: needinfo?(pubalapoub)
Correct, a few errors show up as soon as I press Enter to (try to) trigger a search:

TypeError: Services.search.originalDefaultEngine is null[En savoir plus]  nsSearchService.js:2363:1
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "Services.search.originalDefaultEngine is null" {file: "jar:file:///usr/lib/firefox/omni.ja!/components/nsSearchService.js" line: 2363}]'[JavaScript Error: "Services.search.originalDefaultEngine is null" {file: "jar:file:///usr/lib/firefox/omni.ja!/components/nsSearchService.js" line: 2363}]' when calling method: [nsISearchEngine::speculativeConnect]  search.xml:525
TypeError: Services.search.originalDefaultEngine is null[En savoir plus]  nsSearchService.js:2363:1
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "Services.search.originalDefaultEngine is null" {file: "jar:file:///usr/lib/firefox/omni.ja!/components/nsSearchService.js" line: 2363}]'[JavaScript Error: "Services.search.originalDefaultEngine is null" {file: "jar:file:///usr/lib/firefox/omni.ja!/components/nsSearchService.js" line: 2363}]' when calling method: [nsISearchEngine::getSubmission]

Qwant.com was used as default search engine in this case. I get the same error with StartPage.com.
Surprisingly, Ixquick.com works correctly (while being more or less the same s.e. as StartPage.com).
Flags: needinfo?(pubalapoub)
Florian, do you think this might be related to your work in bug 1419941?  Please see comment 5.
Flags: needinfo?(florian)
(In reply to Drew Willcoxon :adw from comment #6)
> Florian, do you think this might be related to your work in bug 1419941? 
> Please see comment 5.

Somehow related, yes, in that it's the patch in bug 1419941 that started using Services.search.originalDefaultEngine. But given that this happens only on Linux Mint and not other Linux distribution, it's likely something triggered by the specific way Firefox is packaged on Mint.

Services.search.originalDefaultEngine should never be null, and I would be curious to know what they do to end up in this case.
Flags: needinfo?(florian)
Summary: [Search field] Some DEFAULT search engines no longer work since FF 57 (GNU/Linux) → Services.search.originalDefaultEngine is null on Linux Mint (breaking some non default engines since FF 57)
(In reply to Florian Quèze [:florian] from comment #7)

> Services.search.originalDefaultEngine should never be null, and I would be
> curious to know what they do to end up in this case.

I was told they install language packs by default.
Priority: -- → P5
I just did a fresh Mint install and switched my default to Qwant and it's working for me, so I think there's something else at work here.

Can folks encountering this problem please go to about:config and tell me the value for general.useragent.locale? Also, go to about:addons and tell me all languages listed in the Languages section.
(In reply to Mike Kaply [:mkaply] from comment #10)
> I just did a fresh Mint install and switched my default to Qwant and it's
> working for me, so I think there's something else at work here.

Since I spent the entire day debugging bug 1420775, you might need to try installing a different localization in Linux (e.g. French), then create a new user using that language
(In reply to Mike Kaply [:mkaply] from comment #10)
> I just did a fresh Mint install and switched my default to Qwant and it's
> working for me, so I think there's something else at work here.

Thanks for your test Mike. The outcome confirms what I tested myself: a new FF profile solves the issue.
As to the value for general.useragent.locale: fr in my case.
Installed languages:
- English (GB) Language Pack
- English (South Africa) Language Pack
- Français Language Pack
Bug fixed for me!
But I'm not sure whether my actions helped in the resolution or if the fix comes from FF 58.
Here is what I had done some weeks ago:
- modify the value of FF option "browser.search.reset.status" to "pending".
I was expecting this modification to offer me the possibility to reset my search engine parameters again (which I had refused initially). But it didn't happen, until FF 58 landed on Linux Mint yesterday.
THIS TIME, I chose to ACCEPT the change offered to me (by clicking the blue button - see attachment "FF 58 asking again if default search engine parameters should be reset.png").
And voila. Setting Qwant or StartPage as default s.e. works as expected again.
This is a Linux Mint bug that should be reported to them.

The do not ship the Google search engine, but they only updated the browser.search.defaultenginename.US preference, not the browser.search.defaultenginename value in region.properties which is still Google

So whenever the en-US Firefox is used outside of the United States (which access the non US preference), the default engine is Google, but there is no google.xml.

So the call to get the originalDefaultName fails.

We're not going to work around this.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Thank you very much for the details Mike. Now reported at https://bugs.launchpad.net/linuxmint/+bug/1745480
See Also: → 1423880
See Also: → 1435990
You need to log in before you can comment on or make changes to this bug.