Moving /copying addresses to Mailing List group problem

RESOLVED DUPLICATE of bug 160965

Status

RESOLVED DUPLICATE of bug 160965
17 years ago
14 years ago

People

(Reporter: allansw, Assigned: racham)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
(Senario)Imported Addresses from Outlook Express. Highlighted and dragged
everything from imported Outlook Express folder to Personal Folder. Created new
Mailing List group in my Personal Address Book.

(Problem)When I drag address(s) to newly created Mailing List group, the orignal
address(s) isn't removed. If this is by design, then if I delete the original,
then the address(s) in the new Mailing List group is gone except for the icon(s).

Comment 1

17 years ago
oops, i think its okay to keep the address, it should only be copied and not
moved to the mailing list.
but when following that path the address shouldnt disappear from the list when
deleted from address book

Comment 2

16 years ago
As I understand it, Lists are SUBSETS of address books, so if you drag an address
into a list, it is by definition included in the book that contains that list.

If you want an independent book, use File/New/AddressBook instead of New List.

If I'm right, then this should probably be marked INVALID.

Comment 3

15 years ago
The solution proposed by Jim Booth works for the problem as it was stated by
Allan Wilson. However, there IS a problem when copying lists in the address book.

Problem: When you copy a list from one address book to another the "list" gets
changed to a card. In other words, cannot copy lists from one address book to
another.

System: XP Pro with mozilla 1.6.

Reproducible: Always.

Steps:
- Create a new address book
- Create say 2 cards
- Create a list and add the said cards to the list
- Copy the newly created list to say the Personal Address Book
Notice how the "list" changed to  "card"

The bug is specially annoying when importing a large address book that contains
lists and some cards do not belong to any list. I think this fits the
title/summary given by Allan Wilson. If not I can create a new bug for this problem.

Comment 4

14 years ago
So what is this bug about now? Javier seems to be talking about a completely
separate issue. 

I would say that most people probably expect that addresses copied to lists are
separate, not a reference to the address in the address book itself. There are
arguments both ways though
Product: Browser → Seamonkey
Note: the problem referenced by Javier is actually already logged as bug 42879.

Comment 6

14 years ago
(In reply to comment #0)
> ... then if I delete the original,
> then the address(s) in the new Mailing List group is gone except for the icon(s).

see Bug 152133 and Bug 160965, marking as dupe




*** This bug has been marked as a duplicate of 160965 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.