Drag-n-drop a mailing list to another address book and appears as a card

RESOLVED FIXED in mozilla1.9alpha1

Status

MailNews Core
Address Book
P3
major
RESOLVED FIXED
18 years ago
9 years ago

People

(Reporter: marina, Assigned: standard8)

Tracking

Trunk
mozilla1.9alpha1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nab-dnd, [ue2][need info])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Steps to reproduce:
-create a list under Personal AB;
-select the created list and drag/drop it to another AB
//note: nothing is copied

Comment 1

18 years ago
reassigning to chuang.  I think this might be a dup of a feature we latered.
Assignee: putterman → chuang

Comment 2

18 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=32295
http://bugzilla.mozilla.org/show_bug.cgi?id=32305

There isn't an exact one which matches this one.  The above items were the 
closest ones I found.

Comment 3

18 years ago
moving to future milestone
Target Milestone: --- → Future

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 4

16 years ago
reassigning to racham
Assignee: chuang → racham
Status: ASSIGNED → NEW

Comment 5

16 years ago
*** Bug 108082 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Changing summary from "Unable to copy/paste a list to from one AB to another
one" to "Drag-n-drop a list to another AB and nothing copies over"
Summary: Unable to copy/paste a list to from one AB to another one → Drag-n-drop a list to another AB and nothing copies over
Whiteboard: nab-dnd

Comment 7

16 years ago
Trunk build 2001-12-27-03: WinMe
After I dnd a list to another AB, the list appears as a card.

Changing the summary from "Drag-n-drop a list to another AB and nothing copies 
over" to "Drag-n-drop a list to another AB and appears as a card"

Marking nsbeta1 because this makes it difficult to move lists.
Keywords: nsbeta1
QA Contact: lchiang → nbaca
Summary: Drag-n-drop a list to another AB and nothing copies over → Drag-n-drop a list to another AB and appears as a card

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1 → nsbeta1+
Target Milestone: Future → ---

Updated

16 years ago
Blocks: 118769

Updated

16 years ago
Blocks: 122274
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: --- → mozilla1.1

Comment 8

16 years ago
A possible workaround is to Drag-n-drop multiple cards from AB1 into a new
mailing list dialog in AB2. Unfortunately bug# 120445 needs to be fixed. If
neither bug is fixed then the user will have to manually create lists. This
could be painful if the user has large lists.

Comment 9

16 years ago
*** Bug 32299 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 145721 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 145731 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 156960

Updated

15 years ago
Keywords: nsbeta1- → nsbeta1
Whiteboard: nab-dnd → nab-dnd, [ue2]

Updated

15 years ago
Severity: normal → major

Comment 12

15 years ago
Created attachment 97112 [details] [diff] [review]
proposed patch

This patch works well on my Windows and Sparc. The maillist, together with the
cards inside it, is copy to the destinate AB and it does appear as a maillist. 

There still, however, remain some problem:
1. I don't find there is a method to judge whether a maillist name is already 
   used a AB. "mailListNameExists" takes effect on all ABs, therefore it does 
   not permit different ABs have maillist with identical name,:-(.I have tried
   hasCard method in nsIAbMDBDirectory interface, but it seems not working as
   my imagination. Any suggestions?
2. Part of the maillist, more precisely, part content of the cards inside the 
   maillist be dropped will lost. I think this is another bug known as #95299. 


Anyway, the maillist will not be dealed as a card when you drag & drop it.

Updated

15 years ago
Keywords: patch, review

Updated

15 years ago
OS: Windows NT → All
Hardware: PC → All

Comment 13

15 years ago
This bug exists on linux & solaris too. Marking platform and OS to 'All'.

Comment 14

15 years ago
Comment on attachment 97112 [details] [diff] [review]
proposed patch

This patch is a good start point for this big issue. I tested this patch on
linux and it does dnd as mail list instead of card. However,  there are some
areas needed to be improved.

1. decide if the operation is copy or move according to the value of
'needToCopyCard'
2. after dnd copy operation, all cards in the original mail list dispare. When
you restart mozilla, you can see them again
3. code style. Don't mix 'Tab' and 'Space' when writing code. Try to use
'Space'.

Sean, thx for the patch. Keep on going if possible.
Attachment #97112 - Flags: needs-work+

Comment 15

15 years ago
Mail triage team: Sean Gao, would you like to take ownership of this bug?  If
so, feel free to reassign it to yourself.  Thanks.
Whiteboard: nab-dnd, [ue2] → nab-dnd, [ue2][need info]

Comment 16

15 years ago
Mail triage team: nsbeta1-
Keywords: nsbeta1-

Updated

15 years ago
Keywords: nsbeta1
mass re-assign.
Assignee: racham → sspitzer
Status: ASSIGNED → NEW

Comment 18

15 years ago
*** Bug 185014 has been marked as a duplicate of this bug. ***

Comment 19

15 years ago
*** Bug 212062 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
*** Bug 211404 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Target Milestone: mozilla1.1alpha → ---

Comment 21

14 years ago
Also seeing this on Thunderbird 0.4 on Windows.

Comment 22

14 years ago
*** Bug 240009 has been marked as a duplicate of this bug. ***

Comment 23

14 years ago
I just ran into this bug after importing an Eudora address book. Since I don't
wanted to have an extra address book with the imported addresses, I move
everything into the main book. Mailing lists were lost as described before. So I
have two points here: a) this is dataloss and hence should be marked critical
and b) this is particularly relevant for imported data which cannot be imported
into an address book of the user's choice.

pi

Comment 24

13 years ago
*** Bug 265490 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
(Assignee)

Comment 25

13 years ago
As part of adding facilities for copy or move via drag and drop in bug 35837, I
have submitted a patch to implement the correct transfer of mailing lists from
one book to another. Part of the patch was based on the one attached to this bug
by Sean Gao.

Therefore taking bug, cc'ing seth (original owner) and adding dependency for
35837 so that I remember.
Assignee: sspitzer → mark
Depends on: 35837
(Assignee)

Updated

13 years ago
Blocks: 272994

Comment 26

13 years ago
I found a bad drop down list by Mozilla 1.7.7 on Win XP
http://www.tat.com.tw/ 
It was correct on IE.
(Assignee)

Updated

12 years ago
Component: Address Book → MailNews: Address Book
Product: Mozilla Application Suite → Core
(Assignee)

Updated

12 years ago
No longer blocks: 272994
(Assignee)

Comment 27

12 years ago
*** Bug 272994 has been marked as a duplicate of this bug. ***

Comment 28

12 years ago
*** Bug 312515 has been marked as a duplicate of this bug. ***

Comment 29

12 years ago
I propose to change the summary of bug 42879 in such way, that the 
term "mailing list" appears in it, instead of only "list". So it is easier to 
find for people who bumped into the problem and want to check, if it already is 
in the bug list. Could save some dupes.
Maybe
"Drag-n-drop of mailing list to another address book changes it into a card"
(Assignee)

Comment 30

12 years ago
Changed summary from: Drag-n-drop a list to another AB and appears as a card
Status: NEW → ASSIGNED
Summary: Drag-n-drop a list to another AB and appears as a card → Drag-n-drop a mailing list to another address book and appears as a card
Target Milestone: --- → mozilla1.9alpha
(Assignee)

Updated

12 years ago
Blocks: 270415

Comment 31

12 years ago
I can still reproduce the bug with build 20051201.
(Assignee)

Comment 32

12 years ago
*** Bug 320059 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 33

12 years ago
This has been fixed by the Part 2 patch on Bug 35837 that I just checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 34

12 years ago
(In reply to comment #33)
> This has been fixed by the Part 2 patch on Bug 35837 that I just checked in.
> 
The movement of the address list is possible by D&D. 
But It is not possible to copy(Ctrl + D&D) it.

Windows XP SP1
version 3 alpha 1 (20060522)
(Assignee)

Comment 35

12 years ago
(In reply to comment #34)
> (In reply to comment #33)
> > This has been fixed by the Part 2 patch on Bug 35837 that I just checked in.
> > 
> The movement of the address list is possible by D&D. 
> But It is not possible to copy(Ctrl + D&D) it.
> 
> Windows XP SP1
> version 3 alpha 1 (20060522)
> 
That is correct. Currently mailing list names have to be unique (bug 170296) and therefore a copy isn't allowed. The main reason mailing list names have to be unique is for autocomplete (otherwise which mailing list is in which ab). Note that I'm not saying we can't implement this in future, but it should be part of bug 170296 if we do.
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.