Preferences font size is tiny after latest nightly update

RESOLVED FIXED in Firefox 59

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: bgstandaert, Assigned: myk)

Tracking

({nightly-community})

Trunk
Firefox 59
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180103231032

Steps to reproduce:

Open the firefox preferences.


Actual results:

Starting in the 2018-01-05 nightly, the preferences font size is noticeably smaller, making it difficult to read. I've attached a screenshot comparing the font size in 58.0beta to the latest nightly (58 is on the left, nightly is on the right).


Expected results:

The font size should be the same as it was in previous nightlies.

I'm guessing this may be caused by bug 1379338?
Blocks: 1379338
Component: Untriaged → Preferences
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
Version: 57 Branch → Trunk
(In reply to bgstandaert from comment #0)

> I'm guessing this may be caused by bug 1379338?

That's a reasonable suspicion!  I'll take a look.
Assignee: nobody → myk
Before bug 1379338, the font size in about:preferences on Mac was determined by https://searchfox.org/mozilla-central/rev/f42618c99dcb522fb674221acfbc68c2d92e7936/browser/themes/osx/preferences/in-content/preferences.css#7-9, which sets |:root > * { font-size: 1.36em }|.

After bug 1379338, the size is determined by https://searchfox.org/mozilla-central/rev/f42618c99dcb522fb674221acfbc68c2d92e7936/browser/themes/osx/preferences/preferences.css#15-18, which sets |.prefwindow { font: -moz-dialog !important }|, overriding the other rule.

I copied the latter rule from toolkit/themes/osx/global/preferences.css, where it had applied to <prefwindow> elements.  It's no longer necessary, now that in-content/preferences.css and in-content/dialog.css set the font-size for about:preferences and subdialogs, respectively.  So the fix is to remove it.

(I've checked that the subdialog font size is correct, and I've also checked that sizes are correct on Windows and Linux.  The only regression was in the main about:preferences page on Mac.)
Attachment #8940586 - Flags: review?(jaws)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8940586 [details] [diff] [review]
remove incorrect about:preferences font-size override

Dao recently fixed up the font-sizes in bug 1422100 so I'm redirecting review to him.
Attachment #8940586 - Flags: review?(jaws) → review?(dao+bmo)
Attachment #8940586 - Flags: review?(dao+bmo) → review+
Duplicate of this bug: 1428957
Pushed by myk@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6982051a36b5
remove incorrect about:preferences font-size override; r=dao
https://hg.mozilla.org/mozilla-central/rev/6982051a36b5
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.