Closed Bug 1574520 Opened 4 months ago Closed 4 months ago

Cleanup breadcrumbs.js and breadcrumbs.css after bug 1428917

Categories

(DevTools :: Inspector, defect, P1)

defect

Tracking

(firefox-esr60 unaffected, firefox-esr68 wontfix, firefox68 unaffected, firefox69 wontfix, firefox70 verified)

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox68 --- unaffected
firefox69 --- wontfix
firefox70 --- verified

People

(Reporter: itiel_yn8, Assigned: itiel_yn8)

References

(Regression)

Details

(Keywords: regression, rtl)

Attachments

(1 file)

In bug 1428917 I missed that breadcrumbs.js is dependant on RTLness of the browser, and that there are some rules in breadcrumbs.css that are no longer necessary.

This causes the scroll buttons misbehave when clicking (1 click goes to the beginning/end of the whole scrollbar) and double clicking (double clicking does the opposite behavior and scroll the view to the right instead of left and vice versa) them, on RTL only.

This is still better than what was before bug 1428917 was fixed imo.

[Tracking Requested - why for this release]:
Follow up on bug 1428917 (which was already uplifted to beta and ESR), fixing Inspector breadcrumbs behaviour for RTL + cleaning up redundant and now obsolete code.

I already have a working patch for this, but I'm not sure what the timetable for beta and ESR is.
Hopefully I can submit a bug on Sunday.

This will probably need QE testing though as I missed this in bug 1428917.

Another option is to backport bug 1428917 and uplift this if it'll make it in time.

:itiel_yn8, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(itiel_yn8)
No longer blocks: 1428917
Flags: needinfo?(itiel_yn8)
Regressions: 1428917
Assignee: nobody → itiel_yn8
Status: NEW → ASSIGNED
Regressed by: 1428917
No longer regressions: 1428917
Attachment #9086083 - Attachment description: Bug 1574520 - WIP - Clean up Inspector breadcrumbs for RTL → Bug 1574520 - Clean up Inspector breadcrumbs for RTL + arrows border fix for white theme
Priority: -- → P3

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1
See Also: → 1576092
Attachment #9086083 - Attachment description: Bug 1574520 - Clean up Inspector breadcrumbs for RTL + arrows border fix for white theme → Bug 1574520 - Clean up Inspector breadcrumbs for RTL
Pushed by gluong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/24a73105e026
Clean up Inspector breadcrumbs for RTL r=gl
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Status: RESOLVED → VERIFIED

Too late for an uplift.

You need to log in before you can comment on or make changes to this bug.