Closed Bug 1429785 Opened 2 years ago Closed Last year

In-page back navigation broken

Categories

(bugzilla.mozilla.org :: General, defect, P1)

Production
defect

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: Kwan, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

45 bytes, text/x-github-pull-request
dylan
: review+
Details | Review
STR:
1) Go to bug 712130
2) Find in page for "comment 32" and go to the 2nd result (in 53rd comment).
3) Click the link to 32nd comment
4) Press the back button/backspace

ER:
returned to previous place in document (viewing 53rd comment)

AR:
Nothing

Similarly if one replaces step 1 with going to bug 712130 comment 43 (as an example), after step 4 one ends up back at 43, instead of the previous scroll position as on normal web pages.
Interesting. The bug is reproducible in other browsers as well.
Priority: -- → P1
This is probably due to the scroll position adjusted by a script (to have an extra room above each comment once it gets focused.) Could remove it; smooth scroll will still work.
Nah, I can reproduce the issue even when script is disabled. So the reason is the scroll container now on `<main>`. Making `<body>` the scroll container again is not an option, because the comment form will also be fixed at the bottom of the page. I'll figure out how to solve the issue. May involve the History API.

https://developer.mozilla.org/en-US/docs/Web/API/History_API
Assignee: nobody → kohei.yoshino
Attached file pull request
Blocks: 1428642
Status: NEW → ASSIGNED
Blocks: 1426685
No longer blocks: 1428642
Attachment #8942046 - Flags: review?(dylan)
PR landed to master.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Attachment #8942046 - Flags: review?(dylan) → review+
I think this needs to be backed out.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
To github.com:mozilla-bteam/bmo.git
   f67962dcb..790e46fac  master -> master
Keywords: regression
Duplicate of this bug: 1444795
The issues in my first PR are described in Bug 1433040 Comment 6. Let’s try again...
Status: REOPENED → ASSIGNED
I’m trying to fix this, but I see a page bounce when replying to the last comment (Bug 1478674). Apparently the autosize functionality is not compatible with smooth scrolling. So, my plan is fixing this after changing the page layout to separate the comment box from comment feed.
Status: ASSIGNED → NEW
Assignee: kohei.yoshino → nobody
Status: NEW → RESOLVED
Closed: 2 years agoLast year
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.