Closed Bug 1431106 Opened 5 years ago Closed 5 years ago

Slack renders as a single blank colour after the initial render with Webrender enabled

Categories

(Core :: Web Painting, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1431128

People

(Reporter: cwiiis, Unassigned)

Details

(Keywords: regression)

I don't know that this is a WebRender bug specifically (it could be retained displaylist?) - I expect there are enough Slack users to be able to verify this though?

As of 17th January Nightly (possibly in 16th too, but I think it was fine on 15th), Slack renders as a single blank colour, off-white, flashing to white briefly as you mouse-over the page (but returning to off-white when you stop moving the cursor, even in a place that caused it to switch to white).
I just had this happen on GMail, so it would appear whatever the bug is, though it's triggered very quickly/easily on Slack, it affects other sites too.
What platform are you seeing this on?

Possibly just a very bad version of Bug 1430700? 

A few pretty nasty regression fixes are inbound (including the above issue). Should wait a bit and see if this gets fixed in the next ~day.
(In reply to Alexis Beingessner [:Gankro] from comment #2)
> What platform are you seeing this on?
> 
> Possibly just a very bad version of Bug 1430700? 
> 
> A few pretty nasty regression fixes are inbound (including the above issue).
> Should wait a bit and see if this gets fixed in the next ~day.

I'm seeing this on Linux - I'm not getting subregions of the page turning invisible, literally the entire page will turn white (maybe bg colour?) and flicker to grey briefly as I mouse over links and things (that are invisible, of course, but still work).

Maybe the same root cause though, let's hope it's fixed tomorrow I suppose :)
Assignee: nobody → a.beingessner
Priority: -- → P1
This is a duplicate of bug 1431128 (well, that's a dupe of this, but that bug has more accurate information, so duping to that). Sorry, this is unrelated to Webrender.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1431128
Assignee: a.beingessner → nobody
Component: Graphics: WebRender → Layout: Web Painting
Priority: P1 → --
You need to log in before you can comment on or make changes to this bug.