Closed Bug 1431128 Opened 5 years ago Closed 5 years ago

Slack tab goes blank randomly (when retained display lists enabled)

Categories

(Core :: Web Painting, defect, P1)

x86_64
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 - fixed

People

(Reporter: nchevobbe, Assigned: mattwoodrow)

References

Details

(Keywords: regression)

On latest Nightly (59.0a1 (2018-01-17) (64-bit), OSX), from time to time, my Slack tab goes blank.
The other tabs are not affected, and reloading the tab makes it "correct" again.
There don't seem to be meaningful logs in the browser console.

The fun thing is that the cursor still changes if I hover what I think is a link, and messages that I typed blindly were sent.

DevTools are still working, and I can even "inspect" elements like I usually do, but the highlighter is not shown.

For now, I encountered this bug only on Slack. I'll post updates if I see it on another site.

Not sure this belong to this component, so feel free to move it.
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
Hardware: x86 → x86_64
I've been seeing this on Slack tabs today as well (but so far I think only when switching to the tab), on Linux.  rnewman mentioned seeing similar on github.
[Tracking Requested - why for this release]: Tabs going blank randomly is a serious regression that we can't ship.
Keywords: regression
Do you have webrender enabled?
I believe I am seeing this issue as well in some Google Docs on macOS.  Disabling retained display lists (setting `layout.display-list.retain` to false in about:config) made the content magically appear, so I am guessing it's related to this feature.

I do not have Webrender enabled.
Flags: needinfo?(matt.woodrow)
I don't have WebRender enabled either.  From about:support, Graphics section:

Decision Log
HW_COMPOSITING	
blocked by default: Acceleration blocked by platform
OPENGL_COMPOSITING	
unavailable by default: Hardware compositing is disabled
WEBRENDER	
opt-in by default: WebRender is an opt-in feature
unavailable by runtime: Hardware compositing is disabled
OMTP	
disabled by default: Disabled by default
And turning off retained display lists also fixes it for me.
Blocks: 1352499
Component: Layout: View Rendering → Layout: Web Painting
Flags: needinfo?(matt.woodrow)
Priority: -- → P1
Summary: Slack tab goes blank randomly → Slack tab goes blank randomly (when retained display lists enabled)
Duplicate of this bug: 1431106
I also saw this happen on GMail, but I don't know what triggered it... Slack triggers it after very little interaction at all.
The Nightly from just now doesn't seem to have this issue, I suspect the backout of bug 1420737 fixed this.
I can confirm that it was fixed by the backout, and is no longer present in the relanded version.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Assignee: nobody → matt.woodrow
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.