Closed Bug 1431955 Opened 3 years ago Closed 3 years ago

Regression: Flashing windows

Categories

(Core :: Graphics: WebRender, defect, P1)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1432309
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- disabled

People

(Reporter: yoasif, Assigned: kvark)

References

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

Attached video flashing firefox.webm
Seen in the latest Nightly. 

One or more windows (but not all) flash or flicker when restoring from session restore. Different windows flicker or flash when restarted, so it doesn't seem connected to a specific site. 

The restored window is pretty unusable; changing the window size does not resolve the issue. 

mozregression:

13:27.22 INFO: Narrowed inbound regression window from [1a4f40cd, 5dddf1e0] (3 builds) to [1a4f40cd, 6d9dc65c] (2 builds) (~1 steps left)
13:27.22 INFO: No more inbound revisions, bisection finished.
13:27.22 INFO: Last good revision: 1a4f40cd0bea7855f76b2237819e07e89fd89d75
13:27.22 INFO: First bad revision: 6d9dc65ca0ed1a374dde7592a5b4191a7a10759c
13:27.22 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=1a4f40cd0bea7855f76b2237819e07e89fd89d75&tochange=6d9dc65ca0ed1a374dde7592a5b4191a7a10759c
Attached file about-config.txt
Has Regression Range: --- → yes
See Also: → 1432012
OS: Unspecified → Linux
We've had different flavours of this problem, and session restore (restart on update) seem to trigger it more.  For me, this is on Windows.
Assignee: nobody → kvark
Priority: -- → P1
Here are steps to reproduce that work reliably for me on macOS:
1. In the current window, start playing any YouTube video.
2. Open a new window and load http://tests.themasta.com/box-shadow-playground/#transparent_red_outset_228_118_258_343_90x86_0x0_0x0_165x161_235_125_27_0 in it.
3. Grab the light blue area and move the light blue box over the purple box in circles, for many seconds.

This corrupts the content in both windows. The new window seems to fix itself fairly quickly if you leave it alone, and the old window seems to be more permanently affected.
Attached video 2018-01-23_20-58-55.mp4
(In reply to Markus Stange [:mstange] from comment #3)
Nightly 60 x64 20180123102017 de_DE @ Debian Testing (KDE, Radeon RX480)
fresh profile: gfx.webrender.all

I noticed that the box moved heavily slower sometimes. When didn't saw a corruption I gave up. I think I closed that second window and opened another one which then was broken. I found this afterwards:
bp-ea42bbef-e976-4ede-bc08-4bda00180123
-----
After trying it in my main profile, I wanted to open the main menu, but it opened with several seconds delay and its icons came after another delay.
My bug 1432375 had crashes + failures, but here I didn't see anything bad on about:support.
I mean: "When I didn't see a corruption I gave up."
I just move the third and then the second tab out of the window while they are loading, to have three windows at the end.
bad is when one window looks like attachment 8944847 [details] (white window with black box).

-----

testing good/bad from bug 1432101 comment 4 (before/after webrender update from bug 1430829)

mozregression --repo autoland --launch 6d9dc65ca0ed1a374dde7592a5b4191a7a10759c --pref gfx.webrender.all:true general.autoScroll:true privacy.trackingprotection.enabled:true startup.homepage_welcome_url:"https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/"
bad, bad, good, good, bad

mozregression --repo autoland --launch 1a4f40cd0bea7855f76b2237819e07e89fd89d75 --pref gfx.webrender.all:true general.autoScroll:true privacy.trackingprotection.enabled:true startup.homepage_welcome_url:"https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/"
good, good, good, good, good, good, good, good, good, good

> WR @ 9cad76acef7c1da00ba4beb1e01e764eee8fe4d5
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=0c4cea5ad05fb531fa50a113b5fbd86c26b8ef7a
mozregression --repo try --launch 0c4cea5ad05fb531fa50a113b5fbd86c26b8ef7a --pref gfx.webrender.all:true general.autoScroll:true privacy.trackingprotection.enabled:true startup.homepage_welcome_url:"https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/"
good, good, bad, bad, bad, bad (differently broken: black text + ui icons), bad

-----

previous wr update was bug 1429806: eb9e1702df4b6dc036b649b3dd32ccc4bfbe43bf

> WR @ eb9e1702df4b6dc036b649b3dd32ccc4bfbe43bf with the reftest updates
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=61fa59a85db368a044f0f67e11d8dc8dd57857cb
mozregression --repo try --launch 61fa59a85db368a044f0f67e11d8dc8dd57857cb --pref gfx.webrender.all:true general.autoScroll:true privacy.trackingprotection.enabled:true startup.homepage_welcome_url:"https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/"
good, good, good, good, good, good

-----

And again: 

bug 1430829
> WR @ 9cad76acef7c1da00ba4beb1e01e764eee8fe4d5
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=0c4cea5ad05fb531fa50a113b5fbd86c26b8ef7a
mozregression --repo try --launch 0c4cea5ad05fb531fa50a113b5fbd86c26b8ef7a --pref gfx.webrender.all:true general.autoScroll:true privacy.trackingprotection.enabled:true startup.homepage_welcome_url:"https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/"
bad, bad, bad (differently broken: broken text like bug 1432309 + black scrollbar), good, bad

bug 1429806
> WR @ eb9e1702df4b6dc036b649b3dd32ccc4bfbe43bf with the reftest updates
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=61fa59a85db368a044f0f67e11d8dc8dd57857cb
mozregression --repo try --launch 61fa59a85db368a044f0f67e11d8dc8dd57857cb --pref gfx.webrender.all:true general.autoScroll:true privacy.trackingprotection.enabled:true startup.homepage_welcome_url:"https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/|https://www.planet3dnow.de/cms/"
good, good, good, good, good, good, good


https://github.com/servo/webrender/compare/eb9e1702df4b6dc036b649b3dd32ccc4bfbe43bf...9cad76acef7c1da00ba4beb1e01e764eee8fe4d5
See Also: 1432012
Duplicate of this bug: 1432012
See Also: → 1431560
It's fixed in the try build from bug 1432309 comment 26. :)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
See Also: 1432309
Duplicate of bug: 1432309
You need to log in before you can comment on or make changes to this bug.