Closed Bug 1432541 Opened 2 years ago Closed 2 years ago

regression: per-message-menus get invisible, contact details sidebar is invisible on https://web.whatsapp.com

Categories

(Core :: Graphics: WebRender, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- disabled

People

(Reporter: darkspirit, Assigned: kats)

References

(Blocks 1 open bug, )

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

Attached video 2018-01-23_18-23-56.mp4
mozregression --good 2018-01-12 --bad 2018-01-23 --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://web.whatsapp.com/"
> 14:41.68 INFO: Last good revision: de52bf2201a6992df26d0e7c7c1223266bcda4f9
> 14:41.68 INFO: First bad revision: 3dea9196184747f4987cbc95d7d11b8e934a3d11
> 14:41.68 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=de52bf2201a6992df26d0e7c7c1223266bcda4f9&tochange=3dea9196184747f4987cbc95d7d11b8e934a3d11

Bug 1414928 changed two java files for Android
Bug 1427260 changed one java file for Android (Activity Stream)

so it's probably
> 3dea91961847	Kartikaya Gupta — Bug 1426386 - Add reftests for position:sticky items inside a transform. r=mstange
> be2548e479a6	Kartikaya Gupta — Bug 1426386 - Split the transform sent to webrender back into the transform and positioning components. r=mstange
> 2254ae8cf040	Kartikaya Gupta — Bug 1426386 - Expose WR stacking context bounds via StackingContextHelper. r=mstange

mozregression --repo autoland --launch 3dea9196184747f4987cbc95d7d11b8e934a3d11 --pref startup.homepage_welcome_url:"https://web.whatsapp.com/"
non-WR Nightly is good
Summary: regression: per-message-menus get invisible, contact details sidebar is invisible → regression: per-message-menus get invisible, contact details sidebar is invisible on https://web.whatsapp.com
Assignee: nobody → bugmail
This also breaks ReCaptcha. Only one image is shown: https://www.google.com/recaptcha/api2/demo
Thanks, the ReCaptcha page was much simpler and helped me track this down faster.

Try push with a fix: https://treeherder.mozilla.org/#/jobs?repo=try&revision=7c443bd0fa3951123aa8b21c06cece0c8fb3b386
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
mozregression --repo try --launch 7c443bd0fa3951123aa8b21c06cece0c8fb3b386 --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://web.whatsapp.com/|https://www.google.com/recaptcha/api2/demo"
good :)
Thanks. I'll see if I can make a reftest for it before I put it up for review.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #4)
> Thanks. I'll see if I can make a reftest for it before I put it up for review.

Same good/bad as comment 0 and fixed in your try build: http://www.bild.de/faq/seite/bildplus/alles-ueber-bildplus-30427132.bild.html
https://treeherder.mozilla.org/#/jobs?repo=try&revision=60ba55b9435dca19a3a39f810f023d50199f0c63 - the test-verify jobs (which run without WR enabled) are all green but the reftest has a few pixel differences when loaded with webrender. Not sure why but I'm going to just fuzz that. The failure case had the second square not showing up at all so a small fuzz should be fine for the purposes of the test.
Duplicate of this bug: 1433079
Comment on attachment 8945138 [details]
Bug 1432541 - Don't reuse clips across a stacking context with a nonzero position.

https://reviewboard.mozilla.org/r/215374/#review221466
Attachment #8945138 - Flags: review?(mstange) → review+
Comment on attachment 8945139 [details]
Bug 1432541 - Add a reftest.

https://reviewboard.mozilla.org/r/215376/#review221470

::: gfx/tests/reftest/1432541-ref.html:12
(Diff revision 1)
> +</style>
> +</head>
> +<body>
> +  <table>
> +    <tr>
> +      <td><div><div class="tile-wrapper" style="width: 126px; height: 126px"><img class="tile-33" src="logo.jpg" style="top:0%; left: 0%"></div></div></td>

Could you move the test into layout/reftests/bugs and use one of the image files from there, e.g. solidblue.png? Then you don't have to add another image.
Attachment #8945139 - Flags: review?(mstange) → review+
(In reply to Markus Stange [:mstange] from comment #11)
> Could you move the test into layout/reftests/bugs and use one of the image
> files from there, e.g. solidblue.png? Then you don't have to add another
> image.

Good point, will do.
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a60df1434416
Don't reuse clips across a stacking context with a nonzero position. r=mstange
https://hg.mozilla.org/integration/autoland/rev/9b89294c5bcf
Add a reftest. r=mstange
https://hg.mozilla.org/mozilla-central/rev/a60df1434416
https://hg.mozilla.org/mozilla-central/rev/9b89294c5bcf
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
No longer blocks: 1431326
Duplicate of this bug: 1431326
No longer blocks: 1432742
Duplicate of this bug: 1432742
Verified fixed in Nightly 60 x64 20180126220105 de_DE @ Debian Testing (KDE, Radeon RX480). Thank you!

Wait until all tabs are loaded.
* bug 1432742 tab title: move the wikipedia tab behind Mozilla. If you haven't seen Mozilla's tab title on Fefe's tab, it's good.
* bug 1430830 dailymotion (after the ad!): It's good if the fullscreen icon doesn't jump from the top-right to the bottom-right of the video.
* bug 1430830 whatsapp: login. per-message-menus shouldn't get invisible and the contact details sidebar shouldn't be empty.
* bug 1430830 recaptcha: not only the first image should be visible inside recaptcha.
* bug 1430830 bild: all three offers should be visible next to each other.
* bug 1431326 tab loading icon: Hold Ctrl down and make a doubleclick on "zeit", the first top sites item. Both tabs should have loading indicators.

mozregression --find-fix --bad 2018-01-23 --good 2018-01-26 --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://blog.fefe.de/|https://www.wikipedia.org/|https://www.mozilla.org/|https://www.dailymotion.com/video/x6cz8z2|https://web.whatsapp.com|https://www.google.com/recaptcha/api2/demo|http://www.bild.de/faq/seite/bildplus/alles-ueber-bildplus-30427132.bild.html|about:newtab" browser.newtabpage.pinned:"[{\"url\":\"http://www.zeit.de/index\",\"label\":\"zeit\"}]"
> 14:43.11 INFO: No more inbound revisions, bisection finished.
> 14:43.11 INFO: First good revision: 723b25eb3dd83d0bb1ea846814e9d7e1bdc78e1b
> 14:43.11 INFO: Last bad revision: b5b38db26ed70ba24b64349e6a6528b77ec9599e
> 14:43.11 INFO: Pushlog:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b5b38db26ed70ba24b64349e6a6528b77ec9599e&tochange=723b25eb3dd83d0bb1ea846814e9d7e1bdc78e1b

last bad:
> 0be952431c0c	arthur.iakab — Merge mozilla-central to autoland
mozregression --repo autoland --launch 0be952431c0c --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://blog.fefe.de/|https://www.wikipedia.org/|https://www.mozilla.org/|https://www.dailymotion.com/video/x6cz8z2|https://web.whatsapp.com|https://www.google.com/recaptcha/api2/demo|http://www.bild.de/faq/seite/bildplus/alles-ueber-bildplus-30427132.bild.html|about:newtab" browser.newtabpage.pinned:"[{\"url\":\"http://www.zeit.de/index\",\"label\":\"zeit\"}]"
all are bad

first good:
> a60df1434416	Kartikaya Gupta — Bug 1432541 - Don't reuse clips across a stacking context with a nonzero position. r=mstange
mozregression --repo autoland --launch a60df1434416 --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://blog.fefe.de/|https://www.wikipedia.org/|https://www.mozilla.org/|https://www.dailymotion.com/video/x6cz8z2|https://web.whatsapp.com|https://www.google.com/recaptcha/api2/demo|http://www.bild.de/faq/seite/bildplus/alles-ueber-bildplus-30427132.bild.html|about:newtab" browser.newtabpage.pinned:"[{\"url\":\"http://www.zeit.de/index\",\"label\":\"zeit\"}]"
all are good
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.