Change PaymentRequest UI to support users retrying upon payment failure

VERIFIED FIXED in Firefox 64

Status

()

enhancement
P1
normal
VERIFIED FIXED
a year ago
5 months ago

People

(Reporter: MattN, Assigned: MattN)

Tracking

(Depends on 4 bugs, {dev-doc-complete})

Trunk
Firefox 64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed, firefox65 disabled, firefox66 verified)

Details

(Whiteboard: [webpayments] [user-testing], )

User Story

* Use all new merchant address error string properties
* Show a merchant address error on the summary screen below the relevant picker

Attachments

(3 attachments)

See bug 1435161 and https://github.com/w3c/payment-request/issues/647 for why we don't want to always close the Payment Request dialog upon failure.
Priority: P3 → P2
Whiteboard: [webpayments]
Component: WebPayments UI → WebPayments UI
Product: Toolkit → Firefox
Priority: P2 → P3
Whiteboard: [webpayments] → [webpayments-reserve]
Whiteboard: [webpayments-reserve] → [webpayments-reserve] [user-testing]

Updated

10 months ago
Priority: P3 → P2
Whiteboard: [webpayments-reserve] [user-testing] → [webpayments] [user-testing]
Mentor: hani.yacoub
Flags: qe-verify+
Mentor: hani.yacoub
QA Contact: hani.yacoub

Updated

10 months ago
Priority: P2 → P3
Whiteboard: [webpayments] [user-testing] → [webpayments-reserve] [user-testing]
Priority: P3 → P2
Priority: P2 → P3
Now that bug 1435161 is resolved this is unblocked.
Priority: P3 → P2
User Story: (updated)
Whiteboard: [webpayments-reserve] [user-testing] → [webpayments] [user-testing]

Comment 2

8 months ago
We should follow up with Sharon on whether we need to do any retry in user testing since no real site currently support retry. We may have to customize a page specifically to test this retry user flow.
User Story: (updated)
(In reply to Jean Gong :jgong from comment #2)
> We should follow up with Sharon on whether we need to do any retry in user
> testing since no real site currently support retry. We may have to customize
> a page specifically to test this retry user flow.

It sounded like the team was interested in understanding how people perceive retry, so I think we need some version of it, even if "fake."
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Priority: P2 → P1
Bug 1494723 will handle paymentMethod merchant errors and showing merchant errors under the pickers on the summary page
User Story: (updated)
After thinking about it more, since the bug 1494884 behaviour is so rare, I don't think it makes sense to test that in user testing but having the errors show below the pickers will be more useful and relevant for testing retry.
User Story: (updated)
I still need to write and update tests for this.

Depends on D7159
Comment on attachment 9012758 [details]
Bug 1435163 - Show merchant address errors on billing and payer screens. r=jaws,sfoster

Sam Foster [:sfoster] has approved the revision.
Attachment #9012758 - Flags: review+
Comment on attachment 9012801 [details]
Bug 1435163 - Show the summary page after the processing page when retry() is called. r=jaws,sfoster

Sam Foster [:sfoster] has approved the revision.
Attachment #9012801 - Flags: review+
Comment on attachment 9012802 [details]
Bug 1435163 - Show merchant address errors on the summary screen. r=jaws,sfoster

Jared Wein [:jaws] (please needinfo? me) has approved the revision.
Attachment #9012802 - Flags: review+

Comment 12

8 months ago
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/e2d81abcb655
Show merchant address errors on billing and payer screens. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/e782c165223a
Show the summary page after the processing page when retry() is called. r=sfoster
https://hg.mozilla.org/integration/autoland/rev/ea8385466c06
Show merchant address errors on the summary screen. r=jaws

Updated

8 months ago
Depends on: 1495151

Comment 14

8 months ago
Hi Matt,

We are not sure how to test this since on https://sfoster.github.io/payments-scratch/completeTimeout.html test-page there is no "Retry" button on the error screen as it can be seen in the design doc. 

Is there a different test-page or the above test should support retrying?
Flags: needinfo?(MattN+bmo)
You should test with the 3 retry pages on the site you've been testing with before:
https://rsolomakhin.github.io/
Flags: needinfo?(MattN+bmo)
Bug 1494884 will handle the screen when the merchant provides no errors.

Comment 17

8 months ago
Thank you Matt!

Tested on the test pages from https://rsolomakhin.github.io/

1. The summary page will be displayed after the processing page when retry() is called.
2. The merchant errors will be displayed related to the specific field on the summary screen
3. The merchant errors will be displayed for the invalid fields in every Edit screen


I could also reproduce Bug 1495549 in every test page: shipping address, contact information and both of them in the same test. Waiting for it to be fixed before closing this issue.
Duplicate of this bug: 1494580
Depends on: 1454905
This has been done while writing up the addition of the retry() method.

Comment 20

5 months ago
Verified as fixed on Firefox Nightly 66.0a1 (2018-12-17) on Windows 10 x 64, Mac OS X 10.13 and on Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.