Closed Bug 1435342 Opened 2 years ago Closed 2 years ago

ESLint should ignore the tp5n dataset

Categories

(Firefox Build System :: Lint and Formatting, enhancement, P1)

3 Branch
enhancement

Tracking

(firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: mossop, Assigned: standard8)

References

Details

Attachments

(1 file)

I guess if you run talos locally then it extracts the tp5n dataset into testing/talos/talos/tests/tp5n. This path is ignored in .hgignore but not in .eslintignore so we attempt to lint all this lovely web content against our coding standards ultimately leading to an eslint crash!

We should be ignoring this directory in .eslintignore.
Duplicate of this bug: 1435346
I've filed bug 1435677 as I think that Talos shouldn't really be doing this. However, patch coming up for the ignore file.
Assignee: nobody → standard8
Status: NEW → ASSIGNED
Priority: -- → P1
Comment on attachment 8948327 [details]
Bug 1435342 - ESLint should ignore the tp5n dataset when extracted by Talos.

https://reviewboard.mozilla.org/r/217806/#review223686
Attachment #8948327 - Flags: review?(dtownsend) → review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c587bb954008
ESLint should ignore the tp5n dataset when extracted by Talos. r=mossop
https://hg.mozilla.org/mozilla-central/rev/c587bb954008
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Product: Testing → Firefox Build System
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.