Temporary freeze when moving a message (delete, folder move)

RESOLVED DUPLICATE of bug 1262517

Status

defect
--
major
RESOLVED DUPLICATE of bug 1262517
2 years ago
2 years ago

People

(Reporter: bigmuscle, Unassigned)

Tracking

({perf})

52 Branch
Unspecified
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [antivirus: ?])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36 OPR/50.0.2762.67

Steps to reproduce:

The issue appears every time when any e-mail (IMAP is used) is moved from one folder to another (e.g. incoming mail to spam folder, or mail deleted to bin) and "New mail" notification is displayed on the desktop at the same time.


Actual results:

Thunderbird freezes for tens of seconds or several minutes and is completely unresponsive. The issue appears on any computer where Thunderbird is used.


Expected results:

Tunderbird should move the message immediately without freezing.
You mean the notification that is out of the system tray?
Is sound enabled also?
And if you disable sound or notification the problem goes away?  (in options >  general > show an alert / play a sound)
Severity: normal → major
Flags: needinfo?(bigmuscle)
Keywords: perf
I mean this notification when incoming mail is received: http://cybernetnews.com/wp-content/uploads/2007/04/thunderbird5.jpg

When "Play a sound" is unticked, Thunderbird freezes too.
When "Show an alert" is unticked, Thunderbird freezes too, so it seems that the problem is unrelated to the notification and freezing appears if new message is moved shortly after receiving.
Flags: needinfo?(bigmuscle)
Which platform/OS is this?
Windows 10 64-bit, no antivirus (Defender disabled), but I remember the same problem on Win7 64-bit in the past.
Start *Windows'* safe mode with networking enabled
- win10 https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode
Still In Windows safe mode, start thunderbird in safe mode
- https://support.mozilla.org/kb/safe-mode-thunderbird

Does problem go away?
Summary: Freeze when moving a message while notification is displayed → Freeze when moving a message (delete, folder move,
Yes, problem does not appear in Windows safe mode.

So problem appears only in Windows normal mode and according to the debugger, the Thunderbird's main thread is frozen in xul.dll module.
> Yes, problem does not appear in Windows safe mode.

You would need to test disabling/removing the various software installed on top of Windows to find the cause. Typically antivirus software.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
Summary: Freeze when moving a message (delete, folder move, → Temporary freeze when moving a message (delete, folder move)
Whiteboard: [antivirus: ?]
As I said before, I don't have antivirus and this issue appears on several computers regardless the OS version or used hardware.

Also, no other application freezes, only Thunderbird does.
(In reply to Big Muscle from comment #8)
> As I said before, I don't have antivirus and this issue appears on several
> computers regardless the OS version or used hardware.

Then you'll need to look for something other than AV.  (Maybe a virus, since you don't have AV installed.)


> Also, no other application freezes, only Thunderbird does.

That's great for you. But apparently irrelevant (and it often is) to the case at hand.
On Windows 10, it could be Windows indexing service.
(In reply to Wayne Mery (:wsmwk) from comment #10)
> On Windows 10, it could be Windows indexing service.

Yes! That's it! Disabling Windows Search service "fixes" the problem immediately. But it's rather the workaround but not a real fix, because Thunderbird is not able to correctly work with standard Windows service.
Then you are probably seeing the problem described in bug 1262517
Component: Untriaged → OS Integration
OS: Unspecified → Windows 10
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1262517
You need to log in before you can comment on or make changes to this bug.