TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/message-header/test-reply-identity.js (due to removed menuitem-iconic-desc-noaccel)

RESOLVED FIXED in Thunderbird 60.0

Status

defect
--
major
RESOLVED FIXED
Last year
Last year

People

(Reporter: aceman, Assigned: aceman)

Tracking

Trunk
Thunderbird 60.0
All
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

Last year
SUMMARY-UNEXPECTED-FAIL | test-reply-identity.js | test-reply-identity.js::test_reply_no_matching_identity
 INFO -    EXCEPTION: identityList.selectedItem.label is undefined
 INFO -      at: test-reply-identity.js line 111
 INFO -         checkReply test-reply-identity.js:111 7
 INFO -         test_reply_no_matching_identity test-reply-identity.js:125 3

This is caused because the identity picker in compose window does not work, it does not open properly, showing no identities.
Assignee

Comment 1

Last year
Posted patch 1437306.patchSplinter Review
This is caused by missing chrome://global/content/bindings/menu.xml#menuitem-iconic-desc-noaccel binding, removed in bug 1418459.

The last user is in Linux theme. Can you see if we loose anything by just removing the reference?
The test passes with this change and identity picker works.
Attachment #8950009 - Flags: review?(richard.marti)
Assignee

Updated

Last year
Blocks: 1418459
Summary: TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/message-header/test-reply-identity.js → TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/message-header/test-reply-identity.js (due to removed menuitem-iconic-desc-noaccel)
Version: unspecified → Trunk
Comment on attachment 8950009 [details] [diff] [review]
1437306.patch

It's okay to remove here. I need to restore the removals from bug 1418459 in a new bug and add the binding globally.
Attachment #8950009 - Flags: review?(richard.marti) → review+
Assignee

Comment 3

Last year
Thanks.
Keywords: checkin-needed

Comment 4

Last year
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/10d683309c4d
remove menu.xml#menuitem-iconic-desc-noaccel binding. r=Paenglab
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

Last year
Target Milestone: --- → Thunderbird 60.0
You need to log in before you can comment on or make changes to this bug.