Closed Bug 1441239 Opened 2 years ago Closed 2 years ago

Touchscreen - touching tab close button doesn't work, until I touch the trackpad

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P2)

58 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1446904
Tracking Status
firefox58 --- affected
firefox59 --- affected
firefox60 --- affected

People

(Reporter: dylan_baxter, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180206200532

Steps to reproduce:

Touch the close button to close a tab. Sometimes it works, sometimes I get this result instead.


Actual results:

Tab is not closed. I can press and press and press and nothing happens...UNTIL I reach down and put ANY input to the trackpad. Suddenly my tab closes. Seems like broken input event handling, possibly related to https://bugzilla.mozilla.org/show_bug.cgi?id=1321069


Expected results:

The tab should have closed when I press the close button for that tab.
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

I have tested this issue on Windows 10 x64 with the latest Firefox release (58.0.2) and the latest Nightly (60.0a1-20180301024724) and managed to reproduce the issue.
When opening the browser and several tabs, after touching several times various tabs sometimes nothing happens. As soon as you touch the trackpad all tab events which has been previously done on tabs are runned.

I'm not sure if it is related to the issue you were mentioning(bug 1321069), however, I am going to assign "Core: Event Handling" component which seems to be appropriate for this.
Status: UNCONFIRMED → NEW
Component: Untriaged → Event Handling
Ever confirmed: true
Product: Firefox → Core
See Also: → 1447241
See Also: → 1447738
Duplicate of this bug: 1447241
(In reply to Emil Pasca [:emilpasca], Desktop Engineering QA from comment #1)
> 
> When opening the browser and several tabs, after touching several times
> various tabs sometimes nothing happens. As soon as you touch the trackpad
> all tab events which has been previously done on tabs are runned.

This I can reproduce, too. Nightly on a Surface Laptop with Windows 10.
Priority: -- → P2
FWIW, I was using a finger and not a stylus.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1446904
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.