Closed Bug 1443615 Opened 2 years ago Closed 2 years ago

Remove legacy Telemetry component `TelemetryLog`

Categories

(Toolkit :: Telemetry, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: chutten, Assigned: janerik)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 3 obsolete files)

After we stop reporting TelemetryLog in bug 1443614, we should remove it entirely.
Blocks: 1438873
Priority: -- → P4
Blocks: 1383408
Assignee: nobody → jrediger
Priority: P4 → P1
Depends on: 1420908
Last consumer removed in 1420908. Needs to wait for that to be merged.
Attachment #8964823 - Flags: review?(chutten)
Comment on attachment 8964823 [details] [diff] [review]
Remove legacy Telemetry component `TelemetryLog`

Review of attachment 8964823 [details] [diff] [review]:
-----------------------------------------------------------------

I think we can also remove the TelLog renderer and the telemetry log section from about:telemetry (and then we can remove some localized strings, too). If users need to see the nothing that we record to TelemetryLog, they can use the Raw JSON link :)
Attachment #8964823 - Flags: review?(chutten)
Attachment #8964934 - Flags: review?(chutten)
Attachment #8964823 - Attachment is obsolete: true
Comment on attachment 8964934 [details] [diff] [review]
Remove legacy Telemetry component `TelemetryLog`

Review of attachment 8964934 [details] [diff] [review]:
-----------------------------------------------------------------

I love red patches :)

Did you poke around in about:telemetry and check the devtools log for errors? I don't think there should be, but it might be prudent to check before pushing this.
Attachment #8964934 - Flags: review?(chutten) → review+
Duplicate of this bug: 1420909
I thought I did poke around on about:telemetry, but I did miss one obvious section (which made the site not even load).
Removed the last mention of telemetry-log and poked around with no errors or warnings popping up.
Attachment #8965236 - Flags: review?(chutten)
Attachment #8964934 - Attachment is obsolete: true
Comment on attachment 8965236 [details] [diff] [review]
Remove legacy Telemetry component `TelemetryLog`

Review of attachment 8965236 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome, thank you for your diligence!
Attachment #8965236 - Flags: review?(chutten) → review+
Keywords: checkin-needed
Hello, I've encountered the following error when applying this patch:

hg qpush -a
applying Bug-1443615---Remove-legacy-Telemetry-component-Te.patch
patching file toolkit/content/aboutTelemetry.js
Hunk #3 FAILED at 2443
1 out of 3 hunks FAILED -- saving rejects to file toolkit/content/aboutTelemetry.js.rej

Can you please take a look?
Flags: needinfo?(jrediger)
Attachment #8965236 - Attachment is obsolete: true
Rebased on latest upstream.
Flags: needinfo?(jrediger)
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ba89b2464447
Remove legacy Telemetry component `TelemetryLog`. r=chutten
Keywords: checkin-needed
My mistake. As noted earlier this is blocked by bug 1420908, waiting for that first.
Flags: needinfo?(jrediger)
bug 1420908 and its accompanying bug 1450801 are now merged. This one is ready for check-in now.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a1869efdd7aa
Remove legacy Telemetry component `TelemetryLog`. r=chutten
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/a1869efdd7aa
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.