Closed Bug 1443677 Opened 4 years ago Closed 3 years ago

Context Menus (right click) bring up incorrect menu on OOP IFrames

Categories

(Core :: XUL, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1505909

People

(Reporter: qdot, Unassigned)

References

Details

Right clicking on an oop iframe (see bug 1429896) brings up the context menu for the root page. We also get this error in the logs:

[Parent 13734, Main Thread] WARNING: Wrong button set to eContextMenu event?: 'mMessage != eContextMenu || button == ((mContextMenuTrigger == eNormal) ? eRightButton : eLeftButton)', file /share/code/mozbuild/1429896-oop-iframes/obj-ff-test/dist/include/mozilla/MouseEvents.h, line 300
Summary: Context Menus (right click) don't work with OOP IFrames → Context Menus (right click) bring up incorrect menu on OOP IFrames
Component: XP Toolkit/Widgets: Menus → XUL
Fission Milestone: --- → M3
Priority: -- → P3
Blocks: fission-frontend
No longer blocks: oop-frames, fission
Status: NEW → RESOLVED
Fission Milestone: M3 → ---
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1505909
You need to log in before you can comment on or make changes to this bug.