Closed Bug 1443687 Opened 2 years ago Closed 8 months ago

Using IFrame scrollbar on OOP IFrame can cause crash

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Fission Milestone M3

People

(Reporter: qdot, Unassigned)

References

(Blocks 1 open bug, )

Details

STR: 

- Open page with OOP Iframe
- Try to drag scrollbar with mouse

Expected:

Frame scrolls correctly

Actual:

Crashes occasionally, with following error:

Assertion failure: false (APZ and main thread confirmed scrollbar drag block with different targets), at /share/code/mozbuild/1429896-oop-iframes/gfx/layers/apz/src/InputBlockState.cpp:72
Marking P3 until we verify this continues after architecture changes.
Priority: -- → P3
Blocks: fission
Blocks: fission-events
No longer blocks: oop-frames, fission
Component: DOM: Core & HTML → User events and focus handling

Test case: https://hsivonen.fi/fission-scroll.html

Scroll bars are not displayed. Mouse wheel scrolling the iframes doesn't work. Keyboard scrolling the iframes does not work. The latter two seem like they belong to APZ. The first issue is Layout, maybe?

Thanks Henri. Adding ni for Jonathan and Botond to look into it.

Flags: needinfo?(jwatt)
Flags: needinfo?(botond)

comment 2 seems to describe a different set of issues than comment 0. Should we track it in a different bug?

Flags: needinfo?(botond)

(In reply to Botond Ballo [:botond] from comment #4)

comment 2 seems to describe a different set of issues than comment 0. Should we track it in a different bug?

Filed as bug 1540665 and bug 1540666.

Marking this one dependent on bug 1540666, since at present this one can't be reproduced due to the scrollbars not appearing.

Depends on: 1540666

Moved the needinfo against myself to bug 1540666.

Flags: needinfo?(jwatt)

If you still see the assertion failure in comment 0 after bug 1540665 is properly fixed, feel free to move this bug to the "Core :: Panning and Zooming" component and I can take a look.

Fission Milestone: --- → ?

qdot, do you still see this now the scrollbars appear?

Flags: needinfo?(kyle)

Nope, working for me now. I guess I'll call this fixed by way of its dependencies being fixed.

Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(kyle)
Resolution: --- → FIXED
Fission Milestone: ? → M3
You need to log in before you can comment on or make changes to this bug.