Open Bug 144484 Opened 20 years ago Updated 9 years ago

"Send Page ..." menu option does not integrate with external mail clients (Outlook, Eudora, etc.)

Categories

(SeaMonkey :: UI Design, enhancement)

x86
Windows 95
enhancement
Not set
normal

Tracking

(Not tracked)

People

(Reporter: feanor73, Assigned: jag+mozilla)

References

Details

Outlook is my default mail client AND I have modified my
user preferences to include:
"// Use default mail client
user_pref("network.protocol-handler.external.mailto", true);"

The menu option "Send Page ..." from the right-click menu or from
the File menu opens up Mozilla Mail instead of a new Outlook window.
Note that "mailto:" links properly open with a new Outlook window
now that I have added the above user preference.

Mozilla 1.0 RC 1 Build ID "2002041711".

*** This bug has been marked as a duplicate of 11459 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
REOPEN:
mailto: -> system default when mailnews installed works, but that is not the
problem here.

Send link could work via a mailto: URL (see bug 152526), but not Send Page,
because of RFC 2368.

   The mailto URL is
   primarily intended for generation of short text messages that are
   actually the content of automatic processing (such as "subscribe"
   messages for mailing lists), not general MIME bodies.

Unless there is some MAPI alternative, this might not be possible, and if it was
possible, perhaps Windows-only.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
-> XP APPS
Assignee: matti → jaggernaut
Component: Browser-General → XP Apps
QA Contact: imajes-qa → paw
This bug is a duplicate of bug 152526.

*** This bug has been marked as a duplicate of 152526 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
REOPEN:
Bug 152526 can be fixed by using mailto: URLs for the menu command.

As I've said here, that is not possible w/ send page.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
I can confirm this.

From Bug 152526 Comment 9

Some organizations do not use Mozilla MailNews and are tied to Outlook for one
reason or another. Having Send Page/Link use Mozilla Mail can be a major issue
for them.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Given what happened with bug 144828, I'd guess this bug is not fixable.  Even if 
Outlook has some interface to pass it an entire block of data for mailing, it's 
likely proprietary and I doubt that anyone wants to start making Outlook- 
specific fixes to Mozilla or Thunderbird.
If we are talking about Windows-only, MAPI might do this, and there is some
support for that in mozilla code base. 

My point is that send link and send page are very different (even though they
sound like the same thing).

A windows only MAPI solution would work for me.
This is one of the nice things about IE: I can send a page from it into Eudora 
and don't have to use their mail client (Outlook in this case).
OS: Windows 2000 → Windows 95
Summary: "Send Page ..." menu option does not integrate with Outlook → "Send Page ..." menu option does not integrate with external mail clients (Outlook, Eudora, etc.)
*** Bug 209730 has been marked as a duplicate of this bug. ***
Blocks: 164421
IE saves the page and passes the file to the mail client as an attachment. 
Would this approach be easier than attempting to send the page as the message? 
We could almost get around using MAPI; however, many mail clients do not support
mailto:recipient?attachment="filename" syntax.
That is a good idea. Does anyone know if that is a de facto parameter that is
commonly used?

It is not part of the spec:

http://www.faqs.org/rfcs/rfc2368.html
I might have worded that poorly.  IE _uses MAPI_, but saves the file and sends
it as an attachment.
I just thought of something.  We could call the Send To->Mail Recipient that
Explorer uses, which is basically a virtual drag-and-drop of the attachment into
the mail program.  I found info on that here:
http://www.codeproject.com/useritems/sendtomail.asp?print=true
Unfortunately, it looks like you have to simulate the drag-and-drop; there is no
command line method of attaching the file.
I don't know which is easier to interface, MAPI directly, or Send To.  Here's a
MAPI send mail implementation that doesn't look too bad:
http://codeguru.com/internet/imapi.shtml
Send To | Mail Recipient is just an OS wrapper that invokes the systemwide MAPI 
client.  Programmatically, using MAPI would be much simpler.

re: comment 14:  Are there *any* mail clients that support   
  ?attachment=filename   
on a mailto: URL?  Mozilla accepts an attachment spec on the command line, but 
not (AFAICT) on a mailto.
*** Bug 228863 has been marked as a duplicate of this bug. ***
*** Bug 233432 has been marked as a duplicate of this bug. ***
Benc, you said there's some MAPI support in the codebase... is there any
documentation on how that code works?  It seems it's only in mailnews and may
onl y be for address book stuff... i.e. it might only be incoming and not
outgoing...
*** Bug 254259 has been marked as a duplicate of this bug. ***
Aaron: ask mscott or sspitzer about it, they were working @netscape when that
stuff was added. 
Something's wrong with this picture - IE can do it and mozilla can't??
Product: Core → Mozilla Application Suite
*** Bug 254259 has been marked as a duplicate of this bug. ***
*** Bug 254259 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 372824
At some point, Safari added support for this. I don't know how it works, or when it was added, but I tried it w/ Mail.app, and it works.
Since this bug originally dealt with SeaMonkey (presumably Mozilla Suite at the time), & since neither SeaMonkey 2 (probably since Bug 152526 landed) nor FF any longer have a "File | Send Page...", should this be marked as <INVALID>?
 
 
As far as having this functionality, I was told, "<NeilAway> therube: we can't send a page to an external mail client".
No, but I guess you could make it a RFE.
I think this can be marked as RESOLVED INVALID, WONTFIX or WORKSFORME, as the send page functionality isn't in Firefox anymore.
Status: NEW → RESOLVED
Closed: 19 years ago10 years ago
Resolution: --- → WONTFIX
Still exists in:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110828 SeaMonkey/2.6a1
Re-opening.
Severity: normal → enhancement
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.