Last Comment Bug 152526 - Menu->Send link does not open external mail app (should use mailto:)
: Menu->Send link does not open external mail app (should use mailto:)
Status: RESOLVED FIXED
: fixed-seamonkey2.0.1, fixed-seamonkey2.0.3
Product: SeaMonkey
Classification: Client Software
Component: UI Design (show other bugs)
: Trunk
: All All
: -- normal with 7 votes (vote)
: seamonkey2.1a1
Assigned To: neil@parkwaycc.co.uk
: benc
Mentors:
: 124417 174285 223186 250788 (view as bug list)
Depends on: 533176 534647
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-18 01:07 PDT by Stephan Slabihoud
Modified: 2009-12-14 09:25 PST (History)
20 users (show)
asa: blocking1.8a5-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Proposed patch (570 bytes, patch)
2009-11-13 06:53 PST, neil@parkwaycc.co.uk
iann_bugzilla: review+
Details | Diff | Review
With renamed variable (2.90 KB, patch)
2009-11-17 02:11 PST, neil@parkwaycc.co.uk
iann_bugzilla: review+
iann_bugzilla: approval‑seamonkey2.0.1+
Details | Diff | Review
Don't use prefs directly (1.21 KB, patch)
2009-12-07 09:14 PST, neil@parkwaycc.co.uk
cbiesinger: review+
kairo: approval‑seamonkey2.0.3+
Details | Diff | Review

Description Stephan Slabihoud 2002-06-18 01:07:07 PDT
I use
user_pref("network.protocol-handler.external.mailto", true);
in my users.js

Clicking on a "mailto:" link in the browser and news/mail window opens the
external mail app.

Unfortunately "Menu->Send link" opens the internal mail app.
Comment 1 alanjstr 2002-06-18 06:10:16 PDT
I don't think Mozilla has this ability yet.  I've seen a bug about this somewhere.
Comment 2 freiheit 2002-09-15 21:17:36 PDT
Well add me to the list of people who would like to see this implemented.  For
the sake of consistency and respecting a user's preferences it just makes sense
that any code which calls up the Mail client from the browser should check to
see if the user has opted to use an external mail client.  I have no desire to
migrate my existing email into Mozilla Mail (at this time) and when I send any
mail from the browser (including Send Link and Send Page) I want a record of it
in my chosen email client's Sent folder.
Comment 3 benc 2003-03-06 11:28:06 PST
I don't think this is a dupe. There is one bug that mentions it, but it comes
out of the drift of a long bug.

This also probably is not a MailNews bug, but a browser-only bug.

Chimera (bug 146321) and Phoenix (bug 173954) have looked at this problem.

Comment 4 benc 2003-03-06 13:16:34 PST
*** Bug 174285 has been marked as a duplicate of this bug. ***
Comment 5 benc 2003-03-06 13:20:06 PST
*** Bug 124417 has been marked as a duplicate of this bug. ***
Comment 6 benc 2003-03-06 13:24:03 PST
-> QA to me.

I've also searched the entire bugzilla database for "Send page" and "Send link"
bugs that complain that it does not work w/ non-MailNews configs, and moved them
here.

This really is just a browser feature, where you stub the URL into a mailto:
URL, and punt it to the OS, not a MailNews feature. For example, if you were to
test Chimera or Phoenix, no mailnews QA would participate, but Networking QA
would need to test to make sure the mailnews URL is constructed and the mailto:
protocol handling is stubbed correctly to the OS.

It is also possible that I will take over qa of
"network.protocol-handler.external.mailto" eventually as well.
Comment 7 Rich hart 2003-03-26 05:53:40 PST
Please get this emplemented soon!
Comment 8 Paul Wyskoczka 2003-04-01 07:30:58 PST
*** Bug 144484 has been marked as a duplicate of this bug. ***
Comment 9 Bob Clary [:bc:] 2003-06-06 14:40:02 PDT
Seth, how hard would this be to fix along with the related Bug 144484 ?

Some organizations do not use Mozilla MailNews and are tied to Outlook for one
reason or another. Having Send Page/Link use Mozilla Mail can be a major issue
for them.
Comment 10 Aaron Kaluszka 2003-06-27 09:54:48 PDT
I'd imagine the Firebird patch would take little modification to work here.
Comment 11 Jesper Hertel 2003-06-27 10:02:01 PDT
Why the change of the OS field from Windows 2000 to Windows 95? The problem also
exists on my Windows 2000 machine.

Maybe it's not important; I just wondered.
Comment 12 Mike Cowperthwaite 2003-06-27 10:04:47 PDT
Note that with the fix to bug 144828, the Send Link functionality will use the 
external mail client IF Mozilla is installed as browser-only (no Mail/News).

Send Page to another client (bug 144484) is apparently not feasible.

I doubt these are Windows-only bugs, but even if they are there isn't much to be 
gained by switching the OS from Win2K to Win95.  Bugzilla's Platform and OS 
fields are really not quite up to the task.
Comment 13 Lewis Jardine 2003-07-18 17:36:43 PDT
For the record, the various windows-blah OS options mean 'the windows OS
selected, and every windows OS after it', in the order (IIRC) listed in the
combobox.

So setting OS = win95 means that it affects 95, and every version of windows
below 95, namily

windows 95, windows 98, windows ME, windows NT 4.0, windows 2000, and windows XP.

So now you know :)

Correct me if I'm wrong, the vast majority of supported platforms do not have a
mechanism for declaring the OS default mail client. (The only one I can think of
besides windows is OSX, and I'm not sure if it does or not).

On the other hand, Mozilla should probably be doing by opening a mailto: on
every platform, and letting the system handle it where facilities exist.
Comment 14 Oleg Sidletskiy 2003-11-28 14:14:20 PST
*** Bug 223186 has been marked as a duplicate of this bug. ***
Comment 15 Jesse Weinstein 2004-06-06 21:07:56 PDT
(In reply to comment #13)
> (The only one I can think of
> besides windows is OSX, and I'm not sure if it does or not).
It does(I'm on Mac OS 10.3), however, as you said, Send Link should just be a
mailto link.  Is anyone working on patch for this?  If not, I'll work on one...
Comment 16 Jesse Weinstein 2004-06-06 21:14:42 PDT
(In reply to comment #13)
> (The only one I can think of
> besides windows is OSX, and I'm not sure if it does or not).
It does(I'm on Mac OS 10.3), however, as you said, Send Link should just be a
mailto link.  Is anyone working on patch for this?  If not, I'll work on one...
Comment 17 Max Alekseyev 2004-06-30 16:43:51 PDT
*** Bug 234024 has been marked as a duplicate of this bug. ***
Comment 18 Brent Garber 2004-06-30 16:54:34 PDT
RE: Comment 13

For windows: COntrol Panel>>Internet Options>>Programs Tab>>E-Mail Drop-down
box, select <<Your Program Here> be it TB, or OE, or the Moz built-in.
Comment 19 neil@parkwaycc.co.uk 2004-07-10 13:23:52 PDT
*** Bug 250788 has been marked as a duplicate of this bug. ***
Comment 20 Christian :Biesinger (don't email me, ping me on IRC) 2004-07-10 13:26:32 PDT
Bug 250788 has a description how this could be implemented
Comment 21 benc 2004-10-28 07:50:47 PDT
+mscott.

Promoting thunderbird is a good thing for mozilla, so I'd like to put this up
for consideration.

stop me if I'm wrong, but w/ the powers of lxr, I found the menu command lives at:

http://lxr.mozilla.org/mozilla/source/xpfe/browser/resources/content/mailNavigatorOverlay.xul#106

And in firefox, the code is here:

http://lxr.mozilla.org/mozilla/source/browser/base/content/browser.js#4830
Comment 22 benc 2004-10-30 00:23:40 PDT
bah. The code is all in mailNavigatorOverlay.xul, it just needs to be tweeked.

Patch coming up... if I can remember how to build...
Comment 23 Robert Kaiser (not working on stability any more) 2009-06-14 15:12:02 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 24 neil@parkwaycc.co.uk 2009-11-13 06:53:11 PST
Created attachment 412207 [details] [diff] [review]
Proposed patch

Seeing as we now always bundle mail, changing the test seems to be best.
Comment 25 Ian Neal 2009-11-16 16:39:33 PST
Comment on attachment 412207 [details] [diff] [review]
Proposed patch

The variable name is no longer correct with this change, so should be renamed - perhaps gUseIntegratedMailClient?
r=me with that fixed.
Comment 26 neil@parkwaycc.co.uk 2009-11-17 02:11:31 PST
Created attachment 412810 [details] [diff] [review]
With renamed variable

I also reversed the way the variable works which cut down on the number of !s.
Comment 27 neil@parkwaycc.co.uk 2009-11-22 15:52:56 PST
Pushed changeset b56cbbc73d87 to comm-central.
Comment 28 neil@parkwaycc.co.uk 2009-11-23 16:16:50 PST
Comment on attachment 412810 [details] [diff] [review]
With renamed variable

Worth a try, I guess :-)
Comment 29 Ian Neal 2009-11-24 04:35:58 PST
Comment on attachment 412810 [details] [diff] [review]
With renamed variable

I suppose this a fix rather an enhancement so a=me
Comment 30 neil@parkwaycc.co.uk 2009-11-26 06:03:58 PST
Pushed changeset 455177197a6a to releases/comm-1.9.1
Comment 31 Serge Gautherie (:sgautherie) 2009-12-02 07:40:12 PST
(In reply to comment #30)
> Pushed changeset 455177197a6a to releases/comm-1.9.1

http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey2.0&maxdate=1259205362&hours=12
This changeset caused
[
TEST-PASS | chrome://mochikit/content/browser/suite/smile/test/browser_ApplicationPrefs.js | A single preference should not be locked.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/suite/smile/test/browser_ApplicationPrefs.js | Timed out
]
on all platforms.

Regression timeframe:
http://hg.mozilla.org/releases/comm-1.9.1/pushloghtml?fromchange=39add317ae93&tochange=455177197a6a

(I don't know about SM 2.1.)
Comment 32 Serge Gautherie (:sgautherie) 2009-12-06 08:25:33 PST
(In reply to comment #31)
> TEST-UNEXPECTED-FAIL |
> chrome://mochikit/content/browser/suite/smile/test/browser_ApplicationPrefs.js
> | Timed out

Doesn't time out when running alone or /suite/smile/*,
times out (with no (error) console output) when running /suite/*...
Comment 33 neil@parkwaycc.co.uk 2009-12-06 15:25:31 PST
(In reply to comment #32)
> (In reply to comment #31)
> > TEST-UNEXPECTED-FAIL |
> > chrome://mochikit/content/browser/suite/smile/test/browser_ApplicationPrefs.js
> > | Timed out
> Doesn't time out when running alone or /suite/smile/*,
> times out (with no (error) console output) when running /suite/*...
I can confirm that this is somehow due to the use of Application.prefs in mailNavigatorOverlay.xul; if I switch that to a normal pref branch then the tests pass.
Comment 34 Serge Gautherie (:sgautherie) 2009-12-06 16:03:08 PST
I'll attach a patch to bug 533176 which seems to (help) fix this...
Comment 35 neil@parkwaycc.co.uk 2009-12-07 09:14:26 PST
Created attachment 416427 [details] [diff] [review]
Don't use prefs directly

This also fixes --disable-mailnews builds, I guess.
Comment 36 Christian :Biesinger (don't email me, ping me on IRC) 2009-12-07 09:16:55 PST
Comment on attachment 416427 [details] [diff] [review]
Don't use prefs directly

+                  .getProtocolHandler("mailto")
+                   instanceof Components.interfaces.nsIExternalProtocolHandler;

I think this indentation is somewhat misleading, since it makes it look like instanceof is a continuation of the previous expression. I'd probably indent it to the same level as "Components", but feel free to go with whatever you prefer.
Comment 37 Serge Gautherie (:sgautherie) 2009-12-07 20:02:23 PST
(In reply to comment #34)
> I'll attach a patch to bug 533176 which seems to (help) fix this...

Ftr, that patch did "fix" this failure on Windows (though I've no idea why),
but did not on Linux: hopefully, your patch will.
(MacOSX has not completed yet.)
Comment 38 neil@parkwaycc.co.uk 2009-12-08 11:36:13 PST
Pushed changeset ede628c2cf8f to comm-central.
Comment 39 neil@parkwaycc.co.uk 2009-12-08 16:06:12 PST
(In reply to comment #36)
>(From update of attachment 416427 [details] [diff] [review])
>>+                  .getProtocolHandler("mailto")
>>+                   instanceof Components.interfaces.nsIExternalProtocolHandler;
>I think this indentation is somewhat misleading, since it makes it look like
>instanceof is a continuation of the previous expression. I'd probably indent it
>to the same level as "Components", but feel free to go with whatever you
>prefer.
Sorry, I forgot to address this :-(
Comment 40 Serge Gautherie (:sgautherie) 2009-12-09 10:43:18 PST
(In reply to comment #37)
> (In reply to comment #34)
> > I'll attach a patch to bug 533176 which seems to (help) fix this...
> 
> Ftr, that patch did "fix" this failure on Windows (though I've no idea why),
> but did not on Linux: hopefully, your patch will.
> (MacOSX has not completed yet.)

Actually, (MacOSX is still orange and) Windows changed from perma-orange to random-orange only :-/
Comment 41 Serge Gautherie (:sgautherie) 2009-12-09 10:44:35 PST
(In reply to comment #38)
> Pushed changeset ede628c2cf8f to comm-central.

Can this land on c-1.9.1 (with approval)?
Comment 42 neil@parkwaycc.co.uk 2009-12-09 12:16:22 PST
Pushed changeset 7b80393d1152 to releases/comm-1.9.1

(Still without the whitespace change, for consistency.)
Comment 43 Serge Gautherie (:sgautherie) 2009-12-09 18:41:55 PST
(In reply to comment #42)
> Pushed changeset 7b80393d1152 to releases/comm-1.9.1

Well, that didn't fix it either on SM 2.0 :-/
(Is it fixed for you on SM 2.1?)
Comment 44 neil@parkwaycc.co.uk 2009-12-10 01:43:44 PST
(In reply to comment #43)
> Is it fixed for you on SM 2.1?
Yes, the patch fixes my SM2.1a1pre Linux test box.
Comment 45 neil@parkwaycc.co.uk 2009-12-10 01:44:19 PST
Although now that I think about it that was only with the test path of suite/

Note You need to log in before you can comment on or make changes to this bug.