Closed Bug 1445266 Opened 6 years ago Closed 5 days ago

New Tab page elements are not rendered in High Contrast mode (Windows theme)

Categories

(Firefox :: New Tab Page, defect, P3)

All
Windows
defect

Tracking

()

RESOLVED INVALID
Accessibility Severity s2
Tracking Status
firefox-esr68 --- affected
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- affected
firefox75 --- affected
firefox76 --- affected
firefox77 --- affected
firefox84 --- affected
firefox85 --- affected
firefox86 --- affected

People

(Reporter: cmuresan, Unassigned)

References

Details

(Keywords: access, Whiteboard: [fidefe-quality-foundation])

Attachments

(2 files)

[Affected versions]:
- Firefox 57 and up

[Affected Platforms]:
- All Windows

[Prerequisites]:
- Latest Activity Stream system add-on is available for a clean profile.

[Steps to reproduce]:
1. Go to High Contrast settings in Windows.
2. Choose a different theme. (High Contrast 1, High Contrast 2, High Contrast Black, High Contrast White)
3. Open the browser with the profile from prerequisites.
4. Observe the Search bar, Top Sites, Highlights and Context menu elements.

[Expected result]:
- All the elements of the page are rendered and the high contrast theme is correctly applied.

[Actual result]:
- The Search bar:
    No search icon is visible
    The arrow is not visible in the search button and it has no hover effect.
    Search suggestions have no hover effect.

- Top Sites and Highlights:
    The tiles have no hover effect.
    The context menu button and the options within have no icons.
    The context menu options have no hover effect.
    Section context menu is not visible.
Component: Activity Streams: Newtab → New Tab Page

I can still reproduce this in Firefox Beta 85.0b5 (Build ID: 20210105185604), Firefox Release 84.0.2 (Build ID: 20210105180113), Firefox Nightly 86.0a1 (Build ID: 20210107040715) using Windows 10.

Severity: normal → S3
Whiteboard: [fidefe-quality-foundation]
Accessibility Severity: --- → s2

The majority of the elements mentioned here are no longer present in the current new tab design, and most of the ones that are present seem to have been fixed.

The one thing that I do still see is the top site tile hover effect being entirely missing; I would guess that this is because it's implemented entirely as a background color change, and in high contrast we're not rendering the background.

It seems like in other parts of the browser we're using the selected text color as the background for this kind of hover effect, so I'm assuming that's what should be here also. I would also think that there should be a border around the tile in high contrast, whether its hovered or not. We should make sure I'm on the right track with that before anything gets landed though.

The severity field for this bug is set to S3. However, the accessibility severity is higher, .
:amy, could you consider increasing the severity?

For more information, please visit BugBot documentation.

Flags: needinfo?(achurchwell)

The new tab page recently went under an accessibility review. The remaining issues here will be addressed in bug 1893056 and bug 1893730.

See also: [meta] Firefox surfaces should use standardised HCM components.

Status: NEW → RESOLVED
Closed: 5 days ago
Flags: needinfo?(achurchwell)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: