Graphical issue with skin for Nightly

RESOLVED FIXED in Firefox 60

Status

()

defect
P1
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: wqese2, Assigned: dao)

Tracking

(Depends on 2 bugs, {nightly-community, regression})

61 Branch
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 fixed, firefox61 fixed)

Details

()

Attachments

(2 attachments)

Reporter

Description

Last year
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180317220121

Steps to reproduce:

Once opened Nightly window on 1080p monitor, and moved into 1440p monitor,  Skin doesn't adjust, and just have this greenish spot.
https://i.imgur.com/vovfekq.png


Actual results:

https://i.imgur.com/vovfekq.png


Expected results:

Adjust skin width correctly.

did not have this problem with Firefox quantum.
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Hi wqese2, thanks for reporting this issue.

I wasn't able to reproduce the issue on Windows 10 x64, using latest Nightly 61.0a1 (2018-03-21) and Firefox Release 59.0.1. 
I've set the following values for the monitors:
- monitor 1: 1920 x 1080
- monitor 2: 1440 x 900

After setting the custom values for resolution, I've installed the theme you are using (https://addons.mozilla.org/en-US/firefox/addon/deep-dark-blue-forest/?src=collection&collection_id=325c993e-0379-4151-adb5-ad28dccc41fd), but I wasn't able to reproduce the issue you described after moving the browser window between the 2 screens.

Could you please retest this issue using a new clean Firefox profile (https://goo.gl/7Fec9d), maybe even safe mode (https://goo.gl/AR5o9d), to eliminate custom settings as a possible cause?

Thanks.
Component: Untriaged → Theme
Flags: needinfo?(wqese2)
Reporter

Comment 2

Last year
Okay, did it on clean profile, Its the same

But this time i know exactly when this happens.

Made video explaining:

https://youtu.be/YUVNcr1SA4c



I have 2 screens

One bigger   2560x1440

Smaller  1920x1080

When My browser first opens on Bigger screen,  there is no problem.

If it opens first on small screen,  and I move it and maximize to bigger screen,  theme doesn't adjust.
Flags: needinfo?(wqese2)
Reporter

Comment 3

Last year
Checked also  on 59.0.1   It works as it should. no matter on which screen window opens first
Tested again using the following resolutions available:2560 x 1440 and 1680 x 1050 and managed to reproduce it intermittently on Nightly 61.0a1 (2018-03-29).

I'll try to narrow down a regression window asap.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Updated

Last year
Assignee

Comment 5

Last year
(In reply to Carmen Fat [:carmenf] from comment #4)
> I'll try to narrow down a regression window asap.

Any update?
Flags: needinfo?(carmen.fat)
Sorry for the delay!

I have tested this issue on Windows 10 x64, using the STR  from comment 2, performed a regression, the result as follows:

Last good revision: 994a8d6eccbcdc6106794705bd77e3ac5f031be2 (2018-02-15)
First bad revision: c4d818c138689a66a397393fe1dd259ef0943b35 (2018-02-16)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=994a8d6eccbcdc6106794705bd77e3ac5f031be2&tochange=c4d818c138689a66a397393fe1dd259ef0943b35

I wasn't able to bisect more since the tool didn't provide me more builds, so this is the best I could do.
Flags: needinfo?(carmen.fat)
Might be bug 1438573? Is that plausible, Dao?
Flags: needinfo?(dao+bmo)
Assignee

Comment 8

Last year
(In reply to Mike Conley (:mconley) (:⚙️) (Totally backlogged on reviews and needinfos) from comment #7)
> Might be bug 1438573? Is that plausible, Dao?

Yeah, looks like I removed too much.
Assignee: nobody → dao+bmo
Blocks: 1438573
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
Comment hidden (mozreview-request)
Assignee

Updated

Last year
Priority: -- → P1
Comment on attachment 8969624 [details]
Bug 1446762 - Update the lwt header image on resolution change.

https://reviewboard.mozilla.org/r/238408/#review244318

This should work but I have never heard of `resolutionchange` so know if it works on every platform.
Attachment #8969624 - Flags: review?(MattN+bmo) → review+

Comment 11

Last year
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3a2fedfeaa96
Update the lwt header image on resolution change. r=MattN

Comment 12

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/3a2fedfeaa96
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Assignee

Comment 13

Last year
wqese2, would you please check if this is fixed for you in the latest Nightly?
Flags: needinfo?(wqese2)
Reporter

Comment 14

Last year
Sorry, i tested both in my profile, and that clean one i created to test it last time.
Still same issue.

https://youtu.be/VeLlpZxlMiQ
Flags: needinfo?(wqese2)
Assignee

Updated

Last year
Flags: needinfo?(dao+bmo)
Assignee

Comment 15

Last year
Approval Request Comment
[Feature/Bug causing the regression]: bug 1438573
[User impact if declined]: lightweight theme header image can be too small in a multi-monitor setting
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: see comment 2
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple backout
[String changes made/needed]: /
Attachment #8970448 - Flags: approval-mozilla-beta?
Dão, from comment 14 it sounds like it might not be fixed in the first patch. 

Carmen, can you reproduce this on nightly, or verify the fix? Thanks!
Flags: needinfo?(carmen.fat)
Assignee

Comment 17

Last year
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #16)
> Dão, from comment 14 it sounds like it might not be fixed in the first
> patch. 

I'm still investigating that, but that patch is not what I want to uplift anyway.
Flags: needinfo?(dao+bmo)
Comment on attachment 8970448 [details] [diff] [review]
bug 1438573 backout for uplift

backout bug 1438573 for causing a regression, approved for 60.0b16
Attachment #8970448 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Tested again on latest Nightly 61.0a1 (2018-04-26) using Windows 10 x64. I wasn't able to reproduce the issue anymore. The theme rendered correctly to the new resolution of the second monitor.
Flags: needinfo?(carmen.fat)
Assignee

Updated

Last year
Depends on: 1457186
Assignee

Updated

Last year
Depends on: 1457189
Assignee

Comment 21

Last year
I think I found the missing pieces that prevent this from working consistently; filed bug 1457186 and bug 1457189.
Assignee

Updated

Last year
Depends on: 1457436
Assignee

Updated

Last year
Depends on: 1457437
Reporter

Comment 22

Last year
Hi guys,

I'm on new system now (upgraded a lot), and that smnall bug was one of first thing I tried after fresh windows install and some drivers.
It's not fixed yet. 
Theme still wont adjust when moving nightly from smaller screen to bigger one.
Assignee

Updated

Last year
Duplicate of this bug: 1439415
Assignee

Updated

Last year
See Also: → 1463019
Assignee

Updated

Last year
See Also: 1463019
You need to log in before you can comment on or make changes to this bug.