Closed Bug 1447536 Opened 4 years ago Closed 2 years ago

Feature Request: Add position=x,y to --new-window command

Categories

(Toolkit :: Startup and Profile System, enhancement, P5)

enhancement

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: eng, Assigned: mkaply)

References

Details

(Keywords: dev-doc-needed, parity-chrome, parity-ie, Whiteboard: [DUPEME?])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36

Steps to reproduce:

This is a feature request.

Add "--start-fullscreen" and "position=x,y" to "--new-window" command. This is implemented in Chrome. It helps for kiosk-like applications w/o user input.


Actual results:

firefox.exe -new-window http://localhost/monitor.html --position=0,0 --start-fullscreen


Expected results:

Browser loads page in correct position (multiple monitors require changing starting position) in fullscreen.
Probably a duplicate of bug 158968.
Severity: normal → enhancement
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Component: Untriaged → Startup and Profile System
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Whiteboard: [parity-chrome][parity-ie][DUPEME?]
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Whiteboard: [parity-chrome][parity-ie][DUPEME?] → [DUPEME?]
Priority: -- → P5
Duplicate of this bug: 1633321
Assignee: nobody → mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

so this patch is pretty simple. It just adds left and top to our existing width/height parameters.

In my testing, it works on the first profile, but none of this works with the -new-window parameter.

Well, chrome requires multiple different instances to be up to do start kiosk mode in multiple screens as well. While not perfect, at least matching their functionality is much better than not having the option at all.

This page should be updated:

https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options

it never had width/height either

Keywords: dev-doc-needed
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/00f21c6e82bc
Add left/top command line options. r=mconley
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

The patch actually missed the second half of the request. What shall we do with the --start-fullscreen argument?

Flags: needinfo?(mozilla)

The patch actually missed the second half of the request. What shall we do with the --start-fullscreen argument?

We have kiosk which should be the equivalent.

Flags: needinfo?(mozilla)

Ah thanks.

Summary: Feature Request: Add --start-fullscreen and position=x,y to --new-window command → Feature Request: Add position=x,y to --new-window command
You need to log in before you can comment on or make changes to this bug.