Closed Bug 1447611 Opened 2 years ago Closed 2 years ago

Remove --enable-stylo

Categories

(Firefox Build System :: General, enhancement)

3 Branch
enhancement
Not set

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(4 files)

No description provided.
Comment on attachment 8960925 [details]
Bug 1447611: Remove --enable-stylo and --enable-stylo-build-bindgen.

https://reviewboard.mozilla.org/r/229660/#review235432
Attachment #8960925 - Flags: review+
Comment on attachment 8960926 [details]
Bug 1447611: Remove references to stylo prefs from Troubleshoot.jsm.

https://reviewboard.mozilla.org/r/229662/#review235434
Attachment #8960926 - Flags: review?(jwatt) → review+
Comment on attachment 8960927 [details]
Bug 1447611: Remove now-unused AppConstants.MOZ_STYLO.

https://reviewboard.mozilla.org/r/229664/#review235436
Attachment #8960927 - Flags: review?(jwatt) → review+
Comment on attachment 8960928 [details]
Bug 1447611: Cleanup prefs that do nothing now.

https://reviewboard.mozilla.org/r/229666/#review235438
Attachment #8960928 - Flags: review?(jwatt) → review+
Attachment #8960925 - Flags: review?(core-build-config-reviews) → review?(nfroyd)
Comment on attachment 8960925 [details]
Bug 1447611: Remove --enable-stylo and --enable-stylo-build-bindgen.

https://reviewboard.mozilla.org/r/229660/#review235504

And we've already handled all the mozconfig bits previously, right?

Please post about this in dev-platform so people know that `--disable-stylo` is no longer a thing.

::: modules/libpref/init/all.js:5923
(Diff revision 1)
>  
>  // Is Stylo CSS support built and enabled?
>  // Only define these prefs if Stylo support is actually built in.
> -#ifdef MOZ_STYLO
> -#ifdef MOZ_STYLO_ENABLE
>  pref("layout.css.servo.enabled", true);

TODO: remove this pref, too, right?  I guess you mentioned that in the commit message.
Attachment #8960925 - Flags: review?(nfroyd) → review+
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bb84ac6e1468
Remove --enable-stylo and --enable-stylo-build-bindgen. r=froydnj
https://hg.mozilla.org/integration/mozilla-inbound/rev/86c9fed44da2
Remove references to stylo prefs from Troubleshoot.jsm. r=jwatt
https://hg.mozilla.org/integration/mozilla-inbound/rev/01ada1c5a95f
Remove now-unused AppConstants.MOZ_STYLO. r=jwatt
https://hg.mozilla.org/integration/mozilla-inbound/rev/c6193142bbcf
Cleanup prefs that do nothing now. r=jwatt
backed out for  mass failures KeyError: 'enable_stylo'

backout: https://hg.mozilla.org/integration/mozilla-inbound/rev/1fadea75f3630176098917eb3e085c57a42a793f

push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=c6193142bbcf6dbd7e7562243282f543310a0ea1

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=169478827&repo=mozilla-inbound&lineNumber=405

[task 2018-03-21T16:55:58.403Z] Running: python2.7 /builds/worker/workspace/mozharness/scripts/desktop_unittest.py  --config-file /builds/worker/workspace/mozharness/configs/unittests/linux_unittest.py --config-file /builds/worker/workspace/mozharness/configs/remove_executables.py --no-read-buildbot-config --installer-url=https://queue.taskcluster.net/v1/task/S2B6CeNHQw-mhKRdNAjh0Q/artifacts/public/build/target.tar.bz2 --test-packages-url=https://queue.taskcluster.net/v1/task/S2B6CeNHQw-mhKRdNAjh0Q/artifacts/public/build/target.test_packages.json --mochitest-suite=mochitest-media --e10s --allow-software-gl-layers --total-chunk=3 --this-chunk=2 --download-symbols=true 
[task 2018-03-21T16:55:58.695Z] 16:55:58     INFO - MultiFileLogger online at 20180321 16:55:58 in /builds/worker/workspace
[task 2018-03-21T16:55:58.698Z] 16:55:58     INFO - Run as /builds/worker/workspace/mozharness/scripts/desktop_unittest.py --config-file /builds/worker/workspace/mozharness/configs/unittests/linux_unittest.py --config-file /builds/worker/workspace/mozharness/configs/remove_executables.py --no-read-buildbot-config --installer-url=https://queue.taskcluster.net/v1/task/S2B6CeNHQw-mhKRdNAjh0Q/artifacts/public/build/target.tar.bz2 --test-packages-url=https://queue.taskcluster.net/v1/task/S2B6CeNHQw-mhKRdNAjh0Q/artifacts/public/build/target.test_packages.json --mochitest-suite=mochitest-media --e10s --allow-software-gl-layers --total-chunk=3 --this-chunk=2 --download-symbols=true
[task 2018-03-21T16:55:58.699Z] Traceback (most recent call last):
[task 2018-03-21T16:55:58.699Z]   File "/builds/worker/workspace/mozharness/scripts/desktop_unittest.py", line 917, in <module>
[task 2018-03-21T16:55:58.699Z]     desktop_unittest = DesktopUnittest()
[task 2018-03-21T16:55:58.699Z]   File "/builds/worker/workspace/mozharness/scripts/desktop_unittest.py", line 232, in __init__
[task 2018-03-21T16:55:58.700Z]     if c['enable_stylo']:
[task 2018-03-21T16:55:58.700Z] KeyError: 'enable_stylo'
[task 2018-03-21T16:55:58.710Z] cleanup
[task 2018-03-21T16:55:58.710Z] + cleanup
[task 2018-03-21T16:55:58.710Z] + local rv=1
[task 2018-03-21T16:55:58.710Z] + [[ -s /builds/worker/.xsession-errors ]]
[task 2018-03-21T16:55:58.710Z] + cp /builds/worker/.xsession-errors /builds/worker/artifacts/public/xsession-errors.log
[task 2018-03-21T16:55:58.713Z] + true
[task 2018-03-21T16:55:58.713Z] + cleanup_xvfb
[task 2018-03-21T16:55:58.716Z] pidof Xvfb
[task 2018-03-21T16:55:58.716Z] ++ pidof Xvfb
[task 2018-03-21T16:55:58.720Z] + local xvfb_pid=22
[task 2018-03-21T16:55:58.720Z] + local vnc=false
[task 2018-03-21T16:55:58.720Z] + local interactive=false
[task 2018-03-21T16:55:58.720Z] + '[' -n 22 ']'
[task 2018-03-21T16:55:58.720Z] + [[ false == false ]]
[task 2018-03-21T16:55:58.720Z] + [[ false == false ]]
[task 2018-03-21T16:55:58.721Z] + kill 22
[task 2018-03-21T16:55:58.722Z] XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
[task 2018-03-21T16:55:58.723Z]       after 477 requests (477 known processed) with 1 events remaining.
[task 2018-03-21T16:55:58.725Z] compizconfig - Info: Backend     : ini
[task 2018-03-21T16:55:58.730Z] compizconfig - Info: Integration : true
[task 2018-03-21T16:55:58.731Z] compizconfig - Info: Profile     : default
[task 2018-03-21T16:55:58.731Z] + screen -XS xvfb quit
[task 2018-03-21T16:55:58.945Z] No screen session found.
[task 2018-03-21T16:55:58.946Z] + true
[task 2018-03-21T16:55:58.946Z] + exit 1
[taskcluster 2018-03-21 16:55:59.200Z] === Task Finished ===
[taskcluster 2018-03-21 16:56:06.333Z] Unsuccessful task run with exit code: 1 completed in 28.661 seconds
Flags: needinfo?(emilio)
Comment on attachment 8960925 [details]
Bug 1447611: Remove --enable-stylo and --enable-stylo-build-bindgen.

https://reviewboard.mozilla.org/r/229660/#review235586

::: testing/talos/talos/unittests/test_config.py:139
(Diff revision 3)
>                  'test_timeout',
>                  'xperf_path',
>                  'error_filename',
>                  'no_upload_results',
> -                'enable_stylo',
>                  'disable_stylo',

Why are we not removing `disable_stylo`?
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fb0e473776cf
Remove --enable-stylo and --enable-stylo-build-bindgen. r=froydnj
https://hg.mozilla.org/integration/mozilla-inbound/rev/89d6c362a11a
Remove references to stylo prefs from Troubleshoot.jsm. r=jwatt
https://hg.mozilla.org/integration/mozilla-inbound/rev/c28d9e857a1a
Remove now-unused AppConstants.MOZ_STYLO. r=jwatt
https://hg.mozilla.org/integration/mozilla-inbound/rev/dffa74b15eec
Cleanup prefs that do nothing now. r=jwatt
Flags: needinfo?(emilio)
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/68cf22025cc0
followup: Remove useless and unused option from the talos config which I thought I had removed already. r=me
(In reply to Nathan Froyd [:froydnj] from comment #20)
> Comment on attachment 8960925 [details]
> Bug 1447611: Remove --enable-stylo and --enable-stylo-build-bindgen.
> 
> https://reviewboard.mozilla.org/r/229660/#review235586
> 
> ::: testing/talos/talos/unittests/test_config.py:139
> (Diff revision 3)
> >                  'test_timeout',
> >                  'xperf_path',
> >                  'error_filename',
> >                  'no_upload_results',
> > -                'enable_stylo',
> >                  'disable_stylo',
> 
> Why are we not removing `disable_stylo`?

I thought I pushed this change too, but looking at https://hg.mozilla.org/integration/mozilla-inbound/rev/fb0e473776cf I didn't, thus the followup.

The answer is "no reason, we can remove it". Nice catch Nathan, thanks!
Depends on: 1448026
Aceman reports that we're seeing |Stylo content=undefined, chrome=undefined| in about:troubleshooting. You're planning to remove this? We'd like to port that removal.
Flags: needinfo?(emilio)
I just missed to remove this, yeah. Filed bug 1448173.
Flags: needinfo?(emilio)
Duplicate of this bug: 1370571
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.