Replace "when Firefox starts" section in about:preferences#general with checkbox

RESOLVED FIXED in Firefox 61

Status

()

enhancement
P1
normal
RESOLVED FIXED
Last year
Last month

People

(Reporter: k88hudson, Assigned: k88hudson)

Tracking

(Blocks 2 bugs)

unspecified
Firefox 61
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 wontfix, firefox61 fixed)

Details

(Whiteboard: [strings m-c needed] [has-pr])

User Story

https://mozilla.invisionapp.com/share/UGFMYBETEDV#/screens/276669531

Attachments

(1 attachment)

Assignee

Description

Last year
The "Startup" section should have a checkbox that reads "Restore Previous Session", which should replace the "when firefox starts" section. This is a follow-up to landing the home section in about:preferences.
Assignee

Updated

Last year
User Story: (updated)
Assignee

Updated

Last year
Blocks: 1432589
Assignee

Updated

Last year
Iteration: --- → 61.2 - Apr 9

Comment 1

Last year
Bug 1440219 already blocked the meta but was filed under Preferences Component.

I believe we could just have bugzy list the bugs blocking the meta independent of the component?
See Also: → 1440219
Severity: normal → enhancement
Priority: -- → P2

Updated

Last year
Whiteboard: [strings m-c needed]
Assignee: nobody → khudson
Assignee

Updated

Last year
Priority: P2 → P1
Iteration: 61.2 - Apr 9 → 61.3 - Apr 23
Assignee

Updated

Last year
Whiteboard: [strings m-c needed] → [strings m-c needed] [has-pr]
Assignee

Comment 3

Last year
I tried to preserve the existing functionality for users/tests that have browser.startup.page set to 0 (blank), while introducing the new functionality with browser.startup.homepage (it's possible to have session restore / a custom or blank homepage for every subsequent new window)
Assignee

Comment 4

Last year
Oops, I still need to fix a couple of tests
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Assignee

Updated

Last year
Attachment #8966280 - Flags: review?(jaws)
Comment hidden (mozreview-request)
Comment on attachment 8966280 [details]
Bug 1448971 - Replace "when Firefox starts" section in about:preferences#general with checkbox

https://reviewboard.mozilla.org/r/234278/#review241142

::: browser/components/preferences/in-content/home.js:71
(Diff revision 6)
>     * @param {bool} shouldShow Should the custom UI be shown?
> +   * @param {bool} isControlled Is an extension controlling the home page?
>     */
> -  _renderCustomSettings(shouldShow) {
> +  _renderCustomSettings(shouldShow, isControlled) {

Can you change this to take an options Object argument since one of your callsites is passing `undefined` for the first argument?

```
_renderCustomSettings({shouldShow, isControlled}) {
}
```

::: browser/components/preferences/in-content/home.js:80
(Diff revision 6)
>      const customUrlEl = document.getElementById("homePageUrl");
> -    const isHomepageCustom = !this._isHomePageDefaultValue() && !this._isHomePageBlank();
> +    const homePref = Preferences.get("browser.startup.homepage");
> -    if (typeof shouldShow === "undefined") shouldShow = isHomepageCustom;
>  
> +    const isHomePageCustom = isControlled || (!this._isHomePageDefaultValue() && !this.isHomePageBlank());
> +    if (typeof shouldShow === "undefined") shouldShow = isHomePageCustom;

nit, please put this on two lines. The convention in this file is to also wrap with curly brackets.
Attachment #8966280 - Flags: review?(jaws) → review+
Comment hidden (mozreview-request)
Assignee

Comment 12

Last year
I needed to fix some somewhat unrelated race conditions in tests that got exposed as a result of these changes in the last update
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Iteration: 61.3 - Apr 23 → 61.4 - May 7
hg error in cmd: hg push -r tip ssh://hg.mozilla.org/integration/autoland: pushing to ssh://hg.mozilla.org/integration/autoland
searching for changes
remote: adding changesets
remote: adding manifests
remote: adding file changes
remote: added 1 changesets with 7 changes to 7 files
remote: (ftl_check check enabled per config override)
remote: 
remote: ************************ ERROR *************************
remote: You are trying to commit a change to an FTL file.
remote: At the moment modifying FTL files requires a review from
remote: one of the L10n Drivers.
remote: Please, request review from either:
remote:     - Francesco Lodolo (:flod)
remote:     - Zibi Braniecki (:gandalf)
remote:     - Axel Hecht (:pike)
remote:     - Stas Malolepszy (:stas)
remote: ********************************************************
remote: 
remote: transaction abort!
remote: rollback completed
remote: pretxnchangegroup.mozhooks hook failed
abort: push failed on remote
Assignee

Updated

Last year
Attachment #8966280 - Flags: review?(francesco.lodolo)
Comment on attachment 8966280 [details]
Bug 1448971 - Replace "when Firefox starts" section in about:preferences#general with checkbox

https://reviewboard.mozilla.org/r/234278/#review244686
Attachment #8966280 - Flags: review?(francesco.lodolo) → review+

Comment 19

Last year
Pushed by francesco.lodolo@mozillaitalia.org:
https://hg.mozilla.org/integration/autoland/rev/63b01e47c7bb
Replace "when Firefox starts" section in about:preferences#general with checkbox r=flod,jaws

Comment 20

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/63b01e47c7bb
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Component: Activity Streams: Newtab → Preferences
See Also: 1440219
Duplicate of this bug: 1440219

Updated

Last year
Depends on: 1472599

Updated

Last month
Blocks: 1530536
You need to log in before you can comment on or make changes to this bug.