Closed Bug 1451168 Opened 2 years ago Closed 2 years ago

No scrollbar thumb is displayed

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
All
defect

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- verified
firefox62 --- verified

People

(Reporter: alice0775, Assigned: kats)

References

(Blocks 1 open bug, )

Details

(Keywords: dupeme, regression)

Attachments

(5 files)

Attached image screenshot
Reproducible: always

Steps To Reproduce:
1. Make sure that WebRender is enabled
2. Open https://www.mozilla.org/en-US/privacy/firefox/
3. Open 3 dots menu at the top-left of the page
4. Expand sub menu so that the left sidebar will overflow
   or reduce height of browser

Actual Results:
No scrollbar thumb is displayed
Attached file about:support
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=7a6d3d03bb20c881d25ae7e6fdb2fbb981e335b7&tochange=cf1fdb432d46e52f795b3e253e851fbf775b2af1

Regressed by:cf1fdb432d46	Kartikaya Gupta — Bug 1423370 - Create fewer WebRenderLayerScrollData items for transformed items. r=jrmuizel
Blocks: 1423370
Keywords: regression
Assignee: nobody → bugmail
Why did you mark 59 and 60 affected?
Flags: needinfo?(stefan.georgiev)
59,60,61 are not affected by default.

The bug is reproduced if WebRender is enabled.
I thought I can see the same behavior there as in the attached screenshot. However on more closer look I can actually see that scrollbar thumb is displayed. Sorry about that.
Flags: needinfo?(stefan.georgiev)
OS: Windows 10 → All
Duplicate of this bug: 1455562
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9565f1fbc0c6fedb2a73e455f0d93596b3318bfd

The patch in this try push fixes it for me locally, but it seems to fail other reftests, so it's probably not right. It also doesn't fix bug 1450871 so I'll look at that one in more detail to see if I can figure out what the right fix is.
Sorry for the churn, I uploaded an old version (without comments) first and then I forgot to fix the commit message...
Comment on attachment 8972415 [details]
Bug 1451168 - Add a reftest.

https://reviewboard.mozilla.org/r/241026/#review246810

::: gfx/tests/reftest/1451168-ref.html:9
(Diff revision 3)
> +  <style type="text/css">
> +
> +nav{display:block}
> +body,html{margin:0;padding:0}
> +html{font-size:112.5%;background:#fff}
> +.moz-global-nav-drawer{font-family:"Open Sans",X-LocaleSpecific,sans-serif;background:#000;bottom:0;color:#fff;padding:20px;position:absolute;top:0;width:280px;z-index:1000}

Do we need font-family:"Open Sans"?
No. I didn't bother reducing the CSS to the absolute minimum possible although I guess I probably should.
Comment on attachment 8972414 [details]
Bug 1451168 - Ensure the transforms from ancestor stacking contexts are combined properly.

https://reviewboard.mozilla.org/r/241024/#review246820
Attachment #8972414 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8972415 [details]
Bug 1451168 - Add a reftest.

https://reviewboard.mozilla.org/r/241026/#review246966
Attachment #8972415 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d9b0f9b3bc39
Ensure the transforms from ancestor stacking contexts are combined properly. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/4b8c19afd14e
Add a reftest. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/d9b0f9b3bc39
https://hg.mozilla.org/mozilla-central/rev/4b8c19afd14e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
I’ve reproduced this issue on Firefox 61.0a1 (2018-04-03) under Windows 10 x86.  The issue is fixed on Firefox 62.0a1 (2018-05-21) and Firefox 61.0b7 (20180521110957) under Windows 10 x86, Ubuntu 16.04 x64 and macOS 10.13.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.