Can't delete more than one filter at a time - delete multiple selected filters is disabled

RESOLVED FIXED

Status

MailNews Core
Filters
--
minor
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: JWBohrer, Assigned: Karsten Düsterloh)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [approval-seamonkey1.1.2?][approval-thunderbird2.0.0.1?])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: RC2 as Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4)
Gecko/20011128 Netscape6/6.2.1
BuildID:    2002051006

Using ctrl-click, more than one filter at a time can be selected, but after
pressing delete only the bottom one is deleted.

Reproducible: Always
Steps to Reproduce:
1. Highlight more than one filter
2. Press delete
3.

Actual Results:  The bottom filter was deleted

Expected Results:  All filters should have been deleted

Using windows 98, RC2 as NS6.2.1

Updated

16 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
I'll attach a patch so this bug can't be reproduced, until someone decides to
implement opening/editing/deleting multiple filters at once.

Comment 2

16 years ago
Created attachment 86991 [details] [diff] [review]
don't allow multiple rows to be selected for now

One-liner to prevent multiple rows from being selected in this tree.

Comment 3

16 years ago
Comment on attachment 86991 [details] [diff] [review]
don't allow multiple rows to be selected for now

r=axel@pike.org
renamed patch to make clear that this bug stays open and to back this patch out
once the bug is really fixed
Attachment #86991 - Attachment description: Simple fix → don't allow multiple rows to be selected for now
Attachment #86991 - Flags: review+
mass re-assign.
Assignee: naving → sspitzer

Comment 5

15 years ago
Is the patch for this bug in the trunk?  Currently, the Delete button is greyed 
and the delete key does nothing.  Bug 204547 is an enhancment requesting 
multi-filter deletion; is that a dupe of this?  Should that one be WontFix?

Comment 6

15 years ago
*** Bug 204547 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
I duped bug 204547 to this--the original comment was the same, even if that
issue isn't addressed in the fix.
Not enhancement, the ui is there but fails to work as expected. Delete button
should be enabled and should delete the selected filters when multiple filters
are selected.
Severity: enhancement → minor
OS: Windows 98 → All
Product: MailNews → Core

Comment 9

12 years ago
function onDeleteFilter() needs to behave like runSelectedFilters() and then updateButtons() changed to enable the delete button for multiple select - in http://lxr.mozilla.org/seamonkey/source/mailnews/base/search/resources/content/FilterListDialog.js
Assignee: sspitzer → nobody
QA Contact: laurel → filters
Summary: Can't delete more than one filter at a time → Can't delete more than one filter at a time - delete multiple selected filters is disabled

Updated

11 years ago
Duplicate of this bug: 371589
(Assignee)

Comment 11

11 years ago
Created attachment 256853 [details] [diff] [review]
allow multiple filter deletions; SM v1

First go for fixing this. Will do a TB version if this goes through.
Assignee: nobody → mnyromyr
Attachment #86991 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #256853 - Flags: superreview?(neil)
Attachment #256853 - Flags: review?(iann_bugzilla)

Comment 12

11 years ago
Comment on attachment 256853 [details] [diff] [review]
allow multiple filter deletions; SM v1

>+  var sel = gFilterTree.view.selection, selCount = sel.getRangeCount();
Nit: I found this unsightly. Please put selCount on its own line.
Attachment #256853 - Flags: superreview?(neil) → superreview+

Updated

11 years ago
Attachment #256853 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Updated

11 years ago
Whiteboard: [approval-seamonkey1.1.2?]
(Assignee)

Comment 13

11 years ago
Created attachment 257409 [details] [diff] [review]
allow multiple filter deletions; TB variant
(Assignee)

Updated

11 years ago
Attachment #257409 - Flags: superreview?(bienvenu)
Attachment #257409 - Flags: review?(bienvenu)
(Assignee)

Comment 14

11 years ago
Comment on attachment 256853 [details] [diff] [review]
allow multiple filter deletions; SM v1

Landed on trunk; requesting SM branch approval.

Comment 15

11 years ago
Comment on attachment 257409 [details] [diff] [review]
allow multiple filter deletions; TB variant

looks good, but we can't land that on the 1.8.1 branch because we're past the string freeze...
Attachment #257409 - Flags: superreview?(bienvenu)
Attachment #257409 - Flags: superreview+
Attachment #257409 - Flags: review?(bienvenu)
Attachment #257409 - Flags: review+
(Assignee)

Comment 16

11 years ago
Comment on attachment 257409 [details] [diff] [review]
allow multiple filter deletions; TB variant

Landed on trunk, though. I try to remember "a-TB2.0x?" ;-)
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [approval-seamonkey1.1.2?] → [approval-seamonkey1.1.2?][approval-thunderbird2.0.0.1?]
-deleteFilterConfirmation=Are you sure you want to delete this filter?
+deleteFilterConfirmation=Are you sure you want to delete the selected filter(s)?

This is a semantic change, so the key name should be changed as well.

Comment 18

11 years ago
(In reply to comment #17)
nod

Updated

11 years ago
Duplicate of this bug: 357470

Updated

11 years ago
Duplicate of this bug: 87547
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.