[dogfood] Must press Space twice to insert space in Editor window

VERIFIED FIXED in M12

Status

()

Core
Editor
P2
major
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: cpratt, Assigned: kinmoz)

Tracking

Trunk
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
Build ID: 1999092208
Platform: Windows NT (US-International keyboard layout)

To reproduce:
- Launch apprunner
- Select File | New | New Blank Window
- In the new Editor window that is generated, try typing anything

Result: Every time you want to type a space, you must press the spacebar
*twice*.

Expected result: One press of the spacebar should generate a space.

Updated

18 years ago
Assignee: buster → jfrancis
Priority: P3 → P2
Target Milestone: M12

Comment 1

18 years ago
I don't see this, maybe my fix to isEditable (not yet checked in) corrected this
problem?
assigned to joe.

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

18 years ago
accepting bug / m12
(Reporter)

Comment 3

18 years ago
buster, I did not describe the problem accurately enough. When you press the
spacebar, a space actually *is* generated, but it is not reflected visually on
the screen. That is, if you type "hello^world" (the caret represents the space)
you see "hello world" on the screen - but if you just type "hello^" you will see
"hello|" where | represents the caret instead of "hello |".

Comment 4

18 years ago
*** Bug 15289 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
From Kin's bug:

"There seems to be some optimization in layout that does not extend the text

frame's width for a trailing space. This optimization seems to be turned off

when inside of a Pre block."

Updated

18 years ago
Summary: Must press Space twice to insert space in Editor window → [dogfood] Must press Space twice to insert space in Editor window

Comment 6

18 years ago
marked dogfood because users of mail compose get unexpected results when trying
to edit.

Updated

18 years ago
Depends on: 16176

Updated

18 years ago
Whiteboard: [PDT+]

Comment 7

18 years ago
Putting on [PDT+] radar.

Comment 8

18 years ago
Added Syd Logan and S.Fraser to CC list

Updated

18 years ago
Blocks: 12658
(Assignee)

Updated

18 years ago
Assignee: jfrancis → kin
Status: ASSIGNED → NEW
(Assignee)

Comment 9

18 years ago
Reassigning to kin@netscape.com.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

18 years ago
Fix checked in to Mozilla 5.0 tip.

    layout/base/src/nsCaret.cpp    revision 1.36
        - Modified DrawCaretWithContext so that we only
          adjust the caret position if we are within the
          frame's bounds.

    layout/html/base/src/nsTextFrame.cpp    revision 1.189
        - Modified GetPointFromOffset() to add the width
          of a space if the offset is after a trailing space
          and it was trimmed off the frame.

Fix was reviewed by sfraser@netscape.com.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 11

18 years ago
verified in 10/29 build.
You need to log in before you can comment on or make changes to this bug.