Closed Bug 1457891 Opened 2 years ago Closed 2 years ago

Update webrender to 8da531dc2cd77a4dadbfe632b04e76454f51ac9f

Categories

(Core :: Graphics: WebRender, defect, P3)

61 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1457241 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
Blocks: 1457974
Actually the above try pushes both have a windows debug gl1 failure that is persisting with retriggers. It might be a regression.
WR @ 08ee417bfe165f07f8806bbb9c8bd345578ff167

https://treeherder.mozilla.org/#/jobs?repo=try&revision=92cc3958f47df0f51f2e5dfb6c457bc44b0be046

Green, including the gl1 that was orange before. So maybe it was just was infra issues.
WR @ 08ee417bfe165f07f8806bbb9c8bd345578ff167

https://treeherder.mozilla.org/#/jobs?repo=try&revision=69b7f3d111a6cca078735102517fa404b44fa070

Green

WR @ bd41fa8722e9998a1b3e958839992b4d8e1bbeb6

https://treeherder.mozilla.org/#/jobs?repo=try&revision=43b03d6c35bcd72dada5710f09d8532d0293e9dc

Green

(Both of these have Wr4 failures but that was caused by the last WR update and I already landed a patch to disable those tests)
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 8da531dc2cd77a4dadbfe632b04e76454f51ac9f
Comment on attachment 8972860 [details]
Bug 1457891 - Update webrender to commit 8da531dc2cd77a4dadbfe632b04e76454f51ac9f.

https://reviewboard.mozilla.org/r/241416/#review247246
Attachment #8972860 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2d910b41bff4
Update webrender to commit 8da531dc2cd77a4dadbfe632b04e76454f51ac9f. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/2d910b41bff4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Depends on: 1459102
You need to log in before you can comment on or make changes to this bug.