Closed Bug 1459102 Opened 2 years ago Closed 2 years ago

Windows are blank on Mac with WebRender enabled

Categories

(Core :: Graphics: WebRender, defect, major)

All
macOS
defect
Not set
major

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- disabled

People

(Reporter: mstange, Assigned: kats)

References

Details

(Keywords: regression)

Attachments

(1 file)

Starting with the current Nightly, windows are entirely black or white except for the vibrant tab bar at the top.

Regression range: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=654e81aa75d11605e94e3e9f3a48fd9d48d9b7ac&tochange=2d910b41bff477568a84ab3c65656cb744b2ae84

This is a regression from the WebRender update.
(The tab bar is also blank but at least it's vibrant.)
It would be great to get this fixed ASAP, a lot of people probably don't know how to recover from this. (What worked for me was holding down the <option> key to start in safe mode, disabling the webrender pref, restart.)
Which one is the first bad build?
> WR @ 4b65822a2f7e1fed246a492f9fe193ede2f37d74
mozregression --repo try --launch c02f2c9507c6524a05a04c40b78b8c741e7a5010 --pref gfx.webrender.all:true

> WR @ a2dec3b0aea6b719325946a1b855df49ab33a3c9
mozregression --repo try --launch 9dab22f0fa803da8a1267b36bc32f026ab5b78bc --pref gfx.webrender.all:true

> WR @ 57141376519e0165aa1658f74f88239878cc5402
mozregression --repo try --launch ccd7bb59a9117e1834de895f00833c7ff9ddb850 --pref gfx.webrender.all:true

> WR @ 08ee417bfe165f07f8806bbb9c8bd345578ff167
mozregression --repo try --launch 69b7f3d111a6cca078735102517fa404b44fa070 --pref gfx.webrender.all:true

> WR @ bd41fa8722e9998a1b3e958839992b4d8e1bbeb6
mozregression --repo try --launch 43b03d6c35bcd72dada5710f09d8532d0293e9dc --pref gfx.webrender.all:true

> WR @ 751d3fae893598ed325d15eed1742dd29ea6912c
mozregression --repo try --launch d5d74beb0a1c10fc5038081cab7c69b80fdbb4e9 --pref gfx.webrender.all:true

> WR @ 8da531dc2cd77a4dadbfe632b04e76454f51ac9f
mozregression --repo try --launch 2fba8c52ea0d6cb205a88f91fdb5acf1b29cd2c0 --pref gfx.webrender.all:true
Duplicate of this bug: 1459119
> WR @ 08ee417bfe165f07f8806bbb9c8bd345578ff167
mozregression --repo try --launch 69b7f3d111a6cca078735102517fa404b44fa070 --pref gfx.webrender.all:true

> WR @ bd41fa8722e9998a1b3e958839992b4d8e1bbeb6
mozregression --repo try --launch 43b03d6c35bcd72dada5710f09d8532d0293e9dc --pref gfx.webrender.all:true

It's good in the first one and bad in the second. Regression range is:

* bd41fa87 Auto merge of #2709 - Gankro:raw-dl, r=kvark
* 4c187c2e Output gradientstops in serialization and debug output
Try push with that PR backed out: https://treeherder.mozilla.org/#/jobs?repo=try&revision=06340fd37c676e5cdece497745fd753778f5296f

The macOS build there seems to not have this problem.
Attached patch Back out PR 2709Splinter Review
Assignee: nobody → bugmail
Attachment #8973199 - Flags: review?(a.beingessner)
Attachment #8973199 - Flags: review?(a.beingessner) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/d07a4da682a2
Back out WR PR 2709 to fix webrender-enabled behaviour on macOS. r=kvark a=Aryx
Patch landed directly to m-c, and I requested a new nightly be spun for this.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Dzmitry also made a PR to back this out upstream until we can figure out what's going on.
Is this macOS only? A reddit user is reporting the same bug on Windows 7
https://www.reddit.com/r/firefox/comments/8gzgqz/firefox_loads_as_blank_white_box_with_webrender/
Interesting, it does sound like the same problem. I thought it was limited to macOS since I couldn't repro it on my windows or linux machines, but maybe it does affect a subset of windows users too.
For reference, the new nightly is live now, so if anybody is running into this problem on Mac, update your nightly (you might need to temporarily disable webrender to accomplish this) and it should be resolved.
You need to log in before you can comment on or make changes to this bug.