Closed Bug 1458658 Opened 3 years ago Closed 3 years ago

Unblock sites that are added

Categories

(Firefox :: New Tab Page, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox62 --- wontfix
firefox63 --- verified

People

(Reporter: Mardak, Assigned: ursula)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Similar to bug 735987 where unblock was added, activity stream has in-page UI to allow adding sites instead of drag/drop. Pinned links do get shown even when blocked, but when visited and unpinned, they go away.

Design thinks if we do this, bug 1432307 would be much lower priority as at least for top sites, the user has a way to "undo" by just adding the site back.
Blocks: 1432307
Summary: Unblock sites that are added → Unblock sites that are added if they were previously blocked
Iteration: --- → 62.1 - May 21
Priority: -- → P2
Summary: Unblock sites that are added if they were previously blocked → Unblock sites that are added
Blocks: 1444980
Iteration: 62.1 - May 21 → 62.2 - Jun 4
Iteration: 62.2 - Jun 4 → 63.1 - July 9
Assignee: nobody → usarracini
Depends on: 1470503
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/c035e5130c94431293a298e7d9bd8b3a17c34842
Bug 1458658 - Unblock sites that are added if they were previously
blocked

https://github.com/mozilla/activity-stream/commit/688aaede6fc2d4bd37acd18595285052106b8de0
Merge pull request #4204 from sarracini/bug_1458658

Bug 1458658 - Unblock sites that are added if they were previously blocked
Oops, forgot to put 'Fix' in the commit message. This is fixed by https://github.com/mozilla/activity-stream/pull/4204. Closing this.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Blocks: 1470588
https://hg.mozilla.org/mozilla-central/rev/9dcaad7a978f
Target Milestone: --- → Firefox 63
Is this something you're aiming at the 62 release? If so I'd like us to verify the fix before uplift.
Flags: qe-verify+
Flags: needinfo?(usarracini)
Flags: needinfo?(edilee)
This is an enhancement that missed 62. I don't think it needs to be uplifted.
Flags: needinfo?(usarracini)
Flags: needinfo?(edilee)
I have verified that this issue is no longer reproducible on Windows 10 x64 and Mac 10.13.3 on the Nightly Version 63.0a1, Build ID 20180702220046.
However, the issue is currently reproducible on Ubuntu 16.04 on the same version of Nightly.

After a visited a website that appeared naturally in the Top Sites section is dismissed, pinning it, visiting the website and unpinning causes it to disappear from the Top Sites section.
Considering this I will reopen the issue.
Status: RESOLVED → REOPENED
OS: Unspecified → Linux
Resolution: FIXED → ---
Iteration: 63.1 - July 9 → ---
Priority: P2 → P3
I have verified the issue on Windows 10 and Ubuntu 18 on Nightly 63.0a1 (2018-07-16).
The issue is reproducing on each of the OSes.

Adding a new Top Site, opening it and then unpinning it makes it disappear from the Top Sites.
What's the top site you're trying to add? I could see the unblocking mechanism might have a slightly mismatched url, e.g., blocked https://www.mozilla.org/ but when adding a site, perhaps https is missing, or missing www, or missing the trailing slash -- all of which don't quite match the original url to unblock. I wonder if we should just try unblocking multiple similar urls just in case?
I tried to add the following types of links and the issue is reproducing with all of them:

- https://www.emag.ro
- https://emag.ro
- www.emag.ro
Using Patric's steps from comment 7, Ed's additional info about having slightly mismatching URLs, I have verified that the issue is no longer reproducible on Windows 10 x64, Mac 10.13.5 and Arch Linux x64.

STR on a clean new profile:
1. Add a website to the Top Sites section using its full URL. (eg https://www.imdb.com/)
2. Dismiss the Top Site.
3. Add the same website to the Top Sites section.
4. Open it in at least 2 new tabs.
5. Unpin the website.

@David, for the remaining issue, I suggest filing a new bug with your STR to enhance our unblocking mechanism.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Flags: qe-verify+
OS: Linux → All
Hardware: Unspecified → All
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
See Also: → 1477709
I created an issue also for the incomplete URLs. The issue is: Bug 1477709
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.