Closed Bug 1459289 Opened 3 years ago Closed 3 years ago

Compact Highlight Cards

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 62
Iteration:
62.2 - Jun 4
Tracking Status
firefox62 --- verified

People

(Reporter: rrosario, Assigned: rrosario)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Assignee: nobody → rrosario
Iteration: --- → 62.1 - May 21
Priority: -- → P1
Severity: normal → enhancement
In addition to the style changes, while working on this with UX (Bryan Bell), we decided to make the following changes:

* changed highlights to two rows instead of 3
* fill all the possible/max rows with placeholders instead of just the current row
* on narrow screens, we hide the last two highlights (like we do for top sites)
* no longer showing file type for downloads
* if a link has no image (all downloads), we now show a grey box where the image goes instead of pushing the text to the top
Iteration: 62.1 - May 21 → 62.2 - Jun 4
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Blocks: 1463943
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/fdda2139280fd798002196bf8e71f5a7dc2001af
chore(highlights): Update mochitest to check for 2 rows of placeholders (#4167)

Followup Bug 1459289 - Compact Highlight Cards
Blocks: 1464536
Blocks: 1464467
The issue is no longer reproducible on the latest Nightly build on Windows 10 x64, Mac 10.13.3 and Arch Linux x64. All the additional changes mentioned in comment 2 have also been verified.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.