Application mode (a kind of kiosk mode)

RESOLVED DUPLICATE of bug 1283670

Status

()

enhancement
P5
normal
RESOLVED DUPLICATE of bug 1283670
a year ago
a year ago

People

(Reporter: johnmaverick74, Unassigned)

Tracking

({parity-chrome})

59 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180340000000




Expected results:

I think this is a feature request specific to enterprise environments, but very useful:

There should be a command to include in desktop shortcuts so that when Firefox starts it would hide all of it's UI leaving only the regular window frame (titlebar with minimize, restore & close buttons).

Google Chrome has something like this. If one edits a shortcut link and adds "--app=https://google.com" it will open the browser on https://google.com without any of it's "chrome"

This is very useful on the enterprise environment!
(Reporter)

Comment 1

a year ago
If not turned down immediately, i intent to add it to the "depends on" of meta bug #720362

Comment 2

a year ago
Bug 641320 - I'd think this should be duped to it, were it not for the fact it requests an identical command line option for completely different behavior (pinned tab in Firefox versus window without toolbars in Chrome). Also, the -app command line was at least at one point already in use in Firefox [1] though this may no longer be the case since Webextensions (Firefox 57).

Bug 491588 - this is for an actual kiosk mode, which implies forced fullscreen and other limitations.

(In reply to Maverick from comment #1)
> If not turned down immediately, i intent to add it to the "depends on" of
> meta bug #720362

:mkaply what do you think?


[1] https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options#XULRunner
Severity: normal → enhancement
Has STR: --- → yes
Flags: needinfo?(mozilla)
Keywords: parity-chrome
See Also: → 641320
Most of the people I talk to think Chrome's application mode is useful until they realize that every keyboard shortcut works and you can still navigate to any site.

So it doesn't really accomplish a true kiosk mode or any sort of limiting at all.

I agree that we need some better options around UI limiting on Firefox and this is definitely on my list now that we're over the group policy part.

I think this probably should be duped to the kiosk mode bug.

As far as -app goes, it doesn't still work on Firefox to do a XUL runner app.
Flags: needinfo?(mozilla)
(Reporter)

Comment 4

a year ago
My intention (or should i say "what we, as a business, are looking for") is not a Kiosk mode!
In our case we do not need any other limitation on the browser. We just need a way to, on a shortcut for example, set a propriety that will start that shortcut's web address without any UI.

This way, we can maximize the usable space for the software we're using. (Think, for example, OpenERP or solutions that, like that one, are web based).

I, honestly, think this would be a simple feature many other businesses and software developers would be interested in and, as mentioned, i don't think of is as a dupe of kiosk mode because we do not need (or want) any of the kiosk limitations (e.g.: we want and need window controls, page titles and the browser not to be in complete fullscreen)
That's fair. I'm fine with leaving this open as a unique thing
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Priority: -- → P5
(Reporter)

Comment 6

a year ago
Thanks.

Would be nice to have a place, a way, a tag, "something" were businesses could "suggest" needs.

Also, since this is sort of basic, i think it would be a nice addition to bug 720362 :)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1283670
You need to log in before you can comment on or make changes to this bug.