enable Shadow DOM in Nightly

RESOLVED FIXED in Firefox 62

Status

()

P2
normal
RESOLVED FIXED
9 months ago
11 days ago

People

(Reporter: smaug, Assigned: smaug)

Tracking

({dev-doc-complete})

unspecified
mozilla62
dev-doc-complete
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(2 attachments)

Comment hidden (empty)
Priority: -- → P2
(Assignee)

Comment 1

8 months ago
Created attachment 8980625 [details] [diff] [review]
shadow_dom_enable_nightly.diff

There are still open issues, but I think the state should be good enough for some Nightly testing.


Need to see what all tests breaks if we enable by default.
So I wouldn't land before all the test results

remote: View your changes here:
remote:   https://hg.mozilla.org/try/rev/ea19ea9820f496f682c71634a011991c28f6ab5d
remote:   https://hg.mozilla.org/try/rev/50a6c79860000396a9d1378687e150310ae96eb4
remote:   https://hg.mozilla.org/try/rev/b11b8740599335d6e55806b0339be41b35046e62
remote:   https://hg.mozilla.org/try/rev/3c78e72b0172a119d81aad6e30172b97a8750bd2
remote: 
remote: Follow the progress of your build on Treeherder:
remote:   https://treeherder.mozilla.org/#/jobs?repo=try&revision=3c78e72b0172a119d81aad6e30172b97a8750bd2
remote: recorded changegroup in replication log in 0.094s
Attachment #8980625 - Flags: review?(emilio)
Comment on attachment 8980625 [details] [diff] [review]
shadow_dom_enable_nightly.diff

Review of attachment 8980625 [details] [diff] [review]:
-----------------------------------------------------------------

\o/
Attachment #8980625 - Flags: review?(emilio) → review+
(Assignee)

Comment 3

8 months ago
oops, better try
remote: Follow the progress of your build on Treeherder:
remote:   https://treeherder.mozilla.org/#/jobs?repo=try&revision=0cca74d959898256247be328b38e083c9384d213
remote: recorded changegroup in replication log in 0.113s
(Assignee)

Comment 4

8 months ago
ok, there is one failure
TEST-UNEXPECTED-FAIL | /custom-elements/builtin-coverage.html | slot: Operator 'new' should instantiate a customized built-in element - assert_equals: Cloning a customized built-in element should succeed. expected function "class extends HTMLSlotElement {}" but got function "function HTMLSlotElement() {

but looks like that fails for other elements already.

Comment 5

8 months ago
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/20d536fd0f2a
enable Shadow DOM in Nightly, r=emilio
(Assignee)

Comment 6

8 months ago
Created attachment 8980978 [details] [diff] [review]
shadow_dom_enable_nightly_with_test_fix.diff
(Assignee)

Comment 7

8 months ago
I wouldn't be too surprised if this causes some regressions, so backout is possible.
But shadow DOM is so rarely used feature that it is hard to get enough testing without keeping it enabled.

Comment 8

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/20d536fd0f2a
Status: NEW → RESOLVED
Last Resolved: 8 months ago
status-firefox62: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Keywords: dev-doc-needed

Updated

8 months ago
Depends on: 1466581

Updated

7 months ago
Depends on: 1468307
Depends on: 1466998

Updated

7 months ago
Depends on: 1469674
All the compat data on this is basically still accurate with this change — it still isn't really available anywhere. All I've done is to update the entry on the Experimental features page to say it is enabled in Nightly in 62:

https://developer.mozilla.org/en-US/Firefox/Experimental_features
Keywords: dev-doc-needed → dev-doc-complete
Shouldn't this bug be a dependent of bug 1205323?
Depends on: 1518795
You need to log in before you can comment on or make changes to this bug.