Closed Bug 1460072 Opened 5 years ago Closed 4 years ago

Date picker layout issues when opened in landscape mode

Categories

(Firefox for Android Graveyard :: General, defect)

Firefox 62
All
Android
defect
Not set
normal

Tracking

(firefox60 unaffected, firefox61 unaffected, firefox62 verified, firefox63 verified)

VERIFIED FIXED
Tracking Status
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- verified
firefox63 --- verified

People

(Reporter: JanH, Assigned: petru)

References

()

Details

(Keywords: regression, Whiteboard: [priority:medium])

Attachments

(1 file)

1. If the date picker is initially opened while the phone is in landscape mode, the column displaying the currently selected date in text form seems somewhat overly wide, while the calendar appears rather squished. This gets worse if you subsequently rotate the phone to portrait mode, because the picker dialogue retains the landscape UI and only gets narrower.
2. The Set/Cancel/Clear buttons are scrolled out of view.

The time picker, where we've already been using the system controls for a while now is suffering from a very similar set of problems, see bug 1412517.
Flags: needinfo?(petru.lingurar)
Version: unspecified → Firefox 62
Summary: Date picker layout issues when opened in portrait mode → Date picker layout issues when opened in landscape mode
It seems both DatePicker and TimePicker has their share of bugs which we'll need to resolve.
Keeping my NI to return to this after the Oreo features and bugs which we currently work on are resolved.
Whiteboard: [priority:medium]
(In reply to Petru-Mugurel Lingurar[:petru] from comment #1)
> It seems both DatePicker and TimePicker has their share of bugs which we'll
> need to resolve.
> Keeping my NI to return to this after the Oreo features and bugs which we
> currently work on are resolved.

Might be good to create a tracker bug to collect them in as well.
Blocks: 1464997
Removing my NI from individual Date/TimePicker tickets, as they will be tracked in the new bug 1464997.
Flags: needinfo?(petru.lingurar)
(In reply to Petru-Mugurel Lingurar[:petru] from comment #3)
> Removing my NI from individual Date/TimePicker tickets, as they will be
> tracked in the new bug 1464997.

Hey petru, given your comment in Bug 1464997,

> Similar problems can be observed on Chrome for Android and on our other browser - Focus.

Can you confirm this specific landscape issue reproduces in Chrome Mobile? If so, I don't think we should track as a regression.
(oops, see comment #4)
Flags: needinfo?(petru.lingurar)
It is a regression insofar as before bug 1318046 we didn't use the system DatePicker controls. Our previous implementation had its own share of problems, however those did not include the issues described in comment 0 and attachment 8974190 [details].

So doing bug 1318046 fixed one particular problem, but made other things worse.
Flags: needinfo?(petru.lingurar)
Being that the issues are because of native libraries, all applications that use Android's DatePicker / TimePicker will suffer from similar problems.
I posted in the tickets for Focus a recording of the issues on latest Chrome for Android
https://github.com/mozilla-mobile/focus-android/issues/2595#issuecomment-391242161
https://github.com/mozilla-mobile/focus-android/issues/2596#issuecomment-391242473

This bug could be seen as a regression because the indicated issue probably appeared after bug 1318046 which resolved a bigger problem by using platform's DatePicker. But introduced this one.
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Depends on: 1474888
Depends on: 1412517
The work done in Bug 1412517 and in Bug 1474888 should also fix this. Please check.
Flags: qe-verify+
Verified as fixed on latest Nightly 63.0a1 (2018-08-01) on the following device: Huawei P9 Lite	(Android 6.0) and Nokia 6 (7.1.1).
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Verified as fixed on 62.0b17 on Nexus 6P (Android 8.1.0) and HTC 10 (Android 8.0.0).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.