remove old osx 10.6 references in manifest files

RESOLVED FIXED in Firefox 62

Status

()

P5
trivial
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: jmaher, Assigned: RaulGurzau)

Tracking

54 Branch
mozilla62
Points:
---

Firefox Tracking Flags

(firefox62 fixed)

Details

(Whiteboard: [manifest_cleanup][gfx-noted])

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

7 months ago
we run automation on osx 10.10, not 10.6 anymore, lets remove some old references.

for the webgl tests we need to edit the errata file:
https://searchfox.org/mozilla-central/source/dom/canvas/test/webgl-conf/mochitest-errata.ini

then run generate-wrappers-and-manifest.py to generate the official .ini files that we use.
(Reporter)

Comment 1

7 months ago
it looks like there are 10 tests skipped in the above file.
Severity: normal → trivial
Priority: -- → P5
Whiteboard: [manifest_cleanup] → [manifest_cleanup][gfx-noted]
(Assignee)

Comment 2

7 months ago
Removed the references from errata file but when running generate-wrappers-and-manifest.py i get the following error and i'm stuck here:

usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf inbound(+1) $ python generate-wrappers-and-manifest.py
Traceback (most recent call last):
  File "generate-wrappers-and-manifest.py", line 534, in <module>
    os.chdir(file_dir)
TypeError: coercing to Unicode: need string or buffer, PosixPath found
usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf inbound(+1) $
Flags: needinfo?(gbrown)
(Assignee)

Updated

7 months ago
Assignee: nobody → rgurzau
(Reporter)

Comment 3

7 months ago
:jgilbert, I see you modified this file in the past, I get the same failure that Raul is seeing.  is there some prerequisites or custom version of pathlib needed?
Flags: needinfo?(jgilbert)
Probably caused by bug 1450839? Hopefully jgilbert can work this out.
Flags: needinfo?(gbrown)
Run the file as `./generate-...`. The error you get is likely due to incurring python2 instead of python3.
Flags: needinfo?(jgilbert)
(Assignee)

Comment 6

7 months ago
Tried running as `./generate-...` but the same error occurred and i'm running python 2.7:

usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf (?) $ ./generate-wrappers-and-manifest.py
Traceback (most recent call last):
  File "./generate-wrappers-and-manifest.py", line 534, in <module>
    os.chdir(file_dir)
TypeError: argument should be string, bytes or integer, not PosixPath
usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf (?) $ python -V
Python 2.7.12
usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf (?) $
Flags: needinfo?(jgilbert)
(In reply to Raul Gurzau (:RaulGurzau) from comment #6)
> Tried running as `./generate-...` but the same error occurred and i'm
> running python 2.7:
> 
> usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf (?) $
> ./generate-wrappers-and-manifest.py
> Traceback (most recent call last):
>   File "./generate-wrappers-and-manifest.py", line 534, in <module>
>     os.chdir(file_dir)
> TypeError: argument should be string, bytes or integer, not PosixPath
> usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf (?) $
> python -V
> Python 2.7.12
> usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf (?) $

It requires python3. Please run with python3.
Flags: needinfo?(jgilbert)
(Assignee)

Comment 8

7 months ago
Same error again while running with python3, is there something wrong with my environment maybe?

usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf inbound(0) $ sudo python3 ./generate-wrappers-and-manifest.py
Traceback (most recent call last):
  File "./generate-wrappers-and-manifest.py", line 534, in <module>
    os.chdir(file_dir)
TypeError: argument should be string, bytes or integer, not PosixPath
usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf inbound(0) $ python3 -V
Python 3.5.2
usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf inbound(0) $ python3 ./generate-wrappers-and-manifest.py
Traceback (most recent call last):
  File "./generate-wrappers-and-manifest.py", line 534, in <module>
    os.chdir(file_dir)
TypeError: argument should be string, bytes or integer, not PosixPath
usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf inbound(0) $ python3 generate-wrappers-and-manifest.py
Traceback (most recent call last):
  File "generate-wrappers-and-manifest.py", line 534, in <module>
    os.chdir(file_dir)
TypeError: argument should be string, bytes or integer, not PosixPath
Flags: needinfo?(jmaher)
It seems that script requires Python 3.6+ because os.chdir accepts path-like object since 3.6.
(In reply to Raul Gurzau (:RaulGurzau) from comment #8)
> Same error again while running with python3, is there something wrong with
> my environment maybe?
> 
> usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf
> inbound(0) $ sudo python3 ./generate-wrappers-and-manifest.py
> Traceback (most recent call last):
>   File "./generate-wrappers-and-manifest.py", line 534, in <module>
>     os.chdir(file_dir)
> TypeError: argument should be string, bytes or integer, not PosixPath
> usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf
> inbound(0) $ python3 -V
> Python 3.5.2
> usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf
> inbound(0) $ python3 ./generate-wrappers-and-manifest.py
> Traceback (most recent call last):
>   File "./generate-wrappers-and-manifest.py", line 534, in <module>
>     os.chdir(file_dir)
> TypeError: argument should be string, bytes or integer, not PosixPath
> usernou@raul-VirtualBox ~/mozilla-unified/dom/canvas/test/webgl-conf
> inbound(0) $ python3 generate-wrappers-and-manifest.py
> Traceback (most recent call last):
>   File "generate-wrappers-and-manifest.py", line 534, in <module>
>     os.chdir(file_dir)
> TypeError: argument should be string, bytes or integer, not PosixPath

You shouldn't need sudo to run this. (it's dangerous to try, in case it tries to delete certain root paths by accident)

You should be able to call `./generate-wrappers-and-manifest.py` directly since its shebang line specifies python3. (Generally rely on the shebang line for python files, instead of launching with python2/3 yourself)
Ah, ok, I guess it requires 3.6, so please update. I'm surprised there's much drift between python3 versions.
(Assignee)

Comment 12

7 months ago
Created attachment 8979772 [details] [diff] [review]
bug1461960.patch

Managed to run generate-wrappers-and-manifest.py successfully with python 3.6
Attachment #8979772 - Flags: review?(jmaher)
(Reporter)

Comment 13

7 months ago
Comment on attachment 8979772 [details] [diff] [review]
bug1461960.patch

Review of attachment 8979772 [details] [diff] [review]:
-----------------------------------------------------------------

thanks for working on this.
Attachment #8979772 - Flags: review?(jmaher) → review+
(Reporter)

Updated

7 months ago
Flags: needinfo?(jmaher)
Keywords: checkin-needed
Comment on attachment 8979772 [details] [diff] [review]
bug1461960.patch

Review of attachment 8979772 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/canvas/test/webgl-conf/mochitest-errata.ini
@@ +666,1 @@
>  [generated/test_conformance__glsl__constructors__glsl-construct-mat3.html]

Just remove lines if they no longer have any errata.
(Reporter)

Comment 15

7 months ago
thanks :jgilbert.  Raul, up for removing lines that have no related skip/fail conditions?
Flags: needinfo?(rgurzau)
Keywords: checkin-needed
(Assignee)

Comment 16

7 months ago
Created attachment 8979797 [details] [diff] [review]
bug1461960.patch

Removed lines without conditions.
Attachment #8979772 - Attachment is obsolete: true
Flags: needinfo?(rgurzau)
Attachment #8979797 - Flags: review?(jmaher)
Comment on attachment 8979797 [details] [diff] [review]
bug1461960.patch

Review of attachment 8979797 [details] [diff] [review]:
-----------------------------------------------------------------

r=me
Attachment #8979797 - Flags: review?(jmaher) → review+
(Assignee)

Comment 18

7 months ago
Created attachment 8979801 [details] [diff] [review]
bug1461960.patch

Removed old references for OSX 10.6 and 10.8 too
Attachment #8979797 - Attachment is obsolete: true
Flags: needinfo?(jmaher)
Attachment #8979801 - Flags: review?(jmaher)
Comment on attachment 8979801 [details] [diff] [review]
bug1461960.patch

Review of attachment 8979801 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/canvas/test/webgl-conf/mochitest-errata.ini
@@ -162,4 @@
>  ########################################################################
>  # Complicated
>  
> -[generated/test_conformance__context__context-attributes-alpha-depth-stencil-antialias.html]

This test still has a skip-if, so you can't remove the [*.html] line.

@@ -187,4 @@
>  # Assume crashes like ivec3
>  skip-if = (os == 'linux') || (os == 'mac')
>  
> -[generated/test_conformance__glsl__constructors__glsl-construct-mat2.html]

This test still has a skip-if, so you can't remove the [*.html] line.
Attachment #8979801 - Flags: review?(jmaher) → review-
(Assignee)

Comment 20

7 months ago
Created attachment 8979806 [details] [diff] [review]
bug1461960.patch

Should be right now.
Attachment #8979801 - Attachment is obsolete: true
Attachment #8979806 - Flags: review?(jmaher)
Comment on attachment 8979806 [details] [diff] [review]
bug1461960.patch

Review of attachment 8979806 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8979806 - Flags: review?(jmaher) → review+
(Reporter)

Updated

7 months ago
Flags: needinfo?(jmaher)
Keywords: checkin-needed

Comment 22

7 months ago
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ddf1909c4e58
removed old references for OSX 10.6 and 10.8 r=jmaher
Keywords: checkin-needed

Comment 23

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ddf1909c4e58
Status: NEW → RESOLVED
Last Resolved: 7 months ago
status-firefox62: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.