Closed Bug 1462173 Opened Last year Closed 9 days ago

Blank address bar

Categories

(Core :: Graphics: WebRender, defect, P2)

Unspecified
Windows 7
defect

Tracking

()

RESOLVED WORKSFORME
mozilla70
Tracking Status
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- disabled
firefox63 --- disabled
firefox64 --- disabled
firefox67 --- disabled
firefox68 --- disabled
firefox69 --- disabled
firefox70 --- disabled

People

(Reporter: jrmuizel, Unassigned)

References

(Blocks 2 open bugs, )

Details

(Whiteboard: [sci-exclude])

Attachments

(2 files, 1 obsolete file)

From https://www.reddit.com/r/firefox/comments/8jkm99/webrender_newsletter_19/dz0nxca/

"when typing an address into the address bar, the menu that drops down with suggestions of urls from my browsing history sometimes becomes blank. The menu can still be used, i.e pressing down and then enter will lead to the first suggested result, but the menu is a blank canvas. "

STR:

"I think I've found it - It happens when I connect multiple monitors. The setup, if it matters, is a 1920x1080 monitor @ 144hz, and a 3840x2160 Sony TV @ 60hz. Using both, still at their native resolution introduces this issue. Switching back to the 1080p monitor fixes the issue. It doesn't happen immediately. It seems to occur after some time. It seems to coincide with dragging a tab from the 1080p monitor to the TV, i.e dragging it off the main browser as a new window."
OS: Unspecified → Windows 7
Attached video 2018-05-17 01-35-13.mp4
Win7 SP1, Nvidia GTX 1060 (Driver 388.73), 2560x1440 (Dell U2515H)
Attached file aboutsupport.txt
Same Awesomebar popup bug with latest driver 397.64.

> Workarounds
> NO_CONSTANT_BUFFER_OFFSETTING	Unsupported by driver
Attachment #8976378 - Attachment is obsolete: true
Is this a regression?
Flags: needinfo?(jan)
It looked like another bug morphed into this one. Before this, the menu was often stretched to a greater height. This bug isn't always easy to reproduce.
Batch updating status flags based on WR schedule - please adjust if needed.
Still reproducible.
Flags: needinfo?(jan)
This might be the same issue as bug 1455167. Random guess: We seem to be using WebRender for these popup windows. Maybe we're trying to paint at a 0x0 size at some point, and then we get into a broken state such that no future paints will work.
Assignee: nobody → emilio
Priority: -- → P2
I can't repro this, at least with the monitors and the Windows laptop I have around. Jan Andre, can you still repro this?
Flags: needinfo?(jan)
Yes, still reproducible on Win7. Still not seen on Win10.
(Go through all keys if needed: Press a key, then backspace, then try the next one or the same again, etc.)
Flags: needinfo?(jan)
I'll try to get running some win7 stuff.
I think I can repro this with the window that Linux spawns to run reftests consistently. I'll try to debug that with rr.
If this doesn't happen on Win10 we don't need to block on it.
Blocks: stage-wr-next, wr-win7
No longer blocks: stage-wr-trains
See Also: → 1497072

Not looking into this actively since it's not blocking and doesn't affect win 10.

Assignee: emilio → nobody

Still easy to reproduce for me and only with WebRender on Win7 (with and without Angle). Nightly 20190426094913, GTX 1060.
Could bug 1547277 be related?

See Also: → 1547277
See Also: → 1551598

Reproduced on released 67 version (Win7). WebRender enabled manual (gfx.webrender.all and gfx.webrender.enabled).

Another report: https://www.reddit.com/r/firefox/comments/brdgbv/discord_server_icons_become_transparent_ff_67/eod4575/
Yes, I assume many people will encounter this issue. (gfx.webrender.all set to true is sufficient to force-enable WebRender. Thanks!)

Duplicate of this bug: 1538209
Depends on: 1551598
See Also: 1551598
Whiteboard: [sci-exclude]

Obsolete by bug 1551598.

Status: NEW → RESOLVED
Closed: 9 days ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.