Closed Bug 1574746 Opened 2 years ago Closed 10 months ago

Search suggestions not drawn in WebRender

Categories

(Core :: Graphics: WebRender, defect, P3)

x86_64
Windows 7
defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox-esr68 --- disabled
firefox68 --- disabled
firefox69 --- disabled
firefox70 --- disabled
firefox78 --- fixed

People

(Reporter: mesvam, Assigned: sotaro)

References

(Blocks 1 open bug)

Details

(Keywords: correctness, Whiteboard: wr-planning)

Attachments

(3 files)

Attached image screenshot.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Steps to reproduce:

Reproduce:

  1. Type text in search bar
  2. Deselect/unfocus search bar (e.g. by clicking outside)
  3. Focus the search bar again

Actual results:

The drop down of suggestions is partially drawn. Showing only drop shadows on the border, but the content is not visible.

Attached file about:support

bug 1551598 only fixed bug 1462173. This is the same issue.

Blocks: wr-win7
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: correctness
OS: Unspecified → Windows 7
Priority: -- → P3
Hardware: Unspecified → x86_64
See Also: → 1462173, 1551598
See Also: → 1573710

mesvam, does the problem still happens with latest nightly?

Flags: needinfo?(mesvam)

(In reply to Sotaro Ikeda [:sotaro] from comment #3)

mesvam, does the problem still happens with latest nightly?

Yup, still there

Flags: needinfo?(mesvam)

Thanks for checking! Since OS is Widows 7, Bug 1573710 is not related to this bug.

See Also: 1573710

Some invalidation bugs were addressed by Bug 1595014 and Bug 1624216.

I confirmed that the problem still happen on latest nightly on Windows 7.

(In reply to Sotaro Ikeda [:sotaro] from comment #7)

I confirmed that the problem still happen on latest nightly on Windows 7.

But search suggestion did not use WebRender. But I did not see the problem when WebRender was disabled :(

Assignee: nobody → sotaro.ikeda.g

When D3D11 Advanced Layers was enabled on Win7, the problem did not happen. But in this case, pop up was hardware accelerated. With WebRender, the popup was not accelerated(BasicCompositor).

When I modified the code as that pop up always uses BasicCompositor, D3D11 Advanced Layers usage also caused the problem.

nsBaseWidget::AllowWebRenderForThisWindow() limit WebRender usage to some windows. It was added by Bug 1377321, because initialization of WebRender was heavy weight in the past. See Bug 1377321 Comment 3. The initialization problem does not exist anymore on WebRender on Windows.

The time when bug 1377321 merged I saw a notable delay when opening uBlock Origin on my KDE/X11/Debian Testing/Radeon RX480 desktop.
Today, the delay is almost not noticeable on my KDE/X11/Debian Testing/Intel Iris 6100 (Broadwell GT3) laptop, but compared to the main menu it's still possible to close a panel before it has shown, by double clicking on its button. Using WR for main menu and context menu should still be fine.

Duplicate of this bug: 1567791
Duplicate of this bug: 1622633
Attachment #9141460 - Attachment description: Bug 1574746 - AllowWebRenderForThisWindow() → Bug 1574746 - Remove AllowWebRenderForThisWindow()

Conformed that Attachment 9141460 [details] addressed the problem on my Win7 PC.

(In reply to Sotaro Ikeda [:sotaro] from comment #15)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a16df35d2f9e9902ec9f484a15f9a3637f7a2b4d

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #12)

but compared to the main menu it's still possible to close a panel before it has shown, by double clicking on its button.

That seems only to apply to (even lightweight) webextensions.
Non-webextension panels like the main menu use WebRender in this try build, but are still shown as fast as Basic.

With gfx.webrender.debug.primitives I noticed that Basic is still used for the context menu.

That seems only to apply to (even lightweight) webextensions.
Non-webextension panels like the main menu use WebRender in this try build, but are still shown as fast as Basic.

With gfx.webrender.debug.primitives I noticed that Basic is still used for the context menu.

The patch does not expected to use WebRender for all windows(widgets). When ComputeShouldAccelerate()/WidgetTypeSupportsAcceleration() return false, widget does not use WebRender.

Whiteboard: wr-planning
Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/339795d0a51e
Remove AllowWebRenderForThisWindow() r=nical
Duplicate of this bug: 1633574

(In reply to Andrei Ciure[:aciure] from comment #20)

also introduced this: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=windows%2C7%2Cshippable%2Copt%2Ctest-windows7-32-shippable%2Fopt-marionette-e10s%2C%28mn%29&fromchange=339795d0a51eb84d7d792e1b610c068f52f99b7a&tochange=0affade618e1c7b0343356c61d37057868c6bd30

log: https://treeherder.mozilla.org/logviewer.html#?job_id=298536613&repo=autoland

It seems already exist as Bug 1631112 . This should not related to this bug. The failure happen on Windows 7 Shippable opt. But the patch affect only to WebRender. Windows 7 Shippable opt does not use WebRender.

Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/786823305560
Remove AllowWebRenderForThisWindow() r=nical
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Backout by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/559943097aee
Backed out changeset 786823305560 for Browser-chrome failures in test/performance/browser_startup_syncIPC.js. CLOSED TREE

(In reply to Andrei Ciure[:aciure] from comment #20)

log: https://treeherder.mozilla.org/logviewer.html#?job_id=298538484&repo=autoland

Build: - windows10-64-shippable-qr -

[task 2020-04-21T00:36:46.463Z] 00:36:46 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_startup_syncIPC.js | unexpected PWebRenderBridge::Msg_EnsureConnected sync IPC before handling user events -

(In reply to Dorel Luca [:dluca] from comment #26)

Log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=300804500&repo=autoland&lineNumber=2746

Build: - windows10-64-shippable-qr -

[task 2020-05-05T02:54:24.427Z] 02:54:24 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_startup_syncIPC.js | unused whitelist entry before handling user events: PWebRenderBridge::Msg_EnsureConnected -

It wants an ignoreIfUnused: true,

[task 2020-05-05T02:54:24.429Z] 02:54:24 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_startup_syncIPC.js | unexpected PWebRenderBridge::Msg_EnsureConnected sync IPC before becoming idle -

It wants another entry at "before becoming idle", probably also with ignoreIfUnused: true,.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla78 → ---
Flags: needinfo?(sotaro.ikeda.g)
Pushed by sikeda.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a43f9853075
Remove AllowWebRenderForThisWindow() r=nical
Status: REOPENED → RESOLVED
Closed: 10 months ago10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Regressions: 1635769

== Change summary for alert #25845 (as of Wed, 06 May 2020 12:46:59 GMT) ==

Improvements:

3% raptor-tp6-docs-firefox-cold fcp windows10-64-shippable-qr opt 1,013.29 -> 983.17

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=25845

Regressions: 1638084
Duplicate of this bug: 1644267
You need to log in before you can comment on or make changes to this bug.