Intermittent Quantumrender ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397

RESOLVED FIXED in Firefox 66

Status

()

P3
normal
RESOLVED FIXED
10 months ago
a month ago

People

(Reporter: nataliaCs, Assigned: sotaro)

Tracking

(Blocks: 1 bug)

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 wontfix, firefox61 wontfix, firefox62 wontfix, firefox65 wontfix, firefox66 fixed, firefox67 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=179300474&repo=mozilla-inbound&lineNumber=83897

Task details: https://tools.taskcluster.net/groups/JQ0bN1ylQ7mC2-46_H798Q/tasks/Ok56x1ZjRSSeXGMbwxs5gg/details

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=7fd86a767e08d8eb773bdce22766ded22d02692c&group_state=expanded&selectedJob=179300474

[task 2018-05-19T04:41:21.127Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.127Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.128Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.128Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.129Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.131Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.131Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.132Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.133Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.133Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.134Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.135Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.136Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.136Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.138Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.138Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.139Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.139Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.140Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.141Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.142Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.142Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.143Z] 04:41:21     INFO - PID 6095 | [Parent 6095, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
[task 2018-05-19T04:41:21.145Z] 04:41:21     INFO - TEST-UNEXPECTED-TIMEOUT | /html/dom/dynamic-markup-insertion/document-write/contentType.window.html | expected CRASH
So the real issue here is this bit, right?

[task 2018-05-19T04:40:23.233Z] 04:40:23     INFO - PID 6095 | Assertion failure: GetReadyStateEnum() == nsIDocument::READYSTATE_LOADING (Bad readyState), at /builds/worker/workspace/build/src/dom/html/MediaDocument.cpp:197

The image bridge asserts are presumably just because that process is dead, killed by this fatal assert.  This has nothing to do with graphics.

This is only failing on the tier2 webrender jobs?  :(

Presumably fallout from bug 894215, though why it would be webrender-specific is not clear to me.
Blocks: 894215
Component: Graphics: Layers → Document Navigation
Summary: Intermittent ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397 → Intermittent Quantumrender ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 397
Comment hidden (Intermittent Failures Robot)
I guess I should have been clearer that comment 2 is a question about where this is observed to be failing and hence how I should go about trying to reproduce it...
Flags: needinfo?(bzbarsky) → needinfo?(csabou)
All failures except one are on Linux x64 QR - the other one is on OS X.

The failure
a) is intermittent
b) always occurs in /html/dom/dynamic-markup-insertion/document-write/contentType.window.html
c) can be observed before bug 894215 landed - first fail is https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=6c8bf287d25b8d1ebc0392812b9328d57744233c&filter-searchStr=9fcf78c3a312455760c74d8e9f133a3bad6997e4&filter-resultStatus=success&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=running&filter-resultStatus=pending&filter-resultStatus=runnable

The test got added in bug 1449529. Anne, please take a look at this.
No longer blocks: 894215
Flags: needinfo?(csabou) → needinfo?(annevk)
> can be observed before bug 894215 landed

OK, good.  At the same frequency, or do we not know?

Anne isn't going to tell you anything useful here; he just wrote a test that does things you can expect a webpage to do.  The real issue is in the document/navigation code.

Anyway, this looks like a duplicate of bug 1462789, most likely.  And that bug has an rr capture in bug 1462789 comment 4!  I'll take a look at that soonish.
Depends on: 1462789
Flags: needinfo?(annevk)
Oh, and the point is bug 1462789 tracks the "GetReadyStateEnum() == nsIDocument::READYSTATE_LOADING" assert failure.  This bug is tracking the image bridge thing, but that's very likely to be a webrender-specific assert that just ends up firing any time the content process dies.  And it's dying because of the readystate assert.  So I expect fixing bug 1462789 will fix this specific manifestation of the image bridge assert, but there can in general be lots of causes of the image bridge thing: anything that kills the content process.
Comment hidden (Intermittent Failures Robot)
Moving this bug to WebRender component so that we robustify the WebRender code against a content process dying. We can use bug 1462789 to track the specific content process crash that's the root cause of this intermittent failure.
Component: Document Navigation → Graphics: WebRender
Batch updating status flags based on WR schedule - please adjust if needed.
status-firefox60: --- → wontfix
status-firefox61: --- → wontfix
status-firefox62: --- → fix-optional
Blocks: 1386669
Priority: -- → P3
Comment hidden (Intermittent Failures Robot)
Blocks: 1386674
No longer blocks: 1386669

There are several reports with this assertion spam and a (random?) test failing (e.g. bug 1522767, bug 1522769).

Jeff, can you check what has changed, please?

Flags: needinfo?(jmuizelaar)

No idea what would cause this. Sotaro, do you have any idea?

Flags: needinfo?(jmuizelaar) → needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 15

2 months ago

I also do not have idea what cause this :(

default m-c caused a lot of intermittent failures on both Linux x64 QuantumRender debug and Linux x64 QuantumRender opt.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c9c42930de4e5663f0e2395bde9e331dd7c9a92c

In Linux x64 QuantumRender opt failures, there were "INFO - IOError on command, setting status to CRASH" message just before TEST-UNEXPECTED-CRASH.

Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 16

2 months ago

(In reply to Sotaro Ikeda [:sotaro] from comment #15)

I also do not have idea what cause this :(

default m-c caused a lot of intermittent failures on both Linux x64 QuantumRender debug and Linux x64 QuantumRender opt.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c9c42930de4e5663f0e2395bde9e331dd7c9a92c

I added the log and tried tests. Same failure happened on both Linux x64 QuantumRender debug and Linux x64 QuantumRender opt. And
ImageBridgeParent::GetInstance() was called for already destroyed ImageBridgeParent.

https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=224869360&revision=6b6237c39b2fb098afb29d2f22b1418adb5f709c

(Assignee)

Updated

2 months ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 17

2 months ago

By try tests log, ImageBridgeParent::GetInstance() was called from ImageBridgeParent::NotifyImageComposites(). The NotifyImageComposites() seems to have a problem when ImageBridgeParent::GetInstance() fails.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=91525548a35f61eee106bc523a079ab3e295dec2&selectedJob=225095326

(Assignee)

Comment 18

2 months ago

By comment 17, this bug needs to be addressed as part of Bug 1386669.

(Assignee)

Updated

2 months ago
Blocks: 1386669
No longer blocks: 1386674
(Assignee)

Updated

2 months ago
See Also: → bug 1522767, bug 1522769
(Assignee)

Updated

2 months ago
Blocks: 1416614

Comment 21

2 months ago
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1285ba28ba4b
Fix iteration in ImageBridgeParent::NotifyImageComposites() r=mattwoodrow

Comment 22

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox67: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
(Assignee)

Comment 23

2 months ago

Comment on attachment 9040309 [details]
Bug 1462885 - Fix iteration in ImageBridgeParent::NotifyImageComposites()

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1462885

User impact if declined

Whole firefox rendering could freeze after closing a window playing a video if WebRender is used. The problem could rarely happen also without WebRender.

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

none

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

It is a simple fix to address iteration problem.

String changes made/needed

none

Attachment #9040309 - Flags: approval-mozilla-beta?
status-firefox65: --- → fix-optional
status-firefox66: --- → affected

Comment on attachment 9040309 [details]
Bug 1462885 - Fix iteration in ImageBridgeParent::NotifyImageComposites()

Avoids a hang, let's uplift for beta 5.
Should also be helpful for WebRender experiments in 66.

Attachment #9040309 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment hidden (Intermittent Failures Robot)

Comment 26

2 months ago
bugherderuplift
status-firefox66: affected → fixed
status-firefox62: fix-optional → wontfix
status-firefox65: fix-optional → wontfix

:sotaro , the fail reappeared on mozilla-beta as a Tier2 failure.
Could you please take a look?

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=226471409&repo=mozilla-beta&lineNumber=57975

Log snippet:

[task 2019-02-06T12:43:15.361Z] 12:43:15 INFO - TEST-START | /html/webappapis/dynamic-markup-insertion/document-write/document.write-01.xhtml
[task 2019-02-06T12:43:15.389Z] 12:43:15 INFO - PID 7133 | [Child 7245, Main Thread] WARNING: NS_ENSURE_TRUE(domReturn) failed: file /builds/worker/workspace/build/src/dom/base/nsGlobalWindowOuter.cpp, line 7207
[task 2019-02-06T12:43:15.395Z] 12:43:15 INFO - PID 7133 | ++DOCSHELL 0x7fe8724cc000 == 1 [pid = 8743] [id = {7450fcb0-8dd7-45d0-bccf-77790f968ea2}]
[task 2019-02-06T12:43:15.476Z] 12:43:15 INFO - PID 7133 | ++DOMWINDOW == 1 (0x7fe87121b000) [pid = 8743] [serial = 1] [outer = (nil)]
[task 2019-02-06T12:43:15.518Z] 12:43:15 INFO - PID 7133 | ++DOMWINDOW == 2 (0x7fe871220000) [pid = 8743] [serial = 2] [outer = 0x7fe87121b000]
[task 2019-02-06T12:43:15.555Z] 12:43:15 INFO - PID 7133 | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpr9N0u1.mozrunner/runtests_leaks_852_tab_pid8780.log
[task 2019-02-06T12:43:15.623Z] 12:43:15 INFO - PID 7133 | [Parent 7133, Compositor] ###!!! ASSERTION: Cannot find image bridge for process!: 'false', file /builds/worker/workspace/build/src/gfx/layers/ipc/ImageBridgeParent.cpp, line 363
[task 2019-02-06T12:43:15.816Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 15 (0x7f7ba339b000) [pid = 8711] [serial = 14] [outer = (nil)] [url = http://web-platform.test:8000/images/red.png]
[task 2019-02-06T12:43:15.819Z] 12:43:15 INFO - PID 7133 | --DOCSHELL 0x7f7ba80a5800 == 4 [pid = 8711] [id = {774d9c15-d8ac-4fe3-9ee4-e95d5bcb2500}]
[task 2019-02-06T12:43:15.820Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 14 (0x7f7ba6e17000) [pid = 8711] [serial = 1] [outer = (nil)] [url = http://web-platform.test:8000/html/webappapis/dynamic-markup-insertion/document-write/contentType.window.html]
[task 2019-02-06T12:43:15.821Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 13 (0x7f7ba6e1c000) [pid = 8711] [serial = 2] [outer = (nil)] [url = about:blank]
[task 2019-02-06T12:43:15.823Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 12 (0x7f7ba3398c00) [pid = 8711] [serial = 13] [outer = (nil)] [url = http://web-platform.test:8000/common/blank.html]
[task 2019-02-06T12:43:15.824Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 11 (0x7f7ba6ecf000) [pid = 8711] [serial = 3] [outer = (nil)] [url = about:blank]
[task 2019-02-06T12:43:15.824Z] 12:43:15 INFO - PID 7133 | --DOCSHELL 0x7f7ba6aa0800 == 3 [pid = 8711] [id = {26ae7489-1bfc-4542-adc1-b7e82c723636}]
[task 2019-02-06T12:43:15.825Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 10 (0x7f7ba6e23000) [pid = 8711] [serial = 5] [outer = (nil)] [url = http://web-platform.test:8000/images/pattern.ogv]
[task 2019-02-06T12:43:15.825Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 9 (0x7f7ba6ecfc00) [pid = 8711] [serial = 6] [outer = (nil)] [url = about:blank]
[task 2019-02-06T12:43:15.825Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 8 (0x7f7ba3338000) [pid = 8711] [serial = 16] [outer = (nil)] [url = http://web-platform.test:8000/common/text-plain.txt]
[task 2019-02-06T12:43:15.825Z] 12:43:15 INFO - PID 7133 | --DOCSHELL 0x7f7ba743c800 == 2 [pid = 8711] [id = {889b4f91-d03d-4814-9210-1f30d2a4f8e6}]
[task 2019-02-06T12:43:15.826Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 7 (0x7f7ba805b800) [pid = 8711] [serial = 7] [outer = (nil)] [url = http://web-platform.test:8000/images/red.png]
[task 2019-02-06T12:43:15.826Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 6 (0x7f7ba805c800) [pid = 8711] [serial = 8] [outer = (nil)] [url = about:blank]
[task 2019-02-06T12:43:15.826Z] 12:43:15 INFO - PID 7133 | --DOCSHELL 0x7f7ba7445800 == 1 [pid = 8711] [id = {869207e0-f96f-4f3e-a1b5-4d7a082cdecb}]
[task 2019-02-06T12:43:15.826Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 5 (0x7f7ba805f800) [pid = 8711] [serial = 9] [outer = (nil)] [url = http://web-platform.test:8000/common/text-plain.txt]
[task 2019-02-06T12:43:15.826Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 4 (0x7f7ba805fc00) [pid = 8711] [serial = 10] [outer = (nil)] [url = about:blank]
[task 2019-02-06T12:43:15.830Z] 12:43:15 INFO - PID 7133 | --DOCSHELL 0x7f7ba7447800 == 0 [pid = 8711] [id = {cde748ae-295a-4b11-8f97-f2d4b3ec9897}]
[task 2019-02-06T12:43:15.830Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 3 (0x7f7bbf0d0000) [pid = 8711] [serial = 11] [outer = (nil)] [url = http://web-platform.test:8000/common/blank.html]
[task 2019-02-06T12:43:15.831Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 2 (0x7f7ba6ece000) [pid = 8711] [serial = 12] [outer = (nil)] [url = about:blank]
[task 2019-02-06T12:43:15.831Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 1 (0x7f7ba33e1800) [pid = 8711] [serial = 15] [outer = (nil)] [url = http://web-platform.test:8000/images/pattern.ogv]
[task 2019-02-06T12:43:15.832Z] 12:43:15 INFO - PID 7133 | --DOMWINDOW == 0 (0x7f7ba6e21400) [pid = 8711] [serial = 4] [outer = (nil)] [url = http://web-platform.test:8000/html/webappapis/dynamic-markup-insertion/document-write/contentType.window.html]
[task 2019-02-06T12:43:15.861Z] 12:43:15 INFO - PID 7133 | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2019-02-06T12:43:15.879Z] 12:43:15 INFO - PID 7133 | nsStringStats
[task 2019-02-06T12:43:15.879Z] 12:43:15 INFO - PID 7133 | => mAllocCount: 10443
[task 2019-02-06T12:43:15.880Z] 12:43:15 INFO - PID 7133 | => mReallocCount: 0
[task 2019-02-06T12:43:15.880Z] 12:43:15 INFO - PID 7133 | => mFreeCount: 10443
[task 2019-02-06T12:43:15.882Z] 12:43:15 INFO - PID 7133 | => mShareCount: 9482
[task 2019-02-06T12:43:15.883Z] 12:43:15 INFO - PID 7133 | => mAdoptCount: 487
[task 2019-02-06T12:43:15.883Z] 12:43:15 INFO - PID 7133 | => mAdoptFreeCount: 523
[task 2019-02-06T12:43:15.883Z] 12:43:15 INFO - PID 7133 | => Process ID: 8711, Thread ID: 140169486419776
[task 2019-02-06T12:43:15.932Z] 12:43:15 INFO - PID 7133 | ++DOMWINDOW == 3 (0x7fe8713ce000) [pid = 8743] [serial = 3] [outer = 0x7fe87121b000]
[task 2019-02-06T12:43:16.030Z] 12:43:16 INFO - PID 7133 | [Child 8743, Main Thread] WARNING: site security information will not be persisted: file /builds/worker/workspace/build/src/security/manager/ssl/nsSiteSecurityService.cpp, line 506
[task 2019-02-06T12:43:16.031Z] 12:43:16 INFO - PID 7133 | [Parent 7133, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/workspace/build/src/netwerk/url-classifier/UrlClassifierCommon.cpp, line 125
[task 2019-02-06T12:43:16.047Z] 12:43:16 INFO - PID 7133 | ++DOMWINDOW == 4 (0x7fe871224c00) [pid = 8743] [serial = 4] [outer = 0x7fe87121b000]
[task 2019-02-06T12:43:16.185Z] 12:43:16 INFO - Closing window 115964116993
[task 2019-02-06T12:43:16.248Z] 12:43:16 INFO - PID 7133 | [Child 8743, Main Thread] WARNING: NS_ENSURE_TRUE(maybeContext) failed: file /builds/worker/workspace/build/src/xpcom/threads/nsThread.cpp, line 869
[task 2019-02-06T12:43:16.264Z] 12:43:16 INFO - Got chrome assert count 1
[task 2019-02-06T12:43:16.282Z] 12:43:16 INFO - TEST-UNEXPECTED-FAIL | /html/webappapis/dynamic-markup-insertion/document-write/document.write-01.xhtml | assertion count 1 is more than expected 0 assertions
[task 2019-02-06T12:43:16.283Z] 12:43:16 INFO - .
[task 2019-02-06T12:43:16.284Z] 12:43:16 INFO - TEST-OK | /html/webappapis/dynamic-markup-insertion/document-write/document.write-01.xhtml | took 920ms

Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 29

2 months ago

(In reply to Narcis Beleuzu [:NarcisB] from comment #27)

:sotaro , the fail reappeared on mozilla-beta as a Tier2 failure.
Could you please take a look?

The fix addresses the infinite loop in ImageBridgeParent::NotifyImageComposites(), but "Cannot find image bridge for process" could sometimes happen with WebRender because of its architecture. It seems better to change NS_ASSERTION to NS_WARNING.

Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 30

2 months ago

Created Bug 1525818 for comment 29.

(Assignee)

Updated

2 months ago
Depends on: 1525818
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.