Japanese (2-byte) text doesn't cut/paste properly

VERIFIED DUPLICATE of bug 148395

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 148395
16 years ago
14 years ago

People

(Reporter: Lachlan Arnott, Assigned: Samir Gehani)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051005

Problem:  Putting (Mac) Japanese text from Mozilla page onto the clipboard for
pasting into another application - eg. Japanese SimpleText text editor.

Tried on separate Macs with Systems 8.6 and 9.1 / Japanese Laguage Kit (Apple)
Same problem occurs with both Mozilla versions 0.9.9 and 1.0 RC2.

The Jp text (from the clip board) displays the one-byte parts ok (eg. English), 
but the two-byte (Jp characters) paste as question marks.

Almost certain it's not a config. problem, as Netscape 4.7x on the same 
Machines copies/pastes Jp text from Web pages (eg. www.nikkei.co.jp) fine.

Reproducible: Always
Steps to Reproduce:
1. Get a Mac with the Japanese Language Kit (Apple) installed (OS enhancement)
2. Go to a Jp. Web site (eg. www.nikkei.co.jp) and go to a page with Jp text.
3. Try to copy/paste text from the Jp web-page into any Jp text editor (eg. Mac
    SimpleText)  

Actual Results:  One-byte portions (eg. Engish text) pastes ok.  Two-byte
portions (Jp. Characters)
paste as question marks - no matter which app. they are pasted into.

Expected Results:  Clipboard should have retained the Two-byte nature of the
charaters.

Comment 1

16 years ago
may be dup/related to bug bug 119877 or bug 119899
Resolving as dup of bug 148395 for now

*** This bug has been marked as a duplicate of 148395 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.