Copy & Paste of Japanese into other applications fails

RESOLVED DUPLICATE of bug 108029

Status

()

Core
Internationalization
RESOLVED DUPLICATE of bug 108029
16 years ago
16 years ago

People

(Reporter: mozilla, Assigned: nhottanscp)

Tracking

({intl})

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When copying and pasting from Mozilla into another app, in this case a
dictionary the 8 bit shift-jis characters fail to appear, instead are rendered
as ????

pages have correctly set character type and characters are correctly displayed
on-screen in MoZilla

Comment 1

16 years ago
Dupe of bug 110714?

Reporter, which version do you use, please provide exact steps to reproduce.

pi

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → kasumi
(Reporter)

Comment 2

16 years ago
Bug reporter uses: 
Mozilla 1.0 Release Candidate 2
Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0rc2) Gecko/20020510

Reproduction of bug: 
Japanese kanji copied from Mozilla window and pasted into MacJDic 1.3.4 (based
on Jim Breen's Edict)
*** Bug 148393 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
related to bug 119877 or bug 119899 ?

Comment 5

16 years ago
I think so.

Comment 6

16 years ago
*** Bug 146428 has been marked as a duplicate of this bug. ***
*** Bug 155009 has been marked as a duplicate of this bug. ***
to intl; this has nothing to do with localization
Assignee: rchen → yokoyama
Component: Localization → Internationalization
QA Contact: kasumi → ruixu
confirm based on dup
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

16 years ago
Twiddeling with data I could get Japanese text from Mozilla to another application:
Copy text from Mozilla e-mail page
Paste it into a composer page
Save that file (save as charset - Japanese)
Open that file with Netscape navigator 4.7
Therefrom copy and paste the text into the application.

Comment 11

16 years ago
Mac -> nhotta and cc myself
Assignee: yokoyama → nhotta

Updated

16 years ago
QA Contact: ruixu → kasumi
(Reporter)

Comment 12

16 years ago
I copied Japanese text from a browser window into the composer window and did
"save to charset", chose Japanese and checked the "export to text" using the
Japanese option.

The resulting text file could be opened and read in EudoraJ 4.3 Mac.
(Reporter)

Comment 13

16 years ago
Also (sorry for the noise), pages containing Japanese characters saved as text
file (Save page as -> text file) also display in a text editor with the proper
encoding.

But pasting from Mozilla into another Japanese encoding savvy application fails.
(Assignee)

Comment 14

16 years ago
Is this about Japanese copy/paste support for non Japanese system?
Bug 108029 inlcudes that case.
Status: NEW → ASSIGNED

Comment 15

16 years ago
tested 2002-07-09-05-1.0
On non-Japanese(Englsih) Mac OS 9.1 occured.
On Japanese Mac OS 9.1 didn't occur.
(Assignee)

Comment 16

16 years ago
>On non-Japanese(Englsih) Mac OS 9.1 occured.
This is taken care by bug 108029.

*** This bug has been marked as a duplicate of 108029 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.