Closed Bug 14645 Opened 21 years ago Closed 20 years ago

Profiles not migrated if the user doesn't install mailnews

Categories

(Core Graveyard :: Profile: Migration, defect, P1, blocker)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: trudelle, Assigned: sspitzer)

References

Details

(Whiteboard: [nsbeta2+])

Downloaded today's opt commercial bits.
deleted Users50 folder
deleted mozregistry.dat
ran apprunner -installer
got the profile migration dialog.
selected my primary profile
clicked start
disk spun a bit
Result: New profile with same name as my primary profile, but with default
contents and no bookmarks.
Expected results: New profile that is a copy of my primary profile.
Peter, are you by any chance running low on disk space?
No, I've got 1 GB free.  SElmer sat here with me and tried everything he could
think of (he asked about disk space too), to no avail.  100% reproducible on
Win98 today.
Status: NEW → ASSIGNED
Peter, are you still seeing this now that Seth's changes have landed?
Today's opt bits migrated profiles on Win98.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Peter, your last comment sounds like WORKSFORME.  If I misunderstood, please
reopen.
Status: RESOLVED → VERIFIED
verified worksforme
Ran across this bug today, played with it a while was able to figure out factors 
to its reproduction.!
1. Must be installed as Base, if mail/news is installed Bug will not produce
2. Previous profile must be set to pop3 for mail.
     The important factor in the pop3 I was able to figure was the missing line
     user_pref("mail.server_type", 1);  In prefs.js
     It is not created when using pop3 in 4.72 (maby earlier also.)
     If line is deleted in an imap setup will recreate error also.
:) don't you just hate me.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Increased Severity to critical, as this would have a huge effect on beta. Many 
beta testers may have pop3 set up in their old netscape and wish to only install 
base.
Severity: normal → critical
Hate to be annoying but this is a bug you simply can't go into beta with. All
the recent beta branchs have it.
If the user currently has a pop3 account set up in netscape 4.7x
and uses mozilla-installer-nb2b and just installs base. It will NOT migrate the
profile in windows!
Severity: critical → blocker
wait a second.

you report that mailnews migration fails if you don't install mailnews?
(you only install base?)

of course it is going to fail.  the mailnews migration code is in the mailnews 
package.

or am I misunderstanding?
johnlar - do your bookmarks migrate in the scenario you mentioned?
No nothing migrates. You don't even get the default bookmarks for a new profile. 
You get nothing.
If line user_pref("mail.server_type", 1);
is missing from pref.js the entire migration fails.. (any other line can be 
missing. but if that line is gone it dies)
ok, if nothing migrates, that's bad.  we should gracefully handle mailnews not 
being there.  I'll take this bug.

updating summary.
Assignee: selmer → sspitzer
Status: REOPENED → NEW
Summary: Profiles not migrated → Profiles not migrated if the user doesn't install mailnews
so? did this make it into beta? Just curious, if not you might want a release 
note or something telling people to install mail/news if they are migrating from 
Netscape 4.x
I still haven't gotten to testing this bug.  (got bigger fish to fry).

yes, this would be something to relnote for beta.


setting to m15, accepting.
Status: NEW → ASSIGNED
Target Milestone: --- → M15
Keywords: beta2
having problems reproducing this on the tip.

but it maybe because I don't have activation turned on.  

I see some code in mozilla/profile/nsProfile.cpp that may not fail gracefully
with out mailnews installed

either way, this is not getting fixed for m15.

luckily, there is a work around (if this is still broken) which is to install
mailnews.

I'll continue to investigate.
Target Milestone: M15 → M16
*** Bug 35132 has been marked as a duplicate of this bug. ***
BTW basically the problem is in line 490 of nsPrefMigration.cpp
It fails because current netscape often sets pop as not having line
user_pref("mail.server_type", 1);  Instead of it being 
user_pref("mail.server_type", 0);  As the migration expect, a simple
If fail assume server is pop would suffice.. but I'm not a programmer :) 
Otherwise I would fix it myself :)  (bug is starting to annoy me, because I like 
to install just the navigator for many nightlies, but like to migrate from a 
current netscape profile (hey and I got a vote woho :).
johnlar, your last comments confuse me.

if mail.server_type is not set in prefs.js, then it defaults to 0, which is pop.

(note, if mail.server_type is 1, that indicates imap.)

this bug report (and #35132), it sounds like the real problem is if you don't 
download & install the mailnews component, we bail out of migration, instead of 
proceeding gracefully.  
apologies to johnlar, he is right on the money.

mail.server_type defaults to 0, ONLY IF mailnews.js is package/defaults/pref 
directory.

well, mailnews.js only gets unpackaged in the case where the user downloads and 
installs mail&news.

so, just as johnlar reported, a pop user (who didn't download and install 
mailnews) would fail to migrate.  (in the case of pop, mail.server_type 
would be 0, which would be the same as the default, so it wouldn't be in the 
user's prefs.js file.)  just as he reported, we'd fail line 490 of 
nsPrefMigration.cpp

I'm worried that there will be a bunch of failures (in migration) due to 
the defaults (in) mailnews.js not being present.  a simple fix would be to move 
mailnews.js from the [mail] package to the [browser] package in 
mozilla/xpinstall/packager/packages-[win|mac|unix]

I'm going to do that tomorrow, I've got the fix in my tree.

the only concern I have about migration failing now is in nsProfile.cpp, line 
1552, where get the account manager, during netcenter activation.

Whiteboard: fix in hand
moving p1, as I plan on working on these bugs first.  accepting, if not already
accepted.
Priority: P3 → P1
fixed.  (still worried about activation problems if mailnews is not installed, 
but I log a new bug on that.)

the fix for this is to make sure mailnews.js (and mailnews-ns.js) are part of 
the base browser install.  
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
This is still not fixed in 2000041305, considering you marked this as fixed on
early morning on the 12th, suprised its still not fixed on the 13th. Will reopen
if still not working tomorrow.
just curious, are you testing m15 bits or m16 bits?

looks ok on 2000-04-14-10M16 and 2000-04-14-07M15
Status: RESOLVED → VERIFIED
Reopening
NOT working for 2000-04-14-07M15, working on 2000-04-14-10M16
And again NOT working on 2000-04-18-05M16.
Incase your confused way to reproduce 1 more time
1. Previous profile must be set to pop3 for mail.
2. Must use mozilla-win32-installer.exe
3. Must be installed as Base, if mail/news is installed Bug will not produce
4. Bookmarks will not be migrated






Status: VERIFIED → REOPENED
Resolution: FIXED → ---
johnlar@tfn.net,

Using your steps I was able to reproduce (not sure what I did to verify :( )- on 
build 2000-04-14-07M15 and 
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/ --which is 2000-04-19-0?
Bookmarks are not migrated on a pop3 mail profile
clearing status whiteboard. accepting again.
Status: REOPENED → ASSIGNED
Whiteboard: fix in hand
Putting on [nsbeta2+] radar.
Keywords: beta2nsbeta2
Whiteboard: [nsbeta2+]
moving to m17, since it is not a m16 blocker.

I plan on working on this bug now.
Target Milestone: M16 → M17
ok, I can reproduce this.

if I install and choose "Base" I can reproduce this.  (the problem is 
mailnews.js is not part of "Base".
 
(Note, if I choose "Custom" but uncheck "Mail & News" this bug does not occur.)
ok, found the problem.

the default pref file for mailnews (mailnews.js) are not part of the 
"Base" install.

at one point, they were.

to avoid future regressions, I made it so all the default pref files are part of 
the browser component (and therefore "Base")   

; all the pref files must be part of base
; to prevent migration bugs
bin\defaults\pref\*

should be fixed in tomorrow's build.

thanks again to johnlar for the excellent bug diligence.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
ok, in both the ns and the mozilla trees, all the default pref files get
packaged with the browser.
Sorry, I moved mailnews.js last week when I moved the mailnews chrome out of 
the browser package. It was not obvious that something called mailnews.js was a 
required part of the browser -- maybe you could add a comment to the package 
lists.  I suspect I won't be the only one to come along and "clean up" the 
package lists

Better yet, if these prefs really are required then move them back into all.js 
to eliminate confusion and save a smidgen of file i/o on startup.
it is understandable why mailnews.js got moved.

I added a comment to the packager-* files to avoid confusion.

between the comment and the use of the wildcard, nothing more to do 
here.  (especially for beta2)

*** Bug 41496 has been marked as a duplicate of this bug. ***
mozilla build 2000060720
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.