The "Edit Pop-up Blocker Options/Preferences" command should open the in-content preferences

VERIFIED FIXED in Firefox 65

Status

()

P1
normal
VERIFIED FIXED
10 months ago
3 months ago

People

(Reporter: Paolo, Assigned: Paolo)

Tracking

unspecified
Firefox 66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65+ verified, firefox66+ verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 months ago
The "Edit Pop-up Blocker Preferences" command in the notification bar shown when a popup is blocked is the last user of "permissions.xul" in a separate window that remains in non-test code.

Changing this to open the preferences in-content will allow us to remove support for opening the dialog in a separate window.

While the "Edit Pop-up Blocker Preferences" is not covered by regression tests, some other tests may currently open the dialog in a separate window, and they may have to be adjusted.
(Assignee)

Updated

3 months ago
Summary: The "Edit Pop-up Blocker Options/Preferences" command should open the permissions dialog in-content → The "Edit Pop-up Blocker Options/Preferences" command should open the in-content preferences
(Assignee)

Updated

3 months ago
Blocks: 1514223
(Assignee)

Comment 1

3 months ago
Instead of opening the pop-up permissions dialog with the origin already populated, this command now highlights the pop-up permission row in the preferences. This doesn't remove any functionality because the only action that would be available for the origin in the permissions dialog is "Allow", which is equivalent to the "Allow pop-ups for" command in the notification bar menu.
(Assignee)

Comment 2

3 months ago
I'd like to uplift this to Beta to fix bug 1514223. This also removes the last use of the permissions dialog outside of the in-content preferences.
(Assignee)

Updated

3 months ago
Priority: P3 → P1

Comment 4

3 months ago
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6960ca4db506
The "Edit Pop-up Blocker Options/Preferences" command should open the in-content preferences. r=jaws
(Assignee)

Updated

3 months ago
Flags: qe-verify+

Updated

3 months ago
Duplicate of this bug: 1514223
(Assignee)

Comment 6

3 months ago
[Tracking Requested - why for this release]:
Tracking requested per bug 1514223.
status-firefox65: --- → affected
status-firefox66: --- → affected
tracking-firefox65: --- → ?
tracking-firefox66: --- → ?

Comment 7

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6960ca4db506
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
status-firefox66: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Please nominate this for Beta approval when you get a chance.
tracking-firefox65: ? → +
tracking-firefox66: ? → +
Flags: needinfo?(paolo.mozmail)

Comment 9

3 months ago
Verified - Fixed on latest Nightly 66.0a1 (2018-12-28) on Windows 10, Mac OS 10.13 and Ubuntu 16.04
Clicking on Option -> Edit Pop-up Blocker options... will lead the user to the about:preferences#privacy page with the "Block pop-up windows" option highlighted.
status-firefox66: fixed → verified
(Assignee)

Comment 10

3 months ago
Comment on attachment 9032629 [details]
Bug 1466817 - The "Edit Pop-up Blocker Options/Preferences" command should open the in-content preferences. r=jaws

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1493844

User impact if declined: Bug 1514223

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: See comment 9

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Risk is limited to the feature

String changes made/needed: None
Flags: needinfo?(paolo.mozmail)
Attachment #9032629 - Flags: approval-mozilla-beta?
Comment on attachment 9032629 [details]
Bug 1466817 - The "Edit Pop-up Blocker Options/Preferences" command should open the in-content preferences. r=jaws

[Triage Comment]
Fixes a styling issue and provides a more consistent preferences experience. Approved for 65.0b8.
Attachment #9032629 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 12

3 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/d444faf56f5c
status-firefox65: affected → fixed
(Assignee)

Updated

3 months ago
No longer depends on: 1516340
Verified as fixed on 65.0b8 20190103150357 on Winddows 10 x32 , Ubuntu 16.04 x64 and OSX 10.14.2.
Status: RESOLVED → VERIFIED
status-firefox65: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.