Closed Bug 1467039 Opened Last year Closed Last year

Local builds don't default to gold when it's available anymore

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62 fixed)

RESOLVED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- unaffected
firefox62 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

This is a regression from bug 1455767. Before that bug, building locally without e.g. --enable-release would build with gold if it's installed. After, gold is only picked if --enable-gold is explicitly passed.
Assignee: nobody → mh+mozilla
Depends on: 1467041
No longer depends on: 1467041
Blocks: 1467337
Attachment #8983988 - Flags: review?(core-build-config-reviews) → review?(cmanchester)
Comment on attachment 8983988 [details]
Bug 1467039 - Default to gold on local builds.

https://reviewboard.mozilla.org/r/249860/#review256888
Attachment #8983988 - Flags: review?(cmanchester) → review+
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/0c800e84c991
Default to gold on local builds. r=chmanchester
Backed out changeset 0c800e84c991 (bug 1467039) for Spidermonkey failure. CLOSED TREE

Log:
https://treeherder.mozilla.org/logviewer.html#?job_id=182892222&repo=autoland&lineNumber=58758
/usr/bin/ld.gold: error: prtime.o: unsupported reloc 42 against global symbol PR_LocalTimeParameters
[task 2018-06-12T05:07:57.221Z] /builds/worker/workspace/gcc/bin/../lib/gcc/x86_64-pc-linux-gnu/6.4.0/crtbeginS.o(.text+0x1e): error: unsupported reloc 42
[task 2018-06-12T05:07:57.221Z] /builds/worker/workspace/gcc/bin/../lib/gcc/x86_64-pc-linux-gnu/6.4.0/crtbeginS.o(.text+0x6b): error: unsupported reloc 42
[task 2018-06-12T05:07:57.221Z] /builds/worker/workspace/gcc/bin/../lib/gcc/x86_64-pc-linux-gnu/6.4.0/crtbeginS.o(.text+0xeb): error: unsupported reloc 42
[task 2018-06-12T05:07:57.221Z] /usr/bin/ld.gold: internal error in value_from_output_section, at ../../gold/reloc.cc:1549
[task 2018-06-12T05:07:57.222Z] collect2: error: ld returned 1 exit status
[task 2018-06-12T05:07:57.222Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/config/rules.mk:679: recipe for target 'libnspr4.so' failed
[task 2018-06-12T05:07:57.222Z] make[3]: *** [libnspr4.so] Error 1
[task 2018-06-12T05:07:57.222Z] make[3]: Leaving directory '/builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/config/external/nspr/pr'
[task 2018-06-12T05:07:57.222Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/config/recurse.mk:74: recipe for target 'config/external/nspr/pr/target' failed
[task 2018-06-12T05:07:57.222Z] make[2]: *** [config/external/nspr/pr/target] Error 2
[task 2018-06-12T05:07:57.222Z] make[2]: *** Waiting for unfinished jobs....
[task 2018-06-12T05:07:57.222Z] /builds/worker/workspace/gcc/bin/g++ -o BinTokenReaderTester.o -c -I/builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/dist/system_wrappers -include /builds/worker/workspace/sm-package/mozjs-62.0a1.0/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DENABLE_BINARYDATA -DENABLE_SIMD -DENABLE_WASM_BULKMEM_OPS -DENABLE_WASM_SATURATING_TRUNC_OPS -DENABLE_WASM_THREAD_OPS -DENABLE_WASM_GC -DWASM_HUGE_MEMORY -DJS_CACHEIR_SPEW -DENABLE_SHARED_ARRAY_BUFFER -DEXPORT_JS_API -DMOZ_HAS_MOZGLUE -I/builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src -I/builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/js/src -I/builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/dist/include -I/builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/dist/include/nspr -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/js/src/js-confdefs.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wduplicated-cond -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -freorder-blocks -O3 -fno-omit-frame-pointer -Wno-shadow -Werror=format -fno-strict-aliasing  -MD -MP -MF .deps/BinTokenReaderTester.o.pp   /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinTokenReaderTester.cpp
[task 2018-06-12T05:07:57.316Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinSource-auto.cpp: In member function 'JS::Result<js::frontend::ParseNode*> js::frontend::BinASTParser<Tok>::parseInterfaceBinaryExpression(size_t, js::frontend::BinKind, const BinFields&) [with Tok = js::frontend::BinTokenReaderTester]':
[task 2018-06-12T05:07:57.316Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinSource-auto.cpp:3531:27: warning: 'pnk' may be used uninitialized in this function [-Wmaybe-uninitialized]
[task 2018-06-12T05:07:57.316Z]      if (left->isKind(pnk) &&
[task 2018-06-12T05:07:57.316Z]                             
[task 2018-06-12T05:07:57.429Z] In file included from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/FullParseHandler.h:15:0,
[task 2018-06-12T05:07:57.429Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BCEParserHandle.h:11,
[task 2018-06-12T05:07:57.429Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinSource.h:19,
[task 2018-06-12T05:07:57.429Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinSource-auto.cpp:20:
[task 2018-06-12T05:07:57.429Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/ParseNode.h: In member function 'JS::Result<js::frontend::ParseNode*> js::frontend::BinASTParser<Tok>::parseInterfaceUnaryExpression(size_t, js::frontend::BinKind, const BinFields&) [with Tok = js::frontend::BinTokenReaderTester]':
[task 2018-06-12T05:07:57.429Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/ParseNode.h:494:24: warning: 'pnk' may be used uninitialized in this function [-Wmaybe-uninitialized]
[task 2018-06-12T05:07:57.429Z]          pn_next(nullptr)
[task 2018-06-12T05:07:57.429Z]                         ^
[task 2018-06-12T05:07:57.429Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinSource-auto.cpp:7363:19: note: 'pnk' was declared here
[task 2018-06-12T05:07:57.429Z]      ParseNodeKind pnk;
[task 2018-06-12T05:07:57.429Z]                    ^~~
[task 2018-06-12T05:07:57.525Z] In file included from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/FullParseHandler.h:15:0,
[task 2018-06-12T05:07:57.525Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BCEParserHandle.h:11,
[task 2018-06-12T05:07:57.525Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinSource.h:19,
[task 2018-06-12T05:07:57.525Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinSource-auto.cpp:20:
[task 2018-06-12T05:07:57.525Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/ParseNode.h: In member function 'JS::Result<js::frontend::ParseNode*> js::frontend::BinASTParser<Tok>::parseInterfaceVariableDeclaration(size_t, js::frontend::BinKind, const BinFields&) [with Tok = js::frontend::BinTokenReaderTester]':
[task 2018-06-12T05:07:57.525Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/ParseNode.h:510:17: warning: 'pnk' may be used uninitialized in this function [-Wmaybe-uninitialized]
[task 2018-06-12T05:07:57.525Z]          pn_type = kind;
[task 2018-06-12T05:07:57.525Z]          ~~~~~~~~^~~~~~
[task 2018-06-12T05:07:57.525Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinSource-auto.cpp:7527:19: note: 'pnk' was declared here
[task 2018-06-12T05:07:57.525Z]      ParseNodeKind pnk;
[task 2018-06-12T05:07:57.525Z]                    ^~~
[task 2018-06-12T05:07:57.901Z] In file included from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/dist/include/mozilla/Result.h:17:0,
[task 2018-06-12T05:07:57.901Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/dist/include/js/Result.h:119,
[task 2018-06-12T05:07:57.901Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/jspubtd.h:17,
[task 2018-06-12T05:07:57.901Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/TokenStream.h:177,
[task 2018-06-12T05:07:57.901Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinTokenReaderBase.h:11,
[task 2018-06-12T05:07:57.901Z]                  from /builds/worker/workspace/sm-package/mozjs-62.0a1.0/js/src/frontend/BinTokenReaderBase.cpp:7:
[task 2018-06-12T05:07:57.901Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/dist/include/mozilla/Variant.h: In member function 'JS::Result<unsigned char> js::frontend::BinTokenReaderBase::readByte()':
[task 2018-06-12T05:07:57.901Z] /builds/worker/workspace/sm-package/mozjs-62.0a1.0/obj-spider/dist/include/mozilla/Variant.h:531:5: warning: 'byte' may be used uninitialized in this function [-Wmaybe-uninitialized]
[task 2018-06-12T05:07:57.901Z]      ::new (KnownNotNull, ptr()) T(std::forward<RefT>(aT));
[task 2018-06-12T05:07:57.901Z]      ^~

Push with failures:
https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=0c800e84c99172c583b2f818cb45e0bdb34e79a8&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified

Backout:
https://hg.mozilla.org/integration/autoland/rev/81c54e582e07179b34a9e7b8cd424fd210c94a4f
Flags: needinfo?(mh+mozilla)
(re-requesting review on purpose because of changes)
Flags: needinfo?(mh+mozilla)
Depends on: 1468646
Attachment #8983988 - Flags: review?(core-build-config-reviews)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/bbc721db121c
Default to gold on local builds. r=chmanchester
https://hg.mozilla.org/mozilla-central/rev/bbc721db121c
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.