Attempting to download from ftp://ftp causes a hang

VERIFIED FIXED in Firefox 62

Status

()

defect
--
blocker
VERIFIED FIXED
11 months ago
7 months ago

People

(Reporter: tgnff242, Assigned: dragana)

Tracking

({dogfood, hang, regression})

62 Branch
mozilla63
Points:
---
Bug Flags:
in-qa-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 unaffected, firefox62+ verified, firefox63 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180605220158

Steps to reproduce:

1. Create a new profile (on a Linux system - not sure if it's required).
2. Open this link to download the file: ftp://ftp.freetds.org/pub/freetds/stable/freetds-patched.tar.gz


Actual results:

Browser stops responding. The main process uses a full logical core of the CPU.


Expected results:

It should download the file.

This is a regression. Bisection points to Bug 1436311.

The following is a crash report after I signaled kill -6 to the main process's pid, about a minute after the hung started: https://crash-stats.mozilla.com/report/index/67fc52a0-2f9e-4e56-86a4-559e70180606

mozregression log:
10:59.19 INFO: Last good revision: 2793f77caa2e91f93d84b74f7e067cf0c8b852f5
10:59.19 INFO: First bad revision: 87e13da123ba0d7d89118093e83e3b803fd7f6c3
10:59.19 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2793f77caa2e91f93d84b74f7e067cf0c8b852f5&tochange=87e13da123ba0d7d89118093e83e3b803fd7f6c3

Comment 1

11 months ago
[Tracking Requested - why for this release]: Browser hags up

I can reproduce the hang on Win10 x64 Nightly62.0a1.
Blocks: 1436311
Status: UNCONFIRMED → NEW
Component: Untriaged → Networking
Ever confirmed: true
Keywords: hang, regression
Product: Firefox → Core
Summary: Attempting to download from ftp://ftp causes a hung → Attempting to download from ftp://ftp causes a hang
Dragana, this could be related to your commit pointed to above. Any clues?
Flags: needinfo?(dd.mozilla)

Comment 3

11 months ago
As a workaround, one can browse to the file location and right-click and download the file, which performs as expected, it's "opening" the file directly from FF that causes crahses.

Comment 4

11 months ago
(In reply to Francois Guerraz from comment #3)
> As a workaround, one can browse to the file location and right-click and
> download the file, which performs as expected, it's "opening" the file
> directly from FF that causes crahses.

Actually, the link from https://iihelp.iinet.net.au/iiNet_Firmware  TG-789 Broadband Gateway's Latest Firmware, right clicking Save link as doesn't actually bring up the window to save, nor does it download it. Clicking the link indefinitely hangs the browser.

Comment 5

11 months ago
@Jules: They mean navigate to the ftp directory (in your case ftp://ftp.iinet.net.au/pub/iinet/firmware/TG789vacV2/VANT-6/) and then right-click Save Link from there.
Tracking for 62, Jason, can you help find someone to take a look?
Flags: needinfo?(jduell.mcbugs)
(Assignee)

Updated

10 months ago
Assignee: nobody → dd.mozilla
Flags: needinfo?(dd.mozilla)
(Assignee)

Comment 7

10 months ago
Attachment #8988864 - Flags: review?(daniel)
Duplicate of this bug: 1471594
Attachment #8988864 - Flags: review?(daniel) → review+

Updated

10 months ago
Flags: in-qa-testsuite?
Dragana, is this ready to land? And, if so, do you also want to request verification/uplift to beta? Thanks!
Flags: needinfo?(dd.mozilla)
(Assignee)

Updated

10 months ago
Flags: needinfo?(dd.mozilla)
Keywords: checkin-needed
(Assignee)

Comment 10

10 months ago
Comment on attachment 8988864 [details] [diff] [review]
bug_1467102.patch

Approval Request Comment
[Feature/Bug causing the regression]:  Bug 1436311
[User impact if declined]: hang
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: there is description hot to reproduce this bug in the Description.
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: it adds a missing variable nitialization.
[String changes made/needed]: none
Attachment #8988864 - Flags: approval-mozilla-beta?

Comment 12

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a36553625346
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63

Comment 13

10 months ago
Verified working on Nightly 20180711221812 on Ubuntu 18.04.

Updated

10 months ago
Duplicate of this bug: 1475171
Comment on attachment 8988864 [details] [diff] [review]
bug_1467102.patch

Verified in nightly, recent regression, let's uplift for beta 8.
Attachment #8988864 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I verified this on Ubuntu 16.04, Windows 10, Mac OS X 10.12 and I can't reproduce the issue with FF Nightly 63.0a1(2018-07-16) and Firefox Beta 62.0b9. Please note that this issue was reproducible on Nightly 63.0a1(2018-07-01)and Firefox Beta 62.0b8 on the same OSes. 
Based on the above information I will mark this as Verified Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: in-qa-testsuite? → in-qa-testsuite+

Updated

7 months ago
Flags: needinfo?(jduell.mcbugs)
You need to log in before you can comment on or make changes to this bug.