Closed Bug 1467108 Opened 2 years ago Closed Last year

Update harfbuzz to 1.8.1

Categories

(Core :: Graphics: Text, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: ionnv, Assigned: RyanVM)

References

Details

Attachments

(1 file)

https://cgit.freedesktop.org/harfbuzz/commit/?id=37986aa9b7ac44b1c4c50ebba9902d06cc8a45e0

Overview of changes leading to 1.8.0
Tuesday, June 5, 2018
====================================
- Update to Unicode 11.0.0.
Depends on: 1443812
My understanding is that this is a pretty massive update. What's the urgency on this from our end, Jonathan?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jfkthame)
Worth pointing out also that version 1.7.7 was also simultaneously released, which gives a bit better idea of the volume of changes.

Overview of changes leading to 1.7.7
Tuesday, June 5, 2018
====================================
- Lots of internal changes, but not yet exposed externally.
- All HarfBuzz objects are significantly smaller in size now.
- Sinhala: Position repha on top of post-consonant, not base.
  This better matches Windows 10 behavior, which was changed
  from previous Windows versions.
- New build options:
  o New cpp macro HB_NO_ATEXIT
  o New cpp macro HB_SUBSET_BUILTIN
- Significant libharfbuzz-subset changes. API subject to change.
- New API in libharfbuzz:

+hb_blob_create_from_file()
+hb_face_count()

A hashmap implementation:
+hb-map.h
+HB_MAP_VALUE_INVALID
+hb_map_t
+hb_map_create()
+hb_map_get_empty()
+hb_map_reference()
+hb_map_destroy()
+hb_map_set_user_data()
+hb_map_get_user_data()
+hb_map_allocation_successful()
+hb_map_clear()
+hb_map_is_empty()
+hb_map_get_population()
+hb_map_set()
+hb_map_get()
+hb_map_del()
+hb_map_has()
I've got a patch which builds, but layout/reftests/font-features/subsuper-fallback.html doesn't appear to be very happy about it.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=89e4d5a04bc4782fed3346b93e43cce9e5c85e6d
Hmm, that'll need investigating. I suspect something about hb_set has changed/broken.

In any case, I was going to suggest waiting until the new cycle; I don't think there's any reason to rush this in.
Flags: needinfo?(jfkthame)
This was indeed a bug in harfbuzz... actually there was a pre-existing bug, but minor internal changes happened to make it easier to hit, and one of our testcases stumbled across it. Filed as https://github.com/harfbuzz/harfbuzz/issues/1054, and now fixed upstream.

Re-trying your patch plus the upstream fix:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=fcc1aafcd869c9f396eb69a6ea13dd9e7edd1c7b
And now 1.8.1 is released. :)
Summary: Update harfbuzz to 1.8.0 → Update harfbuzz to 1.8.1
I'll revisit this bug after the Gecko 63 version bump with whatever the current version is by then.
Comment on attachment 8987948 [details] [diff] [review]
update harfbuzz to version 1.8.1

Review of attachment 8987948 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/harfbuzz/README-mozilla
@@ +10,5 @@
> +Note that harfbuzz.pc, harfbuzz-icu.pc, and harfbuzz-subset.pc are not present
> +in the upstream Git repository. They are created at build time by the HarfBuzz
> +build system. Since we don't use that build system in Mozilla, it is
> +necessary to refresh these files when updating HarfBuzz and check them into the
> +Mozilla tree.

Do we actually need the generated *.pc files for anything? (I don't think so... in which case we should be able to forget this mess and just import from the upstream release directly into our tree, now that src/hb-version.h is provided from upstream.)
Comment on attachment 8987948 [details] [diff] [review]
update harfbuzz to version 1.8.1

Review of attachment 8987948 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me;  feel free to simply drop the .pc files as discussed.
Attachment #8987948 - Flags: review?(jfkthame) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4af580347b1c
Update HarfBuzz to version 1.8.1. r=jfkthame
https://hg.mozilla.org/mozilla-central/rev/4af580347b1c
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Blocks: 1473064
You need to log in before you can comment on or make changes to this bug.